aboutsummaryrefslogtreecommitdiff
path: root/www/bookmarkbridge
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-26 15:23:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-26 15:23:02 +0000
commitd6f7ea6b3675a290679d9c6005815f4bbdc2a9b7 (patch)
treeedd8ad750da6cd028e8da07db32b049cbbe2b862 /www/bookmarkbridge
parent236c4bc9b16d8df6bc4d810cd23975fa37eb3e2b (diff)
downloadports-d6f7ea6b3675a290679d9c6005815f4bbdc2a9b7.tar.gz
ports-d6f7ea6b3675a290679d9c6005815f4bbdc2a9b7.zip
Notes
Diffstat (limited to 'www/bookmarkbridge')
-rw-r--r--www/bookmarkbridge/Makefile14
-rw-r--r--www/bookmarkbridge/distinfo6
-rw-r--r--www/bookmarkbridge/files/patch-configure.ac38
-rw-r--r--www/bookmarkbridge/pkg-plist55
4 files changed, 77 insertions, 36 deletions
diff --git a/www/bookmarkbridge/Makefile b/www/bookmarkbridge/Makefile
index 0d769b3a4edf..8175a8bedf5f 100644
--- a/www/bookmarkbridge/Makefile
+++ b/www/bookmarkbridge/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bookmarkbridge
-PORTVERSION= 0.72
-PORTREVISION= 2
+PORTVERSION= 0.76
CATEGORIES= www
MASTER_SITES= SF
@@ -16,12 +15,13 @@ COMMENT= Synchronize bookmarks between multiple browsers
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
-USE_PERL5_BUILD=yes
+USE_PERL5_BUILD= yes
USE_XORG= x11 ice xext
-USE_QT_VER= 3
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui moc_build rcc_build uic_build qt3support
+USE_GNOME= gnometarget libxml2
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-mt --program-prefix="" \
- --with-libxml2-include="${LOCALBASE}/include/libxml2"
+USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:261
+ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
.include <bsd.port.mk>
diff --git a/www/bookmarkbridge/distinfo b/www/bookmarkbridge/distinfo
index 3d94fdb8bd4c..92372a53e7b4 100644
--- a/www/bookmarkbridge/distinfo
+++ b/www/bookmarkbridge/distinfo
@@ -1,3 +1,3 @@
-MD5 (bookmarkbridge-0.72.tar.gz) = cb603840da057be62d5d982a8be947d9
-SHA256 (bookmarkbridge-0.72.tar.gz) = a29c9922b4239b5f793f5c8c89a06559587d77bc68b28df35faa35eb6e562ec2
-SIZE (bookmarkbridge-0.72.tar.gz) = 779363
+MD5 (bookmarkbridge-0.76.tar.gz) = facaeadea681be5a775b1c1623b7a339
+SHA256 (bookmarkbridge-0.76.tar.gz) = c8cda442fee64b3f6a49ba42d289eea08c97ba08d5f4ccd324be87a431b93fc3
+SIZE (bookmarkbridge-0.76.tar.gz) = 309224
diff --git a/www/bookmarkbridge/files/patch-configure.ac b/www/bookmarkbridge/files/patch-configure.ac
new file mode 100644
index 000000000000..be00b21616ca
--- /dev/null
+++ b/www/bookmarkbridge/files/patch-configure.ac
@@ -0,0 +1,38 @@
+--- configure.ac.orig Thu Mar 30 11:04:26 2006
++++ configure.ac Wed Dec 26 22:24:30 2007
+@@ -4,7 +4,7 @@
+
+ AC_PROG_CXX
+
+-PKG_CHECK_MODULES(QT, QtGui >= 4.0.1)
++PKG_CHECK_MODULES(QT, QtCore QtGui >= 4.0.1)
+
+ dnl Check needed because in some cases the QtGui includedir
+ dnl doesn't contain the subsystems dir
+@@ -23,22 +23,11 @@
+ AC_CHECK_PROG(RCC, [rcc], [rcc])
+ AC_CHECK_PROG(PERL, [perl], [perl])
+
+-dnl Specify libxml2 include path
+-AC_ARG_WITH(libxml2-include,
+- [ --with-libxml2-include=path
+- specify libxml2 include path
+- (default is /usr/include/libxml2) ],
+- [ libxml_includes="-I$withval" ],
+- [ libxml_includes="-I/usr/include/libxml2"])
+-CXXFLAGS="$CXXFLAGS $libxml_includes"
+-AC_SUBST(CXXFLAGS)
++dnl Check for libxml2
++PKG_CHECK_MODULES(LIBXML2, [libxml-2.0])
+
+-AC_CHECK_LIB(xml2, xmlNewParserCtxt, [], [
+- "You must have the libxml2 development files installed"
+- exit -1
+- ])
+-
+-QT_CFLAGS="$QT_CFLAGS $libxml_includes -DDATADIR='\"$datadir\"'"
++QT_CFLAGS="$QT_CFLAGS $LIBXML2_CFLAGS -DDATADIR='\"$datadir\"'"
++QT_LIBS="$QT_LIBS $LIBXML2_LIBS"
+
+ AC_SUBST(QT_CFLAGS)
+ AC_SUBST(QT_LIBS)
diff --git a/www/bookmarkbridge/pkg-plist b/www/bookmarkbridge/pkg-plist
index 02c67c93a82f..b1b3420326e6 100644
--- a/www/bookmarkbridge/pkg-plist
+++ b/www/bookmarkbridge/pkg-plist
@@ -1,27 +1,30 @@
bin/bookmarkbridge
-share/bookmarkbridge/about_bookmarkbridge.html
-share/bookmarkbridge/bookmarkbridge_settings.html
-share/bookmarkbridge/bookmarkbridgelogosmall.png
-share/bookmarkbridge/bookmarkbridges_web_sites.html
-share/bookmarkbridge/command_line_operation.html
-share/bookmarkbridge/compiling_bookmarkbridge_from_source.html
-share/bookmarkbridge/configuration_files.html
-share/bookmarkbridge/end_user_license_agreement.html
-share/bookmarkbridge/hacking_bookmarkbridge_source.html
-share/bookmarkbridge/index.html
-share/bookmarkbridge/installing_bookmarkbridge.html
-share/bookmarkbridge/main_screen.png
-share/bookmarkbridge/merging_your_bookmarks.html
-share/bookmarkbridge/obtaining_help.html
-share/bookmarkbridge/online_help.html
-share/bookmarkbridge/running_bookmarkbridge_for_the_first_time.html
-share/bookmarkbridge/settings_screen.png
-share/bookmarkbridge/source_code_roadmap.html
-share/bookmarkbridge/system_requirements.html
-share/bookmarkbridge/the_main_window.html
-share/bookmarkbridge/theory_of_operation.html
-share/bookmarkbridge/view_bookmarks.png
-share/bookmarkbridge/viewing_your_bookmarks.html
-share/bookmarkbridge/where_to_find_bookmarkbridge.html
-share/bookmarkbridge/why_bookmarkbridge_is_free.html
-@dirrm share/bookmarkbridge
+%%DATADIR%%/about_bookmarkbridge.html
+%%DATADIR%%/autodocs.pl
+%%DATADIR%%/bookmarkbridge_settings.html
+%%DATADIR%%/bookmarkbridgelogo.png
+%%DATADIR%%/bookmarkbridgelogosmall.png
+%%DATADIR%%/bookmarkbridges_web_sites.html
+%%DATADIR%%/command_line_operation.html
+%%DATADIR%%/compiling_bookmarkbridge_from_source.html
+%%DATADIR%%/configuration_files.html
+%%DATADIR%%/end_user_license_agreement.html
+%%DATADIR%%/hacking_bookmarkbridge_source.html
+%%DATADIR%%/index.html
+%%DATADIR%%/installing_bookmarkbridge.html
+%%DATADIR%%/main_screen.png
+%%DATADIR%%/merging_your_bookmarks.html
+%%DATADIR%%/obtaining_help.html
+%%DATADIR%%/online_help.html
+%%DATADIR%%/osi-certified-72x60.png
+%%DATADIR%%/running_bookmarkbridge_for_the_first_time.html
+%%DATADIR%%/settings_screen.png
+%%DATADIR%%/source_code_roadmap.html
+%%DATADIR%%/system_requirements.html
+%%DATADIR%%/the_main_window.html
+%%DATADIR%%/theory_of_operation.html
+%%DATADIR%%/view_bookmarks.png
+%%DATADIR%%/viewing_your_bookmarks.html
+%%DATADIR%%/where_to_find_bookmarkbridge.html
+%%DATADIR%%/why_bookmarkbridge_is_free.html
+@dirrm %%DATADIR%%