aboutsummaryrefslogtreecommitdiff
path: root/www/bozohttpd
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-01-24 23:29:53 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-01-24 23:29:53 +0000
commit7bfc8d0f6859b639383185f3c7fcd57140ed8ede (patch)
treed5c03736d07144926fd257ebfba90e3424770beb /www/bozohttpd
parentc5f8b48b3d99d4e92473aa89bd4722b0f2f3998d (diff)
downloadports-7bfc8d0f6859b639383185f3c7fcd57140ed8ede.tar.gz
ports-7bfc8d0f6859b639383185f3c7fcd57140ed8ede.zip
Notes
Diffstat (limited to 'www/bozohttpd')
-rw-r--r--www/bozohttpd/Makefile2
-rw-r--r--www/bozohttpd/files/bozohttpd.in30
2 files changed, 32 insertions, 0 deletions
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index 296c6c5e23c8..e4f45f2fac4b 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bozohttpd
PORTVERSION= 20060517
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.eterna.com.au/bozohttpd/ \
${MASTER_SITE_NETBSD}
@@ -15,6 +16,7 @@ MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= The bozotic HTTP server
USE_BZIP2= YES
+USE_RC_SUBR= bozohttpd
.if defined(WITH_HTPASSWD_SUPPORT)
CFLAGS+= -DDO_HTPASSWD
diff --git a/www/bozohttpd/files/bozohttpd.in b/www/bozohttpd/files/bozohttpd.in
new file mode 100644
index 000000000000..4a5be1fdcb2b
--- /dev/null
+++ b/www/bozohttpd/files/bozohttpd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: bozohttpd
+# REQUIRE: DAEMON
+#
+#
+# Add the following lines to /etc/rc.conf to enable bozohttpd:
+#
+# bozohttpd_enable (bool): Set it to "YES" to enable bozohttpd.
+# Default is "NO".
+# bozohttpd_flags (str): Options to pass to bozohttpd.
+# Default is "-b -t /var/empty -U nobody /".
+# The last argument, slashdir, is required.
+#
+
+. %%RC_SUBR%%
+
+name="bozohttpd"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${bozohttpd_enable="NO"}
+: ${bozohttpd_flags="-b -t /var/empty -U nobody /"}
+
+command=%%PREFIX%%/libexec/${name}
+
+run_rc_command "$1"