aboutsummaryrefslogtreecommitdiff
path: root/www/c-icap-modules
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2016-01-03 23:48:43 +0000
committerMartin Matuska <mm@FreeBSD.org>2016-01-03 23:48:43 +0000
commitea175671f86f00d77a479139c3b07f8137ed3e97 (patch)
treed7ab50649de0ce95ef4da33646ce04e92149684d /www/c-icap-modules
parent6bdccc5cda4f580d42f6b560f32139dcc1eb5450 (diff)
downloadports-ea175671f86f00d77a479139c3b07f8137ed3e97.tar.gz
ports-ea175671f86f00d77a479139c3b07f8137ed3e97.zip
Notes
Diffstat (limited to 'www/c-icap-modules')
-rw-r--r--www/c-icap-modules/Makefile7
-rw-r--r--www/c-icap-modules/distinfo4
-rw-r--r--www/c-icap-modules/files/patch-services_content__filtering_Makefile.in10
-rw-r--r--www/c-icap-modules/files/patch-services_url__check_Makefile.in (renamed from www/c-icap-modules/files/patch-services__url_check__Makefile.in)6
-rw-r--r--www/c-icap-modules/files/patch-services_virus__scan_Makefile.in (renamed from www/c-icap-modules/files/patch-services__virus_scan__Makefile.in)6
-rw-r--r--www/c-icap-modules/pkg-plist6
6 files changed, 27 insertions, 12 deletions
diff --git a/www/c-icap-modules/Makefile b/www/c-icap-modules/Makefile
index e56b22cdf374..6eae15ca41fa 100644
--- a/www/c-icap-modules/Makefile
+++ b/www/c-icap-modules/Makefile
@@ -2,15 +2,14 @@
# $FreeBSD$
PORTNAME= c-icap
-PORTVERSION= 0.3.2
-PORTREVISION= 5
+PORTVERSION= 0.4.2
CATEGORIES= www security
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/0.3.x/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/0.4.x/
PKGNAMESUFFIX= -modules
DISTNAME= c_icap_modules-${PORTVERSION}
MAINTAINER= mm@FreeBSD.org
-COMMENT= c-icap modules virus_scan and srv_url_check
+COMMENT= Modules for c-icap: virus_scan and srv_url_check
LICENSE= GPLv2
diff --git a/www/c-icap-modules/distinfo b/www/c-icap-modules/distinfo
index 1703ce8ec926..a9173e39fe5f 100644
--- a/www/c-icap-modules/distinfo
+++ b/www/c-icap-modules/distinfo
@@ -1,2 +1,2 @@
-SHA256 (c_icap_modules-0.3.2.tar.gz) = e3472662687cf9fa37a496df31436924326e315920056a404f023ec5e852e239
-SIZE (c_icap_modules-0.3.2.tar.gz) = 384788
+SHA256 (c_icap_modules-0.4.2.tar.gz) = f7da6064550c842c13ffab36dd53f1427029a2e362bcf3a0375d99be469f4e29
+SIZE (c_icap_modules-0.4.2.tar.gz) = 428877
diff --git a/www/c-icap-modules/files/patch-services_content__filtering_Makefile.in b/www/c-icap-modules/files/patch-services_content__filtering_Makefile.in
new file mode 100644
index 000000000000..ee3898aeb746
--- /dev/null
+++ b/www/c-icap-modules/files/patch-services_content__filtering_Makefile.in
@@ -0,0 +1,10 @@
+--- services/content_filtering/Makefile.in.orig 2016-01-03 23:26:06 UTC26:06 UTC
++++ services/content_filtering/Makefile.in
+@@ -691,7 +691,6 @@
+
+ install-data-local:
+ $(INSTALL) srv_content_filtering.conf.default $(DESTDIR)$(CONFIGDIR)/srv_content_filtering.conf.default
+- if test ! -f $(DESTDIR)$(CONFIGDIR)/srv_content_filtering.conf.default; then $(INSTALL) srv_content_filtering.conf.default $(DESTDIR)$(CONFIGDIR)/srv_content_filtering.conf; fi
+ $(mkinstalldirs) $(DESTDIR)$(cicapdatadir)/templates/srv_content_filtering/en
+ $(INSTALL) $(TMPLS) $(DESTDIR)$(cicapdatadir)/templates/srv_content_filtering/en/
+
diff --git a/www/c-icap-modules/files/patch-services__url_check__Makefile.in b/www/c-icap-modules/files/patch-services_url__check_Makefile.in
index a86c1627dfcc..cfdc1b350558 100644
--- a/www/c-icap-modules/files/patch-services__url_check__Makefile.in
+++ b/www/c-icap-modules/files/patch-services_url__check_Makefile.in
@@ -1,6 +1,6 @@
---- services/url_check/Makefile.in.orig 2014-05-14 16:56:34.000000000 -0300
-+++ services/url_check/Makefile.in 2014-05-14 16:56:46.000000000 -0300
-@@ -731,7 +731,6 @@
+--- services/url_check/Makefile.in.orig 2016-01-03 23:26:26 UTC
++++ services/url_check/Makefile.in
+@@ -843,7 +843,6 @@
install-data-local:
$(INSTALL) srv_url_check.conf $(DESTDIR)$(CONFIGDIR)/srv_url_check.conf.default
diff --git a/www/c-icap-modules/files/patch-services__virus_scan__Makefile.in b/www/c-icap-modules/files/patch-services_virus__scan_Makefile.in
index 4268eebd87b7..16b36cbb58f6 100644
--- a/www/c-icap-modules/files/patch-services__virus_scan__Makefile.in
+++ b/www/c-icap-modules/files/patch-services_virus__scan_Makefile.in
@@ -1,6 +1,6 @@
---- services/virus_scan/Makefile.in.orig 2014-05-14 16:54:38.000000000 -0300
-+++ services/virus_scan/Makefile.in 2014-05-14 16:54:56.000000000 -0300
-@@ -647,7 +647,6 @@
+--- services/virus_scan/Makefile.in.orig 2016-01-03 23:26:16 UTC
++++ services/virus_scan/Makefile.in
+@@ -750,7 +750,6 @@
install-data-local:
for f in $(CONFS); do \
$(INSTALL) $$f $(DESTDIR)$(CONFIGDIR)/$$f.default; \
diff --git a/www/c-icap-modules/pkg-plist b/www/c-icap-modules/pkg-plist
index 778684d1c36c..08a222d73381 100644
--- a/www/c-icap-modules/pkg-plist
+++ b/www/c-icap-modules/pkg-plist
@@ -4,6 +4,9 @@ etc/c-icap/clamav_mod.conf.default
@unexec if cmp -s %D/etc/c-icap/clamd_mod.conf %D/etc/c-icap/clamd_mod.conf.default; then rm -f %D/etc/c-icap/clamd_mod.conf; fi
etc/c-icap/clamd_mod.conf.default
@exec [ -f %B/clamd_mod.conf ] || cp %B/%f %B/clamd_mod.conf
+@unexec if cmp -s %D/etc/c-icap/srv_content_filtering.conf %D/etc/c-icap/srv_content_filtering.conf.default; then rm -f %D/etc/c-icap/srv_content_filtering.conf; fi
+etc/c-icap/srv_content_filtering.conf.default
+@exec [ -f %B/srv_url_check.conf ] || cp %B/%f %B/srv_url_check.conf
@unexec if cmp -s %D/etc/c-icap/srv_url_check.conf %D/etc/c-icap/srv_url_check.conf.default; then rm -f %D/etc/c-icap/srv_url_check.conf; fi
etc/c-icap/srv_url_check.conf.default
@exec [ -f %B/srv_url_check.conf ] || cp %B/%f %B/srv_url_check.conf
@@ -14,11 +17,14 @@ lib/c_icap/clamav_mod.a
lib/c_icap/clamav_mod.so
lib/c_icap/clamd_mod.a
lib/c_icap/clamd_mod.so
+lib/c_icap/srv_content_filtering.a
+lib/c_icap/srv_content_filtering.so
lib/c_icap/srv_url_check.a
lib/c_icap/srv_url_check.so
lib/c_icap/virus_scan.a
lib/c_icap/virus_scan.so
man/man8/c-icap-mods-sguardDB.8.gz
+%%DATADIR%%/templates/srv_content_filtering/en/BLOCK
%%DATADIR%%/templates/srv_url_check/en/DENY
%%DATADIR%%/templates/virus_scan/en/VIR_MODE_HEAD
%%DATADIR%%/templates/virus_scan/en/VIR_MODE_PROGRESS