aboutsummaryrefslogtreecommitdiff
path: root/www/c-icap-modules
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-08-15 01:19:53 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-08-15 01:19:53 +0000
commit5ffb242c015bc9ce2fe260470b98465595ebf3b8 (patch)
treeed4094cc4dba7bd672fdbd77e3c86700c333a8b7 /www/c-icap-modules
parentf9b6bb72bd478b12951f554e3e87ee3a3ad40716 (diff)
downloadports-5ffb242c015bc9ce2fe260470b98465595ebf3b8.tar.gz
ports-5ffb242c015bc9ce2fe260470b98465595ebf3b8.zip
Notes
Diffstat (limited to 'www/c-icap-modules')
-rw-r--r--www/c-icap-modules/Makefile41
-rw-r--r--www/c-icap-modules/distinfo2
-rw-r--r--www/c-icap-modules/pkg-descr10
-rw-r--r--www/c-icap-modules/pkg-plist24
4 files changed, 77 insertions, 0 deletions
diff --git a/www/c-icap-modules/Makefile b/www/c-icap-modules/Makefile
new file mode 100644
index 000000000000..771a9a8f1819
--- /dev/null
+++ b/www/c-icap-modules/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: c-icap-modules
+# Date created: 15 August 2012
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD: ports/www/c-icap/Makefile,v 1.22 2011/09/23 22:25:54 amdmi3 Exp $
+#
+
+PORTNAME= c-icap
+PORTVERSION= 0.2.1
+CATEGORIES= www
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/0.2.x/
+DISTNAME= c_icap_modules-${PORTVERSION}
+PKGNAMESUFFIX= -modules
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= c-icap modules virus_scan and srv_url_check
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS+= icapapi:${PORTSDIR}/www/c-icap \
+ clamav:${PORTSDIR}/security/clamav
+
+GNU_CONFIGURE= yes
+DATADIR= ${PREFIX}/share/c_icap
+
+CFLAGS+= -DHAVE_STRNSTR
+
+MAN8= c-icap-mods-sguardDB.8
+
+CONFIGURE_ARGS+= --enable-static \
+ --with-c-icap=${LOCALBASE} \
+ --with-clamav=${LOCALBASE}
+
+post-install:
+ @${CP} -np ${PREFIX}/etc/c-icap/srv_url_check.conf.default \
+ ${PREFIX}/etc/c-icap/srv_url_check.conf
+ @${CP} -np ${PREFIX}/etc/c-icap/virus_scan.conf.default \
+ ${PREFIX}/etc/c-icap/virus_scan.conf
+
+.include <bsd.port.mk>
diff --git a/www/c-icap-modules/distinfo b/www/c-icap-modules/distinfo
new file mode 100644
index 000000000000..d6a4b3e3f1a1
--- /dev/null
+++ b/www/c-icap-modules/distinfo
@@ -0,0 +1,2 @@
+SHA256 (c_icap_modules-0.2.1.tar.gz) = e081e7a6584611b101580f7fbd3ae7540a6d9ef53a59efb377c5afd5c41d0c21
+SIZE (c_icap_modules-0.2.1.tar.gz) = 348245
diff --git a/www/c-icap-modules/pkg-descr b/www/c-icap-modules/pkg-descr
new file mode 100644
index 000000000000..b157f42aa6d1
--- /dev/null
+++ b/www/c-icap-modules/pkg-descr
@@ -0,0 +1,10 @@
+c-icap server modules:
+
+virus_scan:
+This is an antivirus service which uses the open source
+clamav antivirus.
+
+srv_url_check:
+This is an URL blacklist/whitelist icap service
+
+WWW: http://c-icap.sourceforge.net/
diff --git a/www/c-icap-modules/pkg-plist b/www/c-icap-modules/pkg-plist
new file mode 100644
index 000000000000..561bf7323941
--- /dev/null
+++ b/www/c-icap-modules/pkg-plist
@@ -0,0 +1,24 @@
+@unexec if cmp -s %D/etc/c-icap/srv_url_check.conf %D/etc/c-icap/srv_url_check.conf.default; then rm -f %D/etc/c-icap/srv_url_check.conf; fi
+etc/c-icap/srv_url_check.conf.default
+@exec [ -f %B/srv_url_check.conf ] || cp %B/%f %B/srv_url_check.conf
+@unexec if cmp -s %D/etc/c-icap/virus_scan.conf %D/etc/c-icap/virus_scan.conf.default; then rm -f %D/etc/c-icap/virus_scan.conf; fi
+etc/c-icap/virus_scan.conf.default
+@exec [ -f %B/virus_scan.conf ] || cp %B/%f %B/virus_scan.conf
+lib/c_icap/srv_url_check.a
+lib/c_icap/srv_url_check.la
+lib/c_icap/srv_url_check.so
+lib/c_icap/virus_scan.a
+lib/c_icap/virus_scan.la
+lib/c_icap/virus_scan.so
+%%DATADIR%%/templates/srv_url_check/en/DENY
+%%DATADIR%%/templates/virus_scan/en/VIR_MODE_HEAD
+%%DATADIR%%/templates/virus_scan/en/VIR_MODE_PROGRESS
+%%DATADIR%%/templates/virus_scan/en/VIR_MODE_TAIL
+%%DATADIR%%/templates/virus_scan/en/VIR_MODE_VIRUS_FOUND
+%%DATADIR%%/templates/virus_scan/en/VIRUS_FOUND
+@dirrm %%DATADIR%%/templates/srv_url_check/en
+@dirrm %%DATADIR%%/templates/srv_url_check
+@dirrm %%DATADIR%%/templates/virus_scan/en
+@dirrm %%DATADIR%%/templates/virus_scan
+@dirrmtry %%DATADIR%%/templates
+@dirrmtry %%DATADIR%%