aboutsummaryrefslogtreecommitdiff
path: root/www/c-icap
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-02-14 13:28:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-02-14 13:28:56 +0000
commit120b5d04c494a1cdea11269d813f7df75ff957b8 (patch)
treea3f7bf67b0f64d4d5ffe555183448747b00543fd /www/c-icap
parentc7847c9f2e89d7724fdcaca4fa2c113b4d99a382 (diff)
downloadports-120b5d04c494a1cdea11269d813f7df75ff957b8.tar.gz
ports-120b5d04c494a1cdea11269d813f7df75ff957b8.zip
Notes
Diffstat (limited to 'www/c-icap')
-rw-r--r--www/c-icap/Makefile6
-rw-r--r--www/c-icap/files/patch-services_clamav_srv_clamav.c35
2 files changed, 36 insertions, 5 deletions
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index deb4e933702d..1b1abf7c16bd 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= c_icap-${PORTVERSION}rc1
-MAINTAINER= b3k@mail.ru
+MAINTAINER= tofig@freebsd.az
COMMENT= An implementation of an ICAP server
GNU_CONFIGURE= yes
@@ -31,10 +31,6 @@ OPTIONS= CLAMAV "Build with srv_clamav service" on \
IPV6 "Enable IPv6 support" off
# PERL "With Perl support" off
-BROKEN= Doesn't build with clamav-0.93 or higher
-DEPRECATED= has been broken for more than 6 months
-EXPIRATION_DATE=2009-01-19
-
.include <bsd.port.pre.mk>
# Perl support not ready yet. Try to contact author or hack it by yourself.
diff --git a/www/c-icap/files/patch-services_clamav_srv_clamav.c b/www/c-icap/files/patch-services_clamav_srv_clamav.c
new file mode 100644
index 000000000000..fe918b65a600
--- /dev/null
+++ b/www/c-icap/files/patch-services_clamav_srv_clamav.c
@@ -0,0 +1,35 @@
+diff -ruN work/c_icap-030606rc1/services/clamav/srv_clamav.c work.patched/c_icap-030606rc1/services/clamav/srv_clamav.c
+--- services/clamav/srv_clamav.c 2006-06-06 22:08:13.000000000 +0500
++++ services/clamav/srv_clamav.c 2009-02-13 11:33:57.000000000 +0400
+@@ -137,17 +137,18 @@
+
+
+ int srvclamav_init_service(service_module_t *this,struct icap_server_conf *server_conf){
+- int ret,no=0,i;
++ int ret,i;
++ unsigned int no = 0;
++ unsigned int options = 0;
++ options = options | CL_DB_STDOPT;
+ magic_db=server_conf->MAGIC_DB;
+ scantypes=(int *)malloc(ci_magic_types_num(magic_db)*sizeof(int));
+ scangroups=(int *)malloc(ci_magic_groups_num(magic_db)*sizeof(int));
+
+ for(i=0;i<ci_magic_types_num(magic_db);i++) scantypes[i]=0;
+ for(i=0;i<ci_magic_groups_num(magic_db);i++) scangroups[i]=0;
+-
+-
+ ci_debug_printf(10,"Going to initialize srvclamav\n");;
+- if((ret = cl_loaddbdir(cl_retdbdir(), &root, &no))) {
++ if((ret = cl_load(cl_retdbdir(), &root, &no, options))) {
+ ci_debug_printf(1,"cl_loaddbdir: %s\n", cl_perror(ret));
+ return 0;
+ }
+@@ -161,7 +162,7 @@
+ limits.maxfiles = 0/*1000*/; /* max files */
+ limits.maxfilesize = 100 * 1048576; /* maximal archived file size == 100 Mb */
+ limits.maxreclevel = 5; /* maximal recursion level */
+- limits.maxratio = 200; /* maximal compression ratio */
++ //limits.maxratio = 200; /* maximal compression ratio */
+ limits.archivememlim = 0; /* disable memory limit for bzip2 scanner */
+ return 1;
+ }