aboutsummaryrefslogtreecommitdiff
path: root/www/c-icap
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-03-15 03:07:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-03-15 03:07:11 +0000
commitf0bf71343cbd98c2c24efab779de45b0f0a133c6 (patch)
treede0ee0b1681621668a2c5140949b755a460a8cef /www/c-icap
parent883dfd622630ce8daeccf22a663ef8a8fcf3bd17 (diff)
Notes
Diffstat (limited to 'www/c-icap')
-rw-r--r--www/c-icap/Makefile19
-rw-r--r--www/c-icap/distinfo4
-rw-r--r--www/c-icap/pkg-plist4
3 files changed, 15 insertions, 12 deletions
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index a5ac417153bc..7d1fa2fd15c7 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= c-icap
-PORTVERSION= 0.2.5
+PORTVERSION= 0.3.3
PORTEPOCH= 2
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.2.x/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.3.x/
DISTNAME= c_icap-${PORTVERSION}
MAINTAINER= mm@FreeBSD.org
@@ -25,7 +25,9 @@ LARGE_FILES_DESC= Enable large files support
POSIXSEM_DESC= Use POSIX Semaphores instead of SYSV IPC
CICAP_USER= c_icap
+CICAP_UID= 959
CICAP_GROUP= c_icap
+CICAP_GID= 959
USERS= ${CICAP_USER}
GROUPS= ${CICAP_GROUP}
@@ -38,9 +40,9 @@ MAN8= c-icap-client.8 \
c-icap.8
CONFIGURE_ARGS+= --enable-static \
- --sysconfdir="${PREFIX}/etc/c-icap"
+ --sysconfdir="${PREFIX}/etc/c-icap" \
+ --localstatedir=/var
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBDB}
@@ -118,10 +120,9 @@ post-patch:
.endif
post-install:
- @${CP} -np ${PREFIX}/etc/c-icap/c-icap.conf.default \
- ${PREFIX}/etc/c-icap/c-icap.conf || ${TRUE}
- @${CP} -np ${PREFIX}/etc/c-icap/c-icap.magic.default \
- ${PREFIX}/etc/c-icap/c-icap.magic || ${TRUE}
- @${SH} ${PKGINSTALL} ${PREFIX} POST-INSTALL
+ @${CP} -np ${STAGEDIR}${PREFIX}/etc/c-icap/c-icap.conf.default \
+ ${STAGEDIR}${PREFIX}/etc/c-icap/c-icap.conf || ${TRUE}
+ @${CP} -np ${STAGEDIR}${PREFIX}/etc/c-icap/c-icap.magic.default \
+ ${STAGEDIR}${PREFIX}/etc/c-icap/c-icap.magic || ${TRUE}
.include <bsd.port.post.mk>
diff --git a/www/c-icap/distinfo b/www/c-icap/distinfo
index e4458468ad4e..b1c6a2ac0b81 100644
--- a/www/c-icap/distinfo
+++ b/www/c-icap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (c_icap-0.2.5.tar.gz) = 125f002f6e2bc70c1d07b2b44ae0d17ee83b9760f4cbe3527865deecdaf877b8
-SIZE (c_icap-0.2.5.tar.gz) = 582223
+SHA256 (c_icap-0.3.3.tar.gz) = 9fc0d7166e65b748138b750f1cba27933aab6ac201fbe2279ab9d7a9c24c7131
+SIZE (c_icap-0.3.3.tar.gz) = 600209
diff --git a/www/c-icap/pkg-plist b/www/c-icap/pkg-plist
index 8a245f5a5df1..9f3accc05a85 100644
--- a/www/c-icap/pkg-plist
+++ b/www/c-icap/pkg-plist
@@ -27,11 +27,13 @@ include/c_icap/hash.h
include/c_icap/header.h
include/c_icap/log.h
include/c_icap/lookup_table.h
+include/c_icap/md5.h
include/c_icap/mem.h
include/c_icap/module.h
include/c_icap/net_io.h
include/c_icap/proc_mutex.h
include/c_icap/proc_threads_queues.h
+include/c_icap/registry.h
include/c_icap/request.h
include/c_icap/service.h
include/c_icap/shared_mem.h
@@ -65,6 +67,6 @@ lib/c_icap/sys_logger.la
lib/c_icap/sys_logger.so
@dirrm lib/c_icap
lib/libicapapi.la
-lib/libicapapi.so.2
+lib/libicapapi.so.3
lib/libicapapi.so
@dirrmtry etc/c-icap