aboutsummaryrefslogtreecommitdiff
path: root/www/c-icap
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-05-04 22:48:03 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-05-04 22:48:03 +0000
commit5ac18767d1594a7c77ba505b9672eb4e3b5284bc (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /www/c-icap
parentb3db8883de118166da92dad3b8b07b17378c911c (diff)
downloadports-5ac18767d1594a7c77ba505b9672eb4e3b5284bc.tar.gz
ports-5ac18767d1594a7c77ba505b9672eb4e3b5284bc.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=317389
Diffstat (limited to 'www/c-icap')
-rw-r--r--www/c-icap/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index b0c6d0dfd67f..c92f614b6376 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: c-icap
-# Date created: 30 January 2006
-# Whom: Elisey Savateev <b3k@mail.ru>
-#
+# Created by: Elisey Savateev <b3k@mail.ru>
# $FreeBSD$
-#
PORTNAME= c-icap
PORTVERSION= 0.2.3
@@ -122,9 +118,9 @@ post-patch:
post-install:
@${CP} -np ${PREFIX}/etc/c-icap/c-icap.conf.default \
- ${PREFIX}/etc/c-icap/c-icap.conf
+ ${PREFIX}/etc/c-icap/c-icap.conf || ${TRUE}
@${CP} -np ${PREFIX}/etc/c-icap/c-icap.magic.default \
- ${PREFIX}/etc/c-icap/c-icap.magic
+ ${PREFIX}/etc/c-icap/c-icap.magic || ${TRUE}
@${SH} ${PKGINSTALL} ${PREFIX} POST-INSTALL
.include <bsd.port.post.mk>