aboutsummaryrefslogtreecommitdiff
path: root/www/cadaver
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-06-17 19:20:04 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-06-17 19:20:04 +0000
commit717b616e93e7555d4a106c9390bf436550a66422 (patch)
tree8f223acc7631f8e48cd4a513ef13f0c1914a575c /www/cadaver
parentb24ff540ad404d2e797d75b215d4f240b78c1e89 (diff)
downloadports-717b616e93e7555d4a106c9390bf436550a66422.tar.gz
ports-717b616e93e7555d4a106c9390bf436550a66422.zip
Notes
Diffstat (limited to 'www/cadaver')
-rw-r--r--www/cadaver/Makefile8
-rw-r--r--www/cadaver/files/patch-aa14
2 files changed, 13 insertions, 9 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 22e61f422e93..3b17b73eac7b 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -12,10 +12,7 @@ MASTER_SITES= http://www.webdav.org/cadaver/
MAINTAINER= ports@FreeBSD.org
-BROKEN= "Does not compile"
-
-LIB_DEPENDS= neon.19:${PORTSDIR}/www/neon \
- intl.2:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
.ifndef NO_OPENSSL
USE_OPENSSL= yes
@@ -25,7 +22,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE} \
--enable-netrc \
- --with-neon=${LOCALBASE}
+ --with-included-neon \
+ --with-included-expat
ALL_TARGET= cadaver
post-install:
diff --git a/www/cadaver/files/patch-aa b/www/cadaver/files/patch-aa
index 722e6cd9d638..10f3531ebe66 100644
--- a/www/cadaver/files/patch-aa
+++ b/www/cadaver/files/patch-aa
@@ -1,6 +1,8 @@
---- Makefile.in.orig Mon Jan 14 12:01:27 2002
-+++ Makefile.in Sat May 11 02:48:50 2002
-@@ -29,7 +29,7 @@
+$FreeBSD$
+
+--- Makefile.in.orig Mon Jun 17 12:02:32 2002
++++ Makefile.in Mon Jun 17 12:04:36 2002
+@@ -29,10 +29,10 @@
# Toolchain settings.
CC = @CC@
@@ -8,4 +10,8 @@
+CPPFLAGS = @DEFS@ @CPPFLAGS@ -I$(top_srcdir)/src -I${top_srcdir}/libneon
CFLAGS = @CFLAGS@ @SDEFS@
LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@ @NEON_LIBS@
+-LIBS = @LIBS@ @NEON_LIBS@
++LIBS = @NEON_LIBS@ @LIBS@
+
+ TARGET = $(PACKAGE)
+ SUBDIRS = libneon @SUBDIRS@