aboutsummaryrefslogtreecommitdiff
path: root/www/cadaver
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-02-07 17:14:35 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-02-07 17:14:35 +0000
commitcebee858d6f3e0f64976a0e8918e2353fc3250f3 (patch)
tree17171ef24ba1f9279e48a1263c5a78252036b682 /www/cadaver
parentf353783dfa5a8aedc58d2316a0bad9c8e4823c0e (diff)
downloadports-cebee858d6f3e0f64976a0e8918e2353fc3250f3.tar.gz
ports-cebee858d6f3e0f64976a0e8918e2353fc3250f3.zip
Notes
Diffstat (limited to 'www/cadaver')
-rw-r--r--www/cadaver/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 56ba188acc22..f6e24009e8af 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cadaver
PORTVERSION= 0.22.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/cadaver/ \
http://www.tcbug.org/
@@ -18,8 +19,6 @@ COMMENT= Commandline client for DAV
LIB_DEPENDS= neon.25:${PORTSDIR}/www/neon
-BROKEN= Does not compile
-
USE_GPG?= yes
SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.asc
USE_GETOPT_LONG= yes
@@ -31,13 +30,15 @@ ALL_TARGET= cadaver
MAN1= cadaver.1
PLIST_FILES= bin/cadaver
+
# Neither expat nor libneon are needed at all, but the configure
# script breaks if it can not find the Makefile* in them. Exclude
# them to be sure, a stray .h is not included instead of what's
# found under PREFIX (installed by the neon port):
EXTRACT_AFTER_ARGS= | ${TAR} -xf - \
- --exclude '${PORTNAME}-${PORTVERSION}/expat/*.[ch]' \
- --exclude '${PORTNAME}-${PORTVERSION}/libneon/*.[ch]'
+ --exclude '${PORTNAME}-${PORTVERSION}/lib/expat/*.[ch]' \
+ --exclude '${PORTNAME}-${PORTVERSION}/lib/intl/*.[ch]' \
+ --exclude '${PORTNAME}-${PORTVERSION}/lib/neon/*.[ch]'
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -47,4 +48,19 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl --with-force-ssl
.endif
+.if !defined(WITHOUT_NLS)
+USE_ICONV= yes
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+LANGS=en@quot es it
+.for lang in ${LANGS}
+PLIST_FILES+= share/locale/${lang}/LC_MESSAGES/cadaver.mo
+.endfor
+.else
+CONFIGURE_ARGS+=--disable-nls \
+ --without-libiconv-prefix \
+ --without-libintl-prefix
+.endif
+
.include <bsd.port.mk>