aboutsummaryrefslogtreecommitdiff
path: root/www/cheetah/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-04 18:52:04 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-04 18:52:04 +0000
commit3abbc6ea3bb5d6f50cf465f3183570a15941d7ff (patch)
tree0708d78ca52a2dcab4a0084a0c3264e60dcee3fe /www/cheetah/Makefile
parent450a6bd5d81fc2631822a04d80ce684595f0d21a (diff)
downloadports-3abbc6ea3bb5d6f50cf465f3183570a15941d7ff.tar.gz
ports-3abbc6ea3bb5d6f50cf465f3183570a15941d7ff.zip
Notes
Diffstat (limited to 'www/cheetah/Makefile')
-rw-r--r--www/cheetah/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/cheetah/Makefile b/www/cheetah/Makefile
index d2c80eafa83f..40165c4a7330 100644
--- a/www/cheetah/Makefile
+++ b/www/cheetah/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= cheetah
-PORTVERSION= 0.05
+PORTVERSION= 0.10
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= cheetah
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ based light-weight web browser
@@ -18,9 +18,16 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
-GNU_CONFIGURE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
+USE_REINPLACE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.mk>