aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee-devel
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-19 18:55:37 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-19 18:55:37 +0000
commit20928188f105b7820e5348d76a613b1951bf5df0 (patch)
tree0704642a977b181e3a9e6903688984153a2d1a6f /www/cherokee-devel
parentc8a48dcaf12d49f2908a9ba51ec534fa29a28e66 (diff)
downloadports-20928188f105b7820e5348d76a613b1951bf5df0.tar.gz
ports-20928188f105b7820e5348d76a613b1951bf5df0.zip
Notes
Diffstat (limited to 'www/cherokee-devel')
-rw-r--r--www/cherokee-devel/Makefile8
-rw-r--r--www/cherokee-devel/distinfo6
-rw-r--r--www/cherokee-devel/files/cherokee.sh.in2
3 files changed, 8 insertions, 8 deletions
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index 03837b9eeb57..5d095a70a3c4 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.5.3
-PORTREVISION= 1
+PORTVERSION= 0.5.4
CATEGORIES= www
MASTER_SITES= http://www.0x50.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
@@ -17,15 +16,16 @@ COMMENT= An extremely fast and flexible web server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
-USE_BISON= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_RC_SUBR= cherokee.sh
USE_GCC= 3.4+
+USE_BISON= yes
USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
+ --with-wwwroot=${PREFIX}/www
INSTALLS_SHLIB= yes
MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
diff --git a/www/cherokee-devel/distinfo b/www/cherokee-devel/distinfo
index c717d19da83d..7bbb8683bd2b 100644
--- a/www/cherokee-devel/distinfo
+++ b/www/cherokee-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (cherokee-0.5.3.tar.gz) = 9e8dfc46f94ee150515be5d31bd40d16
-SHA256 (cherokee-0.5.3.tar.gz) = c91699fe8cd2140e3b236257e7cb5ca4cd42e587a8f3eb932363f82f0e7212ef
-SIZE (cherokee-0.5.3.tar.gz) = 1547870
+MD5 (cherokee-0.5.4.tar.gz) = 4e207961bc8204a2e2026391649dd8af
+SHA256 (cherokee-0.5.4.tar.gz) = f44f16e8cf581ba8a7b22e4c9631e432967f43c9af50cf706432e8ad58a9c331
+SIZE (cherokee-0.5.4.tar.gz) = 1556342
diff --git a/www/cherokee-devel/files/cherokee.sh.in b/www/cherokee-devel/files/cherokee.sh.in
index f35381e205da..098daf69297e 100644
--- a/www/cherokee-devel/files/cherokee.sh.in
+++ b/www/cherokee-devel/files/cherokee.sh.in
@@ -11,7 +11,7 @@
# cherokee_enable (bool): Set it to "YES" to enable cherokee
# Default is "NO".
# cherokee_conf (path): Set full path to config file.
-# Default is "%%PREFIX%%/etc/cherokee.conf".
+# Default is "%%PREFIX%%/etc/cherokee/cherokee.conf".
#
. %%RC_SUBR%%