aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-09-01 00:17:59 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-09-01 00:17:59 +0000
commitd06b56c19d107da3017fbcbb3747cab46c7098d4 (patch)
tree91953eef6d7d5a0e40ace787698738237ef0aa79 /www/cherokee
parentb7fe907a05074d735cb6c0188d95516dd561ec24 (diff)
downloadports-d06b56c19d107da3017fbcbb3747cab46c7098d4.tar.gz
ports-d06b56c19d107da3017fbcbb3747cab46c7098d4.zip
Notes
Diffstat (limited to 'www/cherokee')
-rw-r--r--www/cherokee/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 9bccc9920227..23728aa89db3 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -46,6 +47,10 @@ PLIST_SUB+= PAM=""
PLIST_SUB+= PAM="@comment "
.endif
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|@mkdir_p@|${MKDIR} --|g'
+
pre-build:
.for file in advanced.conf cherokee.conf mods-ssl sites-default sites-example
@cd ${BUILD_WRKSRC} && ${SED} -e \