aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-07 16:54:49 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-07 16:54:49 +0000
commit052c1bab750bd816492d920e1986fab49f77c2a2 (patch)
treeb235e021af8eb957589983ec505e4c4be0ff5bc0 /www/cherokee
parent1434656ad4032f853d7110b9519a146853643e02 (diff)
downloadports-052c1bab750bd816492d920e1986fab49f77c2a2.tar.gz
ports-052c1bab750bd816492d920e1986fab49f77c2a2.zip
Notes
Diffstat (limited to 'www/cherokee')
-rw-r--r--www/cherokee/Makefile32
1 files changed, 25 insertions, 7 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 1605ae75eb22..84d70334fd17 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -7,8 +7,10 @@
PORTNAME= cherokee
PORTVERSION= 0.5.5
+PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= http://www.cherokee-project.com/download/%SUBDIR%/
+MASTER_SITES= http://www.cherokee-project.com/download/%SUBDIR%/ \
+ http://www.alaskaparadise.com/freebsd/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= beech@alaskaparadise.com
@@ -26,6 +28,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
--with-wwwroot=${PREFIX}/www
+
+OPTIONS= GNUTLS "TLS/SSL Use gnutls" on \
+ OPENSSL "TLS/SSL Use openssl" off \
+ NOTLS "No TLS/SSL" off \
+ NOIPV6 "No IPv6" off
+
USE_LDCONFIG= yes
MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
@@ -33,16 +41,26 @@ MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if defined(WITHOUT_GNUTLS)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --enable-tls=openssl
-LDFLAGS+= -lssl -lcrypto
-.else
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GNUTLS)
LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --enable-tls=gnutls
.endif
-.include <bsd.port.pre.mk>
+.if defined(WITH_OPENSSL)
+CFLAGS+= -DHAVE_OPENSSL
+CONFIGURE_ARGS+=--enable-tls=openssl
+LDFLAGS+= -lssl -lcrypto
+.endif
+
+.if defined(WITH_NOTLS)
+CONFIGURE_ARGS+=--disable-tls
+.endif
+
+.if defined(WITH_NOIPV6)
+CONFIGURE_ARGS+=--disable-ipv6
+.endif
.if ${OSVERSION} < 500000
PLIST_SUB+= PAM=""