aboutsummaryrefslogtreecommitdiff
path: root/www/chimera
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-07 23:23:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-07 23:23:03 +0000
commit3196d00a786e7dbeec379dd120d794eb25cf21fe (patch)
treef05c8c8fe42b9faefbb782e66bb6d112a451ef64 /www/chimera
parent6bd449375a5a355d275f1124e4c48dc8bdb3c02d (diff)
downloadports-3196d00a786e7dbeec379dd120d794eb25cf21fe.tar.gz
ports-3196d00a786e7dbeec379dd120d794eb25cf21fe.zip
Notes
Diffstat (limited to 'www/chimera')
-rw-r--r--www/chimera/Makefile8
-rw-r--r--www/chimera/files/patch-Common.tmpl.dist (renamed from www/chimera/files/patch-aa)11
-rw-r--r--www/chimera/files/patch-compat::Imakefile11
-rw-r--r--www/chimera/files/patch-libhtmlw::HTML-PSformat.c40
4 files changed, 52 insertions, 18 deletions
diff --git a/www/chimera/Makefile b/www/chimera/Makefile
index 10ed16eba00b..4ab164c1d3ec 100644
--- a/www/chimera/Makefile
+++ b/www/chimera/Makefile
@@ -19,10 +19,4 @@ USE_IMAKE= yes
MAN1= chimera.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/chimera/files/patch-aa b/www/chimera/files/patch-Common.tmpl.dist
index 6de08afc4cb0..d465aa0bbb37 100644
--- a/www/chimera/files/patch-aa
+++ b/www/chimera/files/patch-Common.tmpl.dist
@@ -9,14 +9,3 @@
/*
* OSF1 needs -D_BSD
---- ./compat/Imakefile.org Mon Mar 13 19:48:00 1995
-+++ ./compat/Imakefile Wed Jun 11 12:42:13 1997
-@@ -31,7 +31,7 @@
-
- DependTarget()
- #else
--all:
-+all::
-
- depend::
- #endif
diff --git a/www/chimera/files/patch-compat::Imakefile b/www/chimera/files/patch-compat::Imakefile
new file mode 100644
index 000000000000..8e9be8d5be71
--- /dev/null
+++ b/www/chimera/files/patch-compat::Imakefile
@@ -0,0 +1,11 @@
+--- ./compat/Imakefile.org Mon Mar 13 19:48:00 1995
++++ ./compat/Imakefile Wed Jun 11 12:42:13 1997
+@@ -31,7 +31,7 @@
+
+ DependTarget()
+ #else
+-all:
++all::
+
+ depend::
+ #endif
diff --git a/www/chimera/files/patch-libhtmlw::HTML-PSformat.c b/www/chimera/files/patch-libhtmlw::HTML-PSformat.c
new file mode 100644
index 000000000000..154d1bff46c1
--- /dev/null
+++ b/www/chimera/files/patch-libhtmlw::HTML-PSformat.c
@@ -0,0 +1,40 @@
+--- libhtmlw/HTML-PSformat.c.orig Sun May 4 17:08:32 1997
++++ libhtmlw/HTML-PSformat.c Sun Nov 30 11:03:28 2003
+@@ -41,7 +41,11 @@
+ * permission of John Bradley.
+ */
+
++#if 0
+ #include <varargs.h>
++#else
++#include <stdarg.h>
++#endif
+
+ #include <stdio.h>
+ #include <ctype.h>
+@@ -204,9 +208,13 @@
+ }
+ #else /* not BROKEN_SOLARIS_COMPILER_STDARG */
+ static int
++#if 0
+ PSprintf (format, va_alist)
+ char *format;
+ va_dcl
++#else
++PSprintf (char *format, ...)
++#endif
+ {
+ int len;
+ char *s;
+@@ -222,7 +230,11 @@
+ }
+ PS_string = s;
+ }
++#if 0
+ va_start (args);
++#else
++ va_start (args, format);
++#endif
+ len = vsprintf (PS_string + PS_len, format, args);
+ /* this is a hack to make it work on systems were vsprintf(s,...)
+ * returns s, instead of the len.