aboutsummaryrefslogtreecommitdiff
path: root/www/choqok
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-09-24 12:07:37 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-09-24 12:07:37 +0000
commitd665c9daf8b6d6779247864b36e782662e62e312 (patch)
tree9746b4732a5a9e5aa3b8c76425c67e0ae55f400f /www/choqok
parent1b8952e92ada0151539fed5277079d46fe633c4d (diff)
downloadports-d665c9daf8b6d6779247864b36e782662e62e312.tar.gz
ports-d665c9daf8b6d6779247864b36e782662e62e312.zip
Notes
Diffstat (limited to 'www/choqok')
-rw-r--r--www/choqok/Makefile6
-rw-r--r--www/choqok/files/patch-cmake__modules__CMakeLists.txt9
2 files changed, 13 insertions, 2 deletions
diff --git a/www/choqok/Makefile b/www/choqok/Makefile
index 952c715c997a..f294608ad580 100644
--- a/www/choqok/Makefile
+++ b/www/choqok/Makefile
@@ -7,7 +7,7 @@
PORTNAME= choqok
PORTVERSION= 0.9.90
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www kde
MASTER_SITES= http://d10xg45o6p6dbl.cloudfront.net/projects/c/choqok/
@@ -16,8 +16,10 @@ COMMENT= KDE micro-blogging client
LICENSE= GPLv3
+BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson \
- qoauth.1:${PORTSDIR}/net/qoauth
+ qoauth.1:${PORTSDIR}/net/qoauth \
+ kwebkit.1:${PORTSDIR}/www/kwebkitpart
USE_BZIP2= yes
USE_CMAKE= yes
diff --git a/www/choqok/files/patch-cmake__modules__CMakeLists.txt b/www/choqok/files/patch-cmake__modules__CMakeLists.txt
new file mode 100644
index 000000000000..47341e257db1
--- /dev/null
+++ b/www/choqok/files/patch-cmake__modules__CMakeLists.txt
@@ -0,0 +1,9 @@
+--- ./cmake/modules/CMakeLists.txt.orig 2010-08-15 16:22:32.000000000 +0400
++++ ./cmake/modules/CMakeLists.txt 2010-08-21 02:07:15.958529747 +0400
+@@ -1,4 +1,4 @@
+ # install the cmake files
+
+-set(cmakeFiles FindChoqok.cmake FindQJson.cmake FindQtOAuth.cmake)
++set(cmakeFiles FindChoqok.cmake FindQtOAuth.cmake)
+ install( FILES ${cmakeFiles} DESTINATION ${DATA_INSTALL_DIR}/cmake/modules )
+\ No newline at end of file