aboutsummaryrefslogtreecommitdiff
path: root/www/chpasswd
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-23 07:19:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-23 07:19:35 +0000
commitbd012dc2aab2d4289b4673c17973ac1972afe3a5 (patch)
tree6b70be6d564a5b0f79b7486ef5c234ba7e07e681 /www/chpasswd
parent1da8ab0c4c36ef7ef3315a9f43fe9161c2a3a5d0 (diff)
downloadports-bd012dc2aab2d4289b4673c17973ac1972afe3a5.tar.gz
ports-bd012dc2aab2d4289b4673c17973ac1972afe3a5.zip
Unbreak the build with recent GCC.
Reported by: kris Approved by: portmgr (marcus), fjoe (mentor, implicit), maintainer
Notes
Notes: svn path=/head/; revision=118353
Diffstat (limited to 'www/chpasswd')
-rw-r--r--www/chpasswd/Makefile8
-rw-r--r--www/chpasswd/files/patch-chpasswd.c19
2 files changed, 20 insertions, 7 deletions
diff --git a/www/chpasswd/Makefile b/www/chpasswd/Makefile
index 223ede1b084d..be9348a64116 100644
--- a/www/chpasswd/Makefile
+++ b/www/chpasswd/Makefile
@@ -21,16 +21,10 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/etc/chpasswd \
--enable-language=English \
--enable-cgidir=${PREFIX}/www/cgi-bin
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
pre-install:
@${MKDIR} ${PREFIX}/www/cgi-bin
post-install:
@${ECHO} 'Remember, passwd and log file must be owned by httpd user, or chmod 777'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/chpasswd/files/patch-chpasswd.c b/www/chpasswd/files/patch-chpasswd.c
new file mode 100644
index 000000000000..13b2872d0767
--- /dev/null
+++ b/www/chpasswd/files/patch-chpasswd.c
@@ -0,0 +1,19 @@
+--- chpasswd.c.orig Fri Apr 11 01:54:02 2003
++++ chpasswd.c Wed Sep 22 15:46:47 2004
+@@ -23,6 +23,16 @@
+ static void vrfyauth(IpAuth,PwdLogFile,PwdFile,SmtpUser,SmtpSubject);
+ eperror(s);
+
++void getword(char *, char *, char);
++void Herror(char *);
++void Hmsg(char *);
++void putline(FILE *, char *);
++void Changed(char *, char *, char *, char *, char *, char *, char *);
++void NotFound(char *, char *, char *, char *, char *, char *, char *);
++void rulefail(char *, char *, char *);
++static void strip_latin(char *);
++void sendmail(char *, char *, char *);
++
+ main(argc, argv)
+ int argc;
+ char *argv[];