aboutsummaryrefslogtreecommitdiff
path: root/www/chpasswd
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2011-08-23 00:07:16 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2011-08-23 00:07:16 +0000
commit2e7a5c351e66d9557bf6b24bb9160d5e541c33c0 (patch)
treea8685eb11e2ab59b6d163313cff9f08f5906260b /www/chpasswd
parenta2b573605fd18dfa7d3151c8c71822f232d140f8 (diff)
downloadports-2e7a5c351e66d9557bf6b24bb9160d5e541c33c0.tar.gz
ports-2e7a5c351e66d9557bf6b24bb9160d5e541c33c0.zip
Notes
Diffstat (limited to 'www/chpasswd')
-rw-r--r--www/chpasswd/Makefile6
-rw-r--r--www/chpasswd/distinfo4
-rw-r--r--www/chpasswd/files/patch-chpasswd.c28
3 files changed, 5 insertions, 33 deletions
diff --git a/www/chpasswd/Makefile b/www/chpasswd/Makefile
index bc61fbaf174c..ed7be10f4e4b 100644
--- a/www/chpasswd/Makefile
+++ b/www/chpasswd/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= chpasswd
-PORTVERSION= 2.2.3
-PORTREVISION= 3
+PORTVERSION= 2.2.4
CATEGORIES= www
-MASTER_SITES= SF/orso${PORTNAME}/orso${PORTNAME}/${PORTVERSION}
+#MASTER_SITES= SF/orsochpasswd/orsochpasswd/chpasswd-2.2.4/
+MASTER_SITES= SF/orso${PORTNAME}/orso${PORTNAME}/${PORTNAME}-${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Allow users to change their Squid or Web password using the browser
diff --git a/www/chpasswd/distinfo b/www/chpasswd/distinfo
index 7e144abc9887..4927cee41e85 100644
--- a/www/chpasswd/distinfo
+++ b/www/chpasswd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chpasswd-2.2.3.tar.gz) = b879b48c340627efc10ef1ecc278f11fc58ff28fe2be5af378ec61fe21e1254b
-SIZE (chpasswd-2.2.3.tar.gz) = 98282
+SHA256 (chpasswd-2.2.4.tar.gz) = 8b665e042faf82372f9f1d19080f427439ad0eeea95903bcada9e07936c5aaba
+SIZE (chpasswd-2.2.4.tar.gz) = 74155
diff --git a/www/chpasswd/files/patch-chpasswd.c b/www/chpasswd/files/patch-chpasswd.c
deleted file mode 100644
index 171961cf36a9..000000000000
--- a/www/chpasswd/files/patch-chpasswd.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- chpasswd.c.orig 2005-05-09 13:05:08.000000000 +0000
-+++ chpasswd.c 2007-11-08 15:10:11.000000000 +0000
-@@ -282,7 +282,7 @@
- }
-
-
--static int
-+int
- htoi(s)
- unsigned char *s;
- {
-@@ -664,6 +664,16 @@
- }
-
-
-+void getword(char *, char *, char);
-+void Herror(char *);
-+void Hmsg(char *);
-+void putline(FILE *, char *);
-+void Changed(char *, char *, char *, char *, char *, char *, char *);
-+void NotFound(char *, char *, char *, char *, char *, char *, char *);
-+void rulefail(char *, char *, char *);
-+static void strip_latin(char *);
-+void sendmail(char *, char *, char *);
-+
- main(argc, argv)
- int argc;
- char *argv[];