aboutsummaryrefslogtreecommitdiff
path: root/www/chromium/files/patch-content__gpu__gpu_main.cc
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-10-08 08:41:51 +0000
committerRene Ladan <rene@FreeBSD.org>2014-10-08 08:41:51 +0000
commit935f403d3f46a7c7804a6d99e2bb53171db157c1 (patch)
treec797b39fa9e90549727670b9173ba6b02a5df0a1 /www/chromium/files/patch-content__gpu__gpu_main.cc
parent92e654eadbd1c6660e23d5dc3ffcfc06690b1c31 (diff)
downloadports-935f403d3f46a7c7804a6d99e2bb53171db157c1.tar.gz
ports-935f403d3f46a7c7804a6d99e2bb53171db157c1.zip
www/chromium: Update to 38.0.2125.101 and clean up pkg-plist
Thanks to all contributors: "tomek", "pavoropaev", Carlos Medina Obtained from: https://github.com/gliaskos/freebsd-chromium/ MFH: 2014Q4 Security: http://www.vuxml.org/freebsd/d2bbcc01-4ec3-11e4-ab3f-00262d5ed8ee.html
Notes
Notes: svn path=/head/; revision=370423
Diffstat (limited to 'www/chromium/files/patch-content__gpu__gpu_main.cc')
-rw-r--r--www/chromium/files/patch-content__gpu__gpu_main.cc29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/chromium/files/patch-content__gpu__gpu_main.cc b/www/chromium/files/patch-content__gpu__gpu_main.cc
new file mode 100644
index 000000000000..370a339bb9b4
--- /dev/null
+++ b/www/chromium/files/patch-content__gpu__gpu_main.cc
@@ -0,0 +1,29 @@
+--- content/gpu/gpu_main.cc.orig 2014-10-02 17:39:47 UTC
++++ content/gpu/gpu_main.cc
+@@ -71,7 +71,7 @@
+ const CommandLine& command_line);
+ bool WarmUpSandbox(const CommandLine& command_line);
+
+-#if !defined(OS_MACOSX)
++#if !defined(OS_MACOSX) && !defined(OS_FREEBSD) //XXX(rene) added !FreeBSD
+ bool CollectGraphicsInfo(gpu::GPUInfo& gpu_info);
+ #endif
+
+@@ -265,7 +265,7 @@
+ // and we already registered them through SetGpuInfo() above.
+ base::TimeTicks before_collect_context_graphics_info =
+ base::TimeTicks::Now();
+-#if !defined(OS_MACOSX)
++#if !defined(OS_MACOSX) && !defined(OS_FREEBSD) //XXX(rene) added !FreeBSD
+ if (!CollectGraphicsInfo(gpu_info))
+ dead_on_arrival = true;
+
+@@ -393,7 +393,7 @@
+ return true;
+ }
+
+-#if !defined(OS_MACOSX)
++#if !defined(OS_MACOSX) && !defined(OS_FREEBSD)//XXX(rene) added !FreeBSD
+ bool CollectGraphicsInfo(gpu::GPUInfo& gpu_info) {
+ bool res = true;
+ gpu::CollectInfoResult result = gpu::CollectContextGraphicsInfo(&gpu_info);