aboutsummaryrefslogtreecommitdiff
path: root/www/chromium
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2018-08-18 14:41:14 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2018-08-18 14:41:14 +0000
commit9435d9f850bee8f07e099ad7ad2f667080a33084 (patch)
tree9d9401884cd657d49bdf078f9894cec64edbba22 /www/chromium
parent13ee5b072d4e3ee1e06f308014d7f298da681f62 (diff)
downloadports-9435d9f850bee8f07e099ad7ad2f667080a33084.tar.gz
ports-9435d9f850bee8f07e099ad7ad2f667080a33084.zip
- Cosmetic fix in Makefile
- Allow chromium to use the Linux GPU access setup implementation by default since it works correctly - Add missing file for DEBUG option in pkg-plist - Sort pkg-plist - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=477504
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/files/patch-content_browser_gpu_gpu__process__host.cc11
-rw-r--r--www/chromium/files/patch-gpu_config_BUILD.gn14
-rw-r--r--www/chromium/files/patch-gpu_config_gpu__info__collector__freebsd.cc32
-rw-r--r--www/chromium/pkg-plist3
5 files changed, 4 insertions, 58 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index c48165b7e720..6b9ab5d964e7 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -3,6 +3,7 @@
PORTNAME= chromium
PORTVERSION= 68.0.3440.106
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -308,4 +309,5 @@ post-install-DRIVER-on:
${INSTALL_PROGRAM} ${WRKSRC}/out/${BUILDTYPE}/chromedriver \
${STAGEDIR}${PREFIX}/bin
.endif
+
.include <bsd.port.mk>
diff --git a/www/chromium/files/patch-content_browser_gpu_gpu__process__host.cc b/www/chromium/files/patch-content_browser_gpu_gpu__process__host.cc
deleted file mode 100644
index 3c30edfa7c0b..000000000000
--- a/www/chromium/files/patch-content_browser_gpu_gpu__process__host.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- content/browser/gpu/gpu_process_host.cc.orig 2017-06-05 19:03:07 UTC
-+++ content/browser/gpu/gpu_process_host.cc
-@@ -965,7 +965,7 @@ bool GpuProcessHost::LaunchGpuProcess(gpu::GpuPreferen
- std::unique_ptr<base::CommandLine> cmd_line =
- base::MakeUnique<base::CommandLine>(base::CommandLine::NO_PROGRAM);
- #else
--#if defined(OS_LINUX)
-+#if defined(OS_LINUX) || defined(OS_BSD)
- int child_flags = gpu_launcher.empty() ? ChildProcessHost::CHILD_ALLOW_SELF :
- ChildProcessHost::CHILD_NORMAL;
- #else
diff --git a/www/chromium/files/patch-gpu_config_BUILD.gn b/www/chromium/files/patch-gpu_config_BUILD.gn
deleted file mode 100644
index c7ee06e048ff..000000000000
--- a/www/chromium/files/patch-gpu_config_BUILD.gn
+++ /dev/null
@@ -1,14 +0,0 @@
---- gpu/config/BUILD.gn.orig 2018-03-20 23:05:26.000000000 +0100
-+++ gpu/config/BUILD.gn 2018-03-26 13:38:50.564110000 +0200
-@@ -107,6 +107,11 @@
- "gpu_util.h",
- ]
-
-+ if (is_bsd) {
-+ sources -= [ "gpu_info_collector_linux.cc" ]
-+ sources += [ "gpu_info_collector_freebsd.cc" ]
-+ }
-+
- if (is_fuchsia) {
- sources += [ "gpu_info_collector_fuchsia.cc" ]
- }
diff --git a/www/chromium/files/patch-gpu_config_gpu__info__collector__freebsd.cc b/www/chromium/files/patch-gpu_config_gpu__info__collector__freebsd.cc
deleted file mode 100644
index 43f721ea96c6..000000000000
--- a/www/chromium/files/patch-gpu_config_gpu__info__collector__freebsd.cc
+++ /dev/null
@@ -1,32 +0,0 @@
---- gpu/config/gpu_info_collector_freebsd.cc.orig 2018-08-13 21:50:38.978048000 +0200
-+++ gpu/config/gpu_info_collector_freebsd.cc 2018-08-13 21:54:59.868827000 +0200
-@@ -0,0 +1,29 @@
-+// Copyright 2017 The Chromium Authors. All rights reserved.
-+// Use of this source code is governed by a BSD-style license that can be
-+// found in the LICENSE file.
-+
-+#include "base/trace_event/trace_event.h"
-+#include "gpu/config/gpu_info_collector.h"
-+#include "third_party/angle/src/gpu_info_util/SystemInfo.h"
-+
-+namespace gpu {
-+
-+bool CollectContextGraphicsInfo(GPUInfo* gpu_info) {
-+ DCHECK(gpu_info);
-+
-+ TRACE_EVENT0("gpu", "gpu_info_collector::CollectGraphicsInfo");
-+
-+ return CollectGraphicsInfoGL(gpu_info);
-+}
-+
-+bool CollectBasicGraphicsInfo(GPUInfo* gpu_info) {
-+ DCHECK(gpu_info);
-+
-+ angle::SystemInfo system_info;
-+ bool success = angle::GetSystemInfo(&system_info);
-+ FillGPUInfoFromSystemInfo(gpu_info, &system_info);
-+ return success;
-+}
-+
-+
-+} // namespace gpu
diff --git a/www/chromium/pkg-plist b/www/chromium/pkg-plist
index a491952c7ffb..810878ab77ce 100644
--- a/www/chromium/pkg-plist
+++ b/www/chromium/pkg-plist
@@ -6,7 +6,6 @@ bin/chrome
%%DATADIR%%/font_service.service
%%DATADIR%%/headless_lib.pak
%%DATADIR%%/icudtl.dat
-%%DATADIR%%/natives_blob.bin
%%DATADIR%%/keyboard_resources.pak
%%DATADIR%%/libEGL.so
%%DATADIR%%/libGLESv2.so
@@ -117,6 +116,7 @@ bin/chrome
%%DATADIR%%/locales/zh-TW.pak
%%DATADIR%%/locales/zh-TW.pak.info
%%DATADIR%%/mksnapshot
+%%DATADIR%%/natives_blob.bin
%%DATADIR%%/product_logo_48.png
%%DATADIR%%/protoc
%%DATADIR%%/resources.pak
@@ -318,6 +318,7 @@ bin/chrome
%%DATADIR%%/v8_context_snapshot.bin
%%DATADIR%%/views_mus_resources.pak
%%DEBUG%%%%DATADIR%%/character_data_generator
+%%DEBUG%%%%DATADIR%%/libVkICD_mock_icd.so
%%DEBUG%%%%DATADIR%%/libVkLayer_core_validation.so
%%DEBUG%%%%DATADIR%%/libVkLayer_object_tracker.so
%%DEBUG%%%%DATADIR%%/libVkLayer_parameter_validation.so