aboutsummaryrefslogtreecommitdiff
path: root/www/cliqz
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-07-17 06:44:04 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-07-17 06:44:04 +0000
commitb0f1d6430efe60a7d9a3aa11e8ed28a80842469b (patch)
tree99d9ac6360ee6f7d04f5cb7d7f1db83a19a355f8 /www/cliqz
parent88700ad75af90b7ed391a06e691b9ddb2a8f9c97 (diff)
downloadports-b0f1d6430efe60a7d9a3aa11e8ed28a80842469b.tar.gz
ports-b0f1d6430efe60a7d9a3aa11e8ed28a80842469b.zip
lang/rust: Update to 1.45.0
- This Rust release comes with LLVM 10. Drop the LLVM patches we no longer need. - On FreeBSD 13.0 powerpc64 set the elfv2 ABI explicitly in the Rust target instead of patching LLVM. - Build LLVM with Ninja. It can shorten the build time slightly. - Force rebuild all consumers to catch regressions early Changes: https://blog.rust-lang.org/2020/07/16/Rust-1.45.0.html Tested by: mikael, pkubaj, tobik With hat: rust Differential Revision: https://reviews.freebsd.org/D25658
Notes
Notes: svn path=/head/; revision=542412
Diffstat (limited to 'www/cliqz')
-rw-r--r--www/cliqz/Makefile2
-rw-r--r--www/cliqz/files/patch-bug164098215
2 files changed, 16 insertions, 1 deletions
diff --git a/www/cliqz/Makefile b/www/cliqz/Makefile
index 6498d3a46baf..0253c6b29ec3 100644
--- a/www/cliqz/Makefile
+++ b/www/cliqz/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cliqz
DISTVERSION= 1.36.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://s3.amazonaws.com/cdn.cliqz.com/browser-f/APT/:amazon \
http://repository.cliqz.com/dist/${CLIQZ_CHANNEL}/${DISTVERSION}/${CLIQZ_LAST_BUILD_ID}/:cliqz
diff --git a/www/cliqz/files/patch-bug1640982 b/www/cliqz/files/patch-bug1640982
new file mode 100644
index 000000000000..ec672ade7c58
--- /dev/null
+++ b/www/cliqz/files/patch-bug1640982
@@ -0,0 +1,15 @@
+Unbreak build with Rust 1.45.0
+
+error: options `-C embed-bitcode=no` and `-C lto` are incompatible
+
+--- mozilla-release/config/makefiles/rust.mk.orig 2020-05-12 09:36:22 UTC
++++ mozilla-release/config/makefiles/rust.mk
+@@ -61,7 +61,7 @@ ifndef MOZ_DEBUG_RUST
+ # Enable link-time optimization for release builds, but not when linking
+ # gkrust_gtest.
+ ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
+-cargo_rustc_flags += -Clto
++cargo_rustc_flags +=
+ endif
+ endif
+ endif