aboutsummaryrefslogtreecommitdiff
path: root/www/cocoon
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-05-14 22:06:29 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-05-14 22:06:29 +0000
commit35af50eeba762ea01b958aa7c8721b9cdb5a338f (patch)
treef2635a886a7e0fbeb76e94b89141f395c02215c8 /www/cocoon
parenta53f2b31106dce2981ffc4577b51385874982ccd (diff)
downloadports-35af50eeba762ea01b958aa7c8721b9cdb5a338f.tar.gz
ports-35af50eeba762ea01b958aa7c8721b9cdb5a338f.zip
Notes
Diffstat (limited to 'www/cocoon')
-rw-r--r--www/cocoon/Makefile4
-rw-r--r--www/cocoon/files/cocoonctl.in2
-rw-r--r--www/cocoon/files/patch-cocoon.sh32
-rw-r--r--www/cocoon/files/upstreams-cocoon.sh.in209
-rw-r--r--www/cocoon/pkg-plist1
5 files changed, 213 insertions, 35 deletions
diff --git a/www/cocoon/Makefile b/www/cocoon/Makefile
index 4bbc80c7041a..660aa081aa0c 100644
--- a/www/cocoon/Makefile
+++ b/www/cocoon/Makefile
@@ -44,7 +44,6 @@ SUB_LIST= \
APP_HOME=${APP_HOME} \
APP_NAME=${APP_NAME} \
RC_SUBR=${RC_SUBR} \
- PREFIX=${PREFIX} \
PORT=${PORT} \
COCOON_LIB=${COCOON_LIB} \
JAVA_HOME=${JAVA_HOME} \
@@ -62,6 +61,7 @@ SUB_FILES= \
pkg-deinstall \
${APP_NAME}ctl \
${APP_NAME}.sh \
+ upstreams-cocoon.sh \
pkg-message
# Load options (before including bsd.port.pre.mk)
@@ -126,9 +126,9 @@ do-install:
@${ECHO_MSG} "===> Installing ${COPYDIRS}"
@${MKDIR} ${APP_HOME}
@cd ${WRKSRC} && ${FIND} -H ${COPYDIRS} | ${CPIO} -pdmuL -R ${LIBOWN}:${LIBGRP} ${APP_HOME}
+ @${INSTALL} ${WRKDIR}/upstreams-cocoon.sh ${APP_HOME}/cocoon.sh
@${ECHO_MSG} "===> Installing into ${PREFIX}/sbin"
- @${INSTALL_SCRIPT} ${WRKDIR}/${APP_NAME}.sh ${PREFIX}/sbin
@${INSTALL_SCRIPT} ${WRKDIR}/${APP_NAME}ctl ${PREFIX}/sbin
@${ECHO_MSG} "===> Installing ${PREFIX}/etc/rc.d/${APP_NAME}.sh"
diff --git a/www/cocoon/files/cocoonctl.in b/www/cocoon/files/cocoonctl.in
index bfc05ad28fe3..b7f3b2bd68c4 100644
--- a/www/cocoon/files/cocoonctl.in
+++ b/www/cocoon/files/cocoonctl.in
@@ -140,7 +140,7 @@ if __name__ == '__main__':
APP_NAME = "%%APP_NAME%%"
APP_HOME = "%%APP_HOME%%"
PID_FILE = "%%PID_FILE%%"
- COMMAND = "%%PREFIX%%/sbin/%%APP_NAME%%.sh"
+ COMMAND = "%%APP_HOME%%/cocoon.sh"
os.environ["JAVA_OPTIONS"] = " ".join(sys.argv[1:-1])
ARGS = [COMMAND, "servlet"]
diff --git a/www/cocoon/files/patch-cocoon.sh b/www/cocoon/files/patch-cocoon.sh
deleted file mode 100644
index 5cd6090cf813..000000000000
--- a/www/cocoon/files/patch-cocoon.sh
+++ /dev/null
@@ -1,32 +0,0 @@
-$FreeBSD$
-
---- cocoon.sh.orig Thu Feb 12 09:48:55 2004
-+++ cocoon.sh Tue May 4 14:44:24 2004
-@@ -57,8 +57,7 @@
- # ----- Verify and Set Required Environment Variables -------------------------
-
- if [ "$JAVA_HOME" = "" ] ; then
-- echo You must set JAVA_HOME to point at your Java Development Kit installation
-- exit 1
-+ JAVA_HOME="%%JAVA_HOME%%"
- fi
-
- if [ "$JAVA_OPTIONS" = "" ] ; then
-@@ -66,7 +65,7 @@
- fi
-
- if [ "$COCOON_HOME" = "" ] ; then
-- COCOON_HOME='.'
-+ COCOON_HOME="%%APP_HOME%%"
- fi
-
- if [ "$COCOON_WEBAPP_HOME" = "" ] ; then
-@@ -76,7 +75,7 @@
- COCOON_WEBAPP_HOME=$STANDALONE_WEBAPP
- else
- # when in the build environment
-- COCOON_WEBAPP_HOME="$COCOON_HOME/build/webapp"
-+ COCOON_WEBAPP_HOME="$COCOON_HOME/webapp"
- fi
- fi
- echo "$0: using $COCOON_WEBAPP_HOME as the webapp directory"
diff --git a/www/cocoon/files/upstreams-cocoon.sh.in b/www/cocoon/files/upstreams-cocoon.sh.in
new file mode 100644
index 000000000000..b78ca4692afc
--- /dev/null
+++ b/www/cocoon/files/upstreams-cocoon.sh.in
@@ -0,0 +1,209 @@
+#!/bin/sh
+# Copyright 1999-2004 The Apache Software Foundation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# -----------------------------------------------------------------------------
+#
+# The file was modified to run on FreeBSD
+#
+# -----------------------------------------------------------------------------
+# Cocoon Unix Shell Script
+#
+# $Id: cocoon.sh 389028 2006-03-27 06:21:40Z rgoers $
+# $FreeBSD$
+# -----------------------------------------------------------------------------
+
+# Configuration variables
+#
+# COCOON_HOME
+# The root of the Cocoon distribution
+#
+# COCOON_WEBAPP_HOME
+# The root of the Cocoon web application
+#
+# COCOON_LIB
+# Folder containing all the library files needed by the Cocoon CLI
+#
+# JAVA_HOME
+# Home of Java installation.
+#
+# JAVA_OPTIONS
+# Extra options to pass to the JVM
+#
+# JAVA_DEBUG_ARGS
+# The command line arguments for the internal JVM debugger
+#
+# JAVA_PROFILE_ARGS
+# The command line arguments for the internal JVM profiler
+#
+# JETTY_PORT
+# Override the default port for Jetty
+#
+# JETTY_ADMIN_PORT
+# The port where the jetty web administration should bind
+#
+# LOADER_LIB
+# The classpath where to lookup the Loader class, defaults to
+# ${COCOON_HOME}/tools/loader
+#
+# CLI_CLASSPATH
+# The additional classpath for cli and precompile, defaults to
+# lib/core/servlet_2_2.jar:$COCOON_WEBAPP_HOME/WEB-INF/classes
+#
+
+
+usage()
+{
+ echo "Usage: $0 (action)"
+ echo "actions:"
+ echo " cli Run Cocoon from the command line"
+ echo " precompile Crawl your webapp to compile all XSP files (requires the xsp block)"
+ echo " servlet Run Cocoon in a servlet container (default)"
+ echo " servlet-admin Run Cocoon in a servlet container and turn on container web administration"
+ echo " servlet-debug Run Cocoon in a servlet container and turn on JVM remote debug"
+ echo " servlet-profile Run Cocoon in a servlet container and turn on JVM profiling"
+ exit 1
+}
+
+# ----- Handle action parameter ------------------------------------------------
+DEFAULT_ACTION="servlet"
+ACTION="$1"
+if [ -n "$ACTION" ]
+then
+ shift
+else
+ ACTION=$DEFAULT_ACTION
+ echo "$0: executing default action '$ACTION', use -h to see other actions"
+fi
+ARGS="$*"
+
+# ----- Verify and Set Required Environment Variables -------------------------
+
+if [ "$JAVA_HOME" = "" ] ; then
+ JAVA_HOME="%%JAVA_HOME%%"
+fi
+
+if [ "$JAVA_OPTIONS" = "" ] ; then
+ JAVA_OPTIONS='-Xms32M -Xmx512M -Dorg.apache.cocoon.settings=cocoon.properties'
+fi
+
+if [ "$COCOON_HOME" = "" ] ; then
+ COCOON_HOME="%%APP_HOME%%"
+fi
+
+if [ "$COCOON_WEBAPP_HOME" = "" ] ; then
+ STANDALONE_WEBAPP=../webapp
+ if [ -d $STANDALONE_WEBAPP ] ; then
+ # for standalone-webapp setup
+ COCOON_WEBAPP_HOME=$STANDALONE_WEBAPP
+ else
+ # when in the build environment
+ COCOON_WEBAPP_HOME="$COCOON_HOME/webapp"
+ fi
+fi
+echo "$0: using $COCOON_WEBAPP_HOME as the webapp directory"
+
+if [ "$COCOON_LIB" = "" ] ; then
+ COCOON_LIB="$COCOON_WEBAPP_HOME/WEB-INF/lib"
+fi
+
+if [ "$JETTY_PORT" = "" ] ; then
+ JETTY_PORT='8888'
+fi
+
+if [ "$JETTY_ADMIN_PORT" = "" ] ; then
+ JETTY_ADMIN_PORT='8889'
+fi
+
+if [ "$JAVA_DEBUG_ARGS" = "" ] ; then
+ JAVA_DEBUG_ARGS='-Xdebug -Xrunjdwp:transport=dt_socket,address=8000,server=y,suspend=n'
+fi
+
+if [ "$JAVA_PROFILE_ARGS" = "" ] ; then
+ JAVA_PROFILE_ARGS='-Xrunhprof:heap=all,cpu=samples,thread=y,depth=3'
+fi
+
+
+# ----- Set platform specific variables
+
+PATHSEP=":";
+case "`uname`" in
+ CYGWIN*) PATHSEP=";"
+ JAVA_HOME=`cygpath --unix "$JAVA_HOME"`;;
+esac
+
+# ----- Set Local Variables ( used to minimize cut/paste) ---------------------
+
+JAVA="exec $JAVA_HOME/bin/java"
+ENDORSED_LIBS="$COCOON_HOME/lib/endorsed"
+ENDORSED="-Djava.endorsed.dirs=$ENDORSED_LIBS"
+PARSER=-Dorg.xml.sax.parser=org.apache.xerces.parsers.SAXParser
+LOADER=Loader
+if [ "$LOADER_LIB" = "" ] ; then
+ LOADER_LIB="${COCOON_HOME}/tools/loader"
+fi
+
+CLI="-Dloader.main.class=org.apache.cocoon.Main"
+CLI_LIBRARIES="-Dloader.jar.repositories=$COCOON_LIB"
+if [ "$CLI_CLASSPATH" = "" ] ; then
+ CLI_CLASSPATH="lib/core/servlet_2_2.jar:$COCOON_WEBAPP_HOME/WEB-INF/classes"
+fi
+CLI_VERBOSE="-Dloader.verbose=false"
+CLI_PROPERTIES="$CLI_LIBRARIES -Dloader.class.path=$CLI_CLASSPATH $CLI_VERBOSE"
+
+PRECOMPILE=-Dloader.main.class=org.apache.cocoon.bean.XSPPrecompileWrapper
+
+JETTY=-Dloader.main.class=org.mortbay.jetty.Server
+JETTY_CONF="$COCOON_HOME/tools/jetty/conf"
+JETTY_MAIN="$JETTY_CONF/main.xml"
+JETTY_ADMIN="$JETTY_CONF/admin.xml"
+JETTY_WEBAPP="-Dwebapp=$COCOON_WEBAPP_HOME"
+JETTY_HOME="-Dhome=$COCOON_HOME"
+JETTY_PORT_ARGS="-Djetty.port=$JETTY_PORT"
+JETTY_ADMIN_ARGS="-Djetty.admin.port=$JETTY_ADMIN_PORT"
+JETTY_LIBRARIES="-Dloader.jar.repositories=$COCOON_HOME/tools/jetty/lib${PATHSEP}${ENDORSED_LIBS}"
+
+# ----- Do the action ----------------------------------------------------------
+
+case "$ACTION" in
+ cli)
+ $JAVA $JAVA_OPTIONS -cp $LOADER_LIB $ENDORSED $CLI_PROPERTIES $CLI $LOADER $ARGS
+ ;;
+
+ precompile)
+ $JAVA $JAVA_OPTIONS -cp $LOADER_LIB $ENDORSED $CLI_PROPERTIES $PRECOMPILE $LOADER $ARGS
+ ;;
+
+ servlet)
+ $JAVA $JAVA_OPTIONS -cp $LOADER_LIB $ENDORSED $PARSER $JETTY_PORT_ARGS $JETTY_LIBRARIES $JETTY_WEBAPP $JETTY_HOME $JETTY $LOADER $JETTY_MAIN
+ ;;
+
+ servlet-admin)
+ $JAVA $JAVA_OPTIONS -cp $LOADER_LIB $ENDORSED $PARSER $JETTY_PORT_ARGS $JETTY_ADMIN_ARGS $JETTY_LIBRARIES $JETTY_WEBAPP $JETTY_HOME $JETTY $LOADER $JETTY_MAIN $JETTY_ADMIN
+ ;;
+
+ servlet-debug)
+ $JAVA $JAVA_OPTIONS $JAVA_DEBUG_ARGS -cp $LOADER_LIB $ENDORSED $PARSER $JETTY_PORT_ARGS $JETTY_LIBRARIES $JETTY_WEBAPP $JETTY_HOME $JETTY $LOADER $JETTY_MAIN
+ ;;
+
+ servlet-profile)
+ $JAVA $JAVA_OPTIONS $JAVA_PROFILE_ARGS -cp $LOADER_LIB $ENDORSED $PARSER $JETTY_ARGS $JETTY_LIBRARIES $JETTY_WEBAPP $JETTY_HOME $JETTY $LOADER $JETTY_MAIN
+ ;;
+
+ *)
+ usage
+ ;;
+esac
+
+exit 0
diff --git a/www/cocoon/pkg-plist b/www/cocoon/pkg-plist
index 9b45edb623c0..a279b5005e69 100644
--- a/www/cocoon/pkg-plist
+++ b/www/cocoon/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
sbin/cocoonctl
etc/rc.d/cocoon.sh
+cocoon/cocoon.sh
@dirrm cocoon/tools
@dirrm cocoon