aboutsummaryrefslogtreecommitdiff
path: root/www/codeigniter-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-05 15:51:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-05 15:51:11 +0000
commit83622044265579f30b57b138192f4b59806b3a5f (patch)
tree2777e46d4d9fd1551ade5107c3659bf78fa91da5 /www/codeigniter-devel
parentc84bb1fae2f44588a60f9a19e55b2ef2e1ff417f (diff)
downloadports-83622044265579f30b57b138192f4b59806b3a5f.tar.gz
ports-83622044265579f30b57b138192f4b59806b3a5f.zip
Notes
Diffstat (limited to 'www/codeigniter-devel')
-rw-r--r--www/codeigniter-devel/Makefile5
-rw-r--r--www/codeigniter-devel/distinfo6
-rw-r--r--www/codeigniter-devel/pkg-plist9
3 files changed, 14 insertions, 6 deletions
diff --git a/www/codeigniter-devel/Makefile b/www/codeigniter-devel/Makefile
index 2450d4cb04d7..3c7da45fa684 100644
--- a/www/codeigniter-devel/Makefile
+++ b/www/codeigniter-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= codeigniter
-PORTVERSION= 1.6.1
+PORTVERSION= 1.6.2
CATEGORIES= www
MASTER_SITES= http://codeigniter.com/download_files/
DISTNAME= CodeIgniter_${PORTVERSION}
@@ -27,7 +27,8 @@ CI_CONF_DIR= ${CI_SYS_DIR}/application/config
# These are all user-configurable files that we'll install
# a .sample copy for each.
CI_CONF_FILES= index.php ${CI_CONF_DIR}/autoload.php \
- ${CI_CONF_DIR}/config.php ${CI_CONF_DIR}/database.php \
+ ${CI_CONF_DIR}/config.php ${CI_CONF_DIR}/constants.php \
+ ${CI_CONF_DIR}/database.php \
${CI_CONF_DIR}/hooks.php ${CI_CONF_DIR}/mimes.php \
${CI_CONF_DIR}/routes.php ${CI_CONF_DIR}/smileys.php \
${CI_CONF_DIR}/user_agents.php
diff --git a/www/codeigniter-devel/distinfo b/www/codeigniter-devel/distinfo
index 845fd4e92fed..1af31479deed 100644
--- a/www/codeigniter-devel/distinfo
+++ b/www/codeigniter-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (CodeIgniter_1.6.1.zip) = cc3f0b566e3654d351fa067aeee9bced
-SHA256 (CodeIgniter_1.6.1.zip) = d4d8b73c787ed4fa5095ef2d3f6a2f5c710d3ed14974059db4ab8bf0f9f60ec5
-SIZE (CodeIgniter_1.6.1.zip) = 822433
+MD5 (CodeIgniter_1.6.2.zip) = 0922830f96dfd40874b39ad018a49206
+SHA256 (CodeIgniter_1.6.2.zip) = ebe28a60400cae87172e45c013bb5f897547a28cbfa4d7afe148facced1d953e
+SIZE (CodeIgniter_1.6.2.zip) = 861202
diff --git a/www/codeigniter-devel/pkg-plist b/www/codeigniter-devel/pkg-plist
index 3ae7558c0544..6231f881cc90 100644
--- a/www/codeigniter-devel/pkg-plist
+++ b/www/codeigniter-devel/pkg-plist
@@ -21,6 +21,7 @@
%%PORTDOCS%%%%DOCSDIR%%/general/ancillary_classes.html
%%PORTDOCS%%%%DOCSDIR%%/general/autoloader.html
%%PORTDOCS%%%%DOCSDIR%%/general/caching.html
+%%PORTDOCS%%%%DOCSDIR%%/general/common_functions.html
%%PORTDOCS%%%%DOCSDIR%%/general/controllers.html
%%PORTDOCS%%%%DOCSDIR%%/general/core_classes.html
%%PORTDOCS%%%%DOCSDIR%%/general/creating_libraries.html
@@ -36,12 +37,14 @@
%%PORTDOCS%%%%DOCSDIR%%/general/profiling.html
%%PORTDOCS%%%%DOCSDIR%%/general/quick_reference.html
%%PORTDOCS%%%%DOCSDIR%%/general/requirements.html
+%%PORTDOCS%%%%DOCSDIR%%/general/reserved_names.html
%%PORTDOCS%%%%DOCSDIR%%/general/routing.html
%%PORTDOCS%%%%DOCSDIR%%/general/scaffolding.html
%%PORTDOCS%%%%DOCSDIR%%/general/security.html
%%PORTDOCS%%%%DOCSDIR%%/general/urls.html
%%PORTDOCS%%%%DOCSDIR%%/general/views.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/array_helper.html
+%%PORTDOCS%%%%DOCSDIR%%/helpers/compatibility_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/cookie_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/date_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/directory_helper.html
@@ -50,7 +53,6 @@
%%PORTDOCS%%%%DOCSDIR%%/helpers/file_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/form_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/html_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/index.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/inflector_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/path_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/security_helper.html
@@ -89,6 +91,7 @@
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_154.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_160.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_161.html
+%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_162.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_b11.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrading.html
%%PORTDOCS%%%%DOCSDIR%%/libraries/benchmark.html
@@ -138,6 +141,9 @@
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/config.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php ]; then cp -p %D/%F %B/config.php; fi
+@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php has not been removed"; fi
+%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php.sample
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php ]; then cp -p %D/%F %B/constants.php; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/database.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php ]; then cp -p %D/%F %B/database.php; fi
@@ -226,6 +232,7 @@
%%WWWDIR%%/system/fonts/index.html
%%WWWDIR%%/system/fonts/texb.ttf
%%WWWDIR%%/system/helpers/array_helper.php
+%%WWWDIR%%/system/helpers/compatibility_helper.php
%%WWWDIR%%/system/helpers/cookie_helper.php
%%WWWDIR%%/system/helpers/date_helper.php
%%WWWDIR%%/system/helpers/directory_helper.php