aboutsummaryrefslogtreecommitdiff
path: root/www/comclear/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2000-11-26 14:16:22 +0000
committerPeter Pentchev <roam@FreeBSD.org>2000-11-26 14:16:22 +0000
commit62c9d63a82c5751c731fe4516fe90f317d7e5482 (patch)
tree0239078d08a273ea3eab678589f9c7b46693f44d /www/comclear/Makefile
parent9fae0f2e47c1435f4f6b104a2f0ea4d3f2a8e066 (diff)
downloadports-62c9d63a82c5751c731fe4516fe90f317d7e5482.tar.gz
ports-62c9d63a82c5751c731fe4516fe90f317d7e5482.zip
Notes
Diffstat (limited to 'www/comclear/Makefile')
-rw-r--r--www/comclear/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/comclear/Makefile b/www/comclear/Makefile
new file mode 100644
index 000000000000..1dd16edaec6d
--- /dev/null
+++ b/www/comclear/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: comclear
+# Date created: 26 November 2000
+# Whom: roam@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= comclear
+PORTVERSION= 1.1
+CATEGORIES= www
+MASTER_SITES= http://www.neuro-tech.net/files/
+
+MAINTAINER= roam@FreeBSD.org
+
+.if defined(WITH_GTK)
+BUILD_DEPENDS= ${X11BASE}/bin/gtk12-config:${PORTSDIR}/x11-toolkits/gtk12/
+CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
+.endif
+
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
+
+# Do not install docs by default, see the ifdef'd post-install below.
+post-configure:
+ ${PERL} -pi.fbsd -e 's/^install-data-am:.*/install-data-am:/' ${WRKSRC}/Makefile
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS:="@comment "
+.else
+PLIST_SUB+= PORTDOCS:=
+
+post-install:
+ cd ${WRKSRC} && ${GMAKE} install-docDATA
+.endif
+
+.include <bsd.port.mk>