aboutsummaryrefslogtreecommitdiff
path: root/www/commonist
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-09 23:15:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-09 23:15:39 +0000
commit60c5651deab2f04ee80ee051d217c2efc1887c69 (patch)
treed200d60c00359b0abbc150f8ec40061e69e0e0cd /www/commonist
parent8650a1cade105ab603bdd77dd128a6ae5116cc84 (diff)
downloadports-60c5651deab2f04ee80ee051d217c2efc1887c69.tar.gz
ports-60c5651deab2f04ee80ee051d217c2efc1887c69.zip
Notes
Diffstat (limited to 'www/commonist')
-rw-r--r--www/commonist/Makefile10
-rw-r--r--www/commonist/distinfo6
-rw-r--r--www/commonist/files/patch-Loader.java20
-rw-r--r--www/commonist/files/patch-Main.java19
-rw-r--r--www/commonist/files/patch-build.xml19
5 files changed, 24 insertions, 50 deletions
diff --git a/www/commonist/Makefile b/www/commonist/Makefile
index 68b3543704cd..a50d03e4c0cf 100644
--- a/www/commonist/Makefile
+++ b/www/commonist/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= commonist
-PORTVERSION= 0.3.28
-PORTREVISION= 1
+PORTVERSION= 0.3.32
CATEGORIES= www java
MASTER_SITES= http://djini.de/software/commonist/
@@ -20,13 +19,16 @@ USE_JAVA= 1.5+
JAVA_EXTRACT= yes
USE_ANT= yes
ALL_TARGET= jar
-MAKE_ARGS+= -Djar.lib.dir=${WRKSRC}/build/jar -Dtarget.name=${WRKSRC}/build/jar/${PORTNAME}.jar
+MAKE_FLAGS+= -verbose
+MAKE_ARGS+= -Djar.lib.dir=${WRKSRC}/build/jar -Dtarget.name=${WRKSRC}/build/jar/${PORTNAME}.jar \
+ -Djavacc.home=${JAVAJARDIR}
SUB_FILES+= commonist
SUB_LIST+= TARGET_JAR=${TARGET_JAR}
BUILD_DEPENDS+= ${JAVAJARDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
- ${JAVAJARDIR}/bsh.jar:${PORTSDIR}/lang/bsh
+ ${JAVAJARDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
+ ${JAVAJARDIR}/javacc.jar:${PORTSDIR}/textproc/javacc
RUN_DEPENDS+= ${JAVAJARDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVAJARDIR}/bsh.jar:${PORTSDIR}/lang/bsh
diff --git a/www/commonist/distinfo b/www/commonist/distinfo
index 023b06cf7c2e..463ed48078f8 100644
--- a/www/commonist/distinfo
+++ b/www/commonist/distinfo
@@ -1,3 +1,3 @@
-MD5 (commonist-0.3.28.zip) = a1a400b09825a16091457be880f8812a
-SHA256 (commonist-0.3.28.zip) = a6352b3939ae2561bf89314a79732443f7421c6a6d34e994c0b406cdee2d30b6
-SIZE (commonist-0.3.28.zip) = 2265234
+MD5 (commonist-0.3.32.zip) = e10de0993bca25dc80e316320a66f32d
+SHA256 (commonist-0.3.32.zip) = 9f55ecca1bd81181e03762f4de78acfba4cb270006a1441ae581338c7eae7ff8
+SIZE (commonist-0.3.32.zip) = 2338261
diff --git a/www/commonist/files/patch-Loader.java b/www/commonist/files/patch-Loader.java
deleted file mode 100644
index 7388a017d810..000000000000
--- a/www/commonist/files/patch-Loader.java
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/net/psammead/commonist/util/Loader.java.orig 2008-06-19 23:45:43.667197457 +0200
-+++ src/net/psammead/commonist/util/Loader.java 2008-06-19 23:46:41.729154606 +0200
-@@ -32,7 +32,7 @@
- File settingsFile = new File(settingsDir, path);
- if (settingsFile.exists()) {
- log.debug("loading from settings: " + path);
-- return settingsFile.toURL();
-+ return settingsFile.toURI().toURL();
- }
- }
- catch (MalformedURLException e) {
-@@ -43,7 +43,7 @@
- File projectFile = new File(projectDir, path);
- if (projectFile.exists()) {
- log.debug("loading from project: " + path);
-- return projectFile.toURL();
-+ return projectFile.toURI().toURL();
- }
- }
- catch (MalformedURLException e) {
diff --git a/www/commonist/files/patch-Main.java b/www/commonist/files/patch-Main.java
index eff175ca3f22..3aba5c0d7139 100644
--- a/www/commonist/files/patch-Main.java
+++ b/www/commonist/files/patch-Main.java
@@ -17,22 +17,3 @@
loader = new Loader(settingsDir, projectDir, "/etc/");
-@@ -77,8 +77,7 @@
- try { licenses = initLicenses(); }
- catch (IOException e) { throw new Error("cannot load licenses.txt"); }
-
-- try { mw = new MediaWiki(); }
-- catch (ConfigException e) { throw new Error("cannot instantiate MediaWiki"); }
-+ mw = new MediaWiki();
- mw.setLog(System.err);
- mw.setupProxy();
-
-@@ -226,7 +225,7 @@
- if (!file.getName().endsWith(".family")) continue;
- log.info("loading family: " + file);
- try {
-- mw.loadFamily(file.toURL());
-+ mw.loadFamily(file.toURI().toURL());
- }
- catch (ConfigException e) {
- log.error("could not load family from: " + file, e);
diff --git a/www/commonist/files/patch-build.xml b/www/commonist/files/patch-build.xml
index daa2ea89ed4f..4396a725b3bc 100644
--- a/www/commonist/files/patch-build.xml
+++ b/www/commonist/files/patch-build.xml
@@ -1,6 +1,17 @@
---- build.xml.orig 2008-01-17 21:47:36.000000000 +0100
-+++ build.xml 2008-06-20 01:11:45.983423901 +0200
-@@ -52,10 +52,9 @@
+--- build.xml.orig 2008-06-25 12:52:30.000000000 +0200
++++ build.xml 2008-12-23 06:09:36.963725735 +0100
+@@ -21,6 +21,10 @@
+
+ <target name="compile" description="compile java classes">
+ <mkdir dir="build/classes"/>
++ <javacc
++ target="src/net/psammead/minibpp/Parser.jj"
++ javacchome="${javacc.home}"
++ />
+ <javac
+ srcdir="src"
+ destdir="build/classes"
+@@ -52,10 +56,9 @@
<attribute name="Creator" value="${author}"/>
<attribute name="License" value="${license}"/>
@@ -8,7 +19,7 @@
- TODO: use a property, add binary.jars to classpath (manifestclasspath from ant 1.7.0)
<attribute name="Main-Class" value="net.psammead.commonist.Main"/>
- -->
-+ <attribute name="Class-Path" value="commons-httpclient.jar commons-codec.jar commons-logging.jar bsh.jar"/>
++ <attribute name="Class-Path" value="jericho-html.jar commons-httpclient.jar commons-codec.jar commons-logging.jar bsh.jar"/>
+
</manifest>
</jar>