aboutsummaryrefslogtreecommitdiff
path: root/www/cppcms
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2015-04-10 06:25:21 +0000
committerKevin Lo <kevlo@FreeBSD.org>2015-04-10 06:25:21 +0000
commit4fa4d8f767c43a09bbccaf8c11941c8948180267 (patch)
tree39bbc29ede63bd1b30eaa9d71de5e0c24651c4ea /www/cppcms
parentdea9500d97f0a1ce15d6e9047ac67e39f499ef37 (diff)
downloadports-4fa4d8f767c43a09bbccaf8c11941c8948180267.tar.gz
ports-4fa4d8f767c43a09bbccaf8c11941c8948180267.zip
Notes
Diffstat (limited to 'www/cppcms')
-rw-r--r--www/cppcms/Makefile45
-rw-r--r--www/cppcms/distinfo2
-rw-r--r--www/cppcms/pkg-descr11
-rw-r--r--www/cppcms/pkg-plist248
4 files changed, 306 insertions, 0 deletions
diff --git a/www/cppcms/Makefile b/www/cppcms/Makefile
new file mode 100644
index 000000000000..0cbb9321d831
--- /dev/null
+++ b/www/cppcms/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= cppcms
+PORTVERSION= 1.0.5
+CATEGORIES= www
+MASTER_SITES= SF/cppcms/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= C++ web development framework
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+
+USES= cmake tar:bzip2
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= EXAMPLES GCRYPT ICU
+OPTIONS_DEFAULT= ICU
+GCRYPT_DESC= libgcrypt support
+ICU_DESC= ICU unicode support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MICU}
+LIB_DEPENDS+= libicuuc.so:${PORTSDIR}/devel/icu
+CMAKE_ARGS+= -DDISABLE_ICONV:BOOL=ON
+.else
+USES+= iconv
+CMAKE_ARGS+= -DDISABLE_ICU_LOCALE:BOOL=ON
+.endif
+
+.if ${PORT_OPTIONS:MGCRYPT}
+LIB_DEPENDS+= libgcrypt.so:${PORTSDIR}/security/libgcrypt
+CMAKE_ARGS+= -DDISABLE_OPENSSL:BOOL=ON
+.else
+USE_OPENSSL= yes
+CMAKE_ARGS+= -DDISABLE_GCRYPT:BOOL=ON
+.endif
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/www/cppcms/distinfo b/www/cppcms/distinfo
new file mode 100644
index 000000000000..a05769010f6c
--- /dev/null
+++ b/www/cppcms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cppcms-1.0.5.tar.bz2) = 84b685977bca97c3e997497f227bd5906adb80555066d811a7046b01c2f51865
+SIZE (cppcms-1.0.5.tar.bz2) = 2509006
diff --git a/www/cppcms/pkg-descr b/www/cppcms/pkg-descr
new file mode 100644
index 000000000000..7b62c020182f
--- /dev/null
+++ b/www/cppcms/pkg-descr
@@ -0,0 +1,11 @@
+CppCMS is a free high performance web development framework aimed at
+rapid web application development. It differs from most other web
+development frameworks like: Python Django, Java Servlets in the
+following ways:
+
+* It is designed and tuned to handle extremely high loads.
+* It uses modern C++ as the primary development language in order to
+ achieve the first goal.
+* It is designed for developing both web sites and web services.
+
+WWW: http://www.cppcms.com
diff --git a/www/cppcms/pkg-plist b/www/cppcms/pkg-plist
new file mode 100644
index 000000000000..78ebbef23a29
--- /dev/null
+++ b/www/cppcms/pkg-plist
@@ -0,0 +1,248 @@
+bin/cppcms_config_find_param
+bin/cppcms_make_key
+bin/cppcms_run
+bin/cppcms_scale
+bin/cppcms_tmpl_cc
+include/booster/aio/acceptor.h
+include/booster/aio/aio_category.h
+include/booster/aio/aio_config.h
+include/booster/aio/basic_io_device.h
+include/booster/aio/basic_socket.h
+include/booster/aio/buffer.h
+include/booster/aio/deadline_timer.h
+include/booster/aio/endpoint.h
+include/booster/aio/io_service.h
+include/booster/aio/reactor.h
+include/booster/aio/socket.h
+include/booster/aio/stream_socket.h
+include/booster/aio/types.h
+include/booster/assert.h
+include/booster/atomic_counter.h
+include/booster/backtrace.h
+include/booster/bad_weak_ptr.h
+include/booster/build_config.h
+include/booster/callback.h
+include/booster/checked_delete.h
+include/booster/clone_ptr.h
+include/booster/config.h
+include/booster/copy_ptr.h
+include/booster/cstdint.h
+include/booster/ctime.h
+include/booster/enable_shared_from_this.h
+include/booster/function.h
+include/booster/hold_ptr.h
+include/booster/intrusive_ptr.h
+include/booster/iterator/iterator_facade.h
+include/booster/locale.h
+include/booster/locale/boundary.h
+include/booster/locale/boundary/boundary_point.h
+include/booster/locale/boundary/facets.h
+include/booster/locale/boundary/index.h
+include/booster/locale/boundary/segment.h
+include/booster/locale/boundary/types.h
+include/booster/locale/collator.h
+include/booster/locale/config.h
+include/booster/locale/conversion.h
+include/booster/locale/date_time.h
+include/booster/locale/date_time_facet.h
+include/booster/locale/encoding.h
+include/booster/locale/encoding_errors.h
+include/booster/locale/encoding_utf.h
+include/booster/locale/format.h
+include/booster/locale/formatting.h
+include/booster/locale/generator.h
+include/booster/locale/gnu_gettext.h
+include/booster/locale/hold_ptr.h
+include/booster/locale/info.h
+include/booster/locale/localization_backend.h
+include/booster/locale/message.h
+include/booster/locale/time_zone.h
+include/booster/locale/utf.h
+include/booster/locale/util.h
+include/booster/log.h
+include/booster/noncopyable.h
+include/booster/nowide/convert.h
+include/booster/nowide/cstdio.h
+include/booster/nowide/fstream.h
+include/booster/perl_regex.h
+include/booster/posix_time.h
+include/booster/refcounted.h
+include/booster/regex.h
+include/booster/regex_match.h
+include/booster/shared_object.h
+include/booster/shared_ptr.h
+include/booster/smart_ptr/operator_bool.h
+include/booster/smart_ptr/shared_count.h
+include/booster/smart_ptr/sp_convertible.h
+include/booster/smart_ptr/sp_counted_base.h
+include/booster/smart_ptr/sp_counted_impl.h
+include/booster/smart_ptr/sp_typeinfo.h
+include/booster/streambuf.h
+include/booster/system_error.h
+include/booster/thread.h
+include/booster/traits/enable_if.h
+include/booster/traits/is_base_of.h
+include/booster/weak_ptr.h
+include/cppcms/application.h
+include/cppcms/applications_pool.h
+include/cppcms/archive_traits.h
+include/cppcms/base64.h
+include/cppcms/base_cache_fwd.h
+include/cppcms/base_content.h
+include/cppcms/base_view.h
+include/cppcms/cache_interface.h
+include/cppcms/cache_pool.h
+include/cppcms/config.h
+include/cppcms/copy_filter.h
+include/cppcms/cppcms_error.h
+include/cppcms/crypto.h
+include/cppcms/cstdint.h
+include/cppcms/defs.h
+include/cppcms/encoding.h
+include/cppcms/filters.h
+include/cppcms/form.h
+include/cppcms/forwarder.h
+include/cppcms/http_content_type.h
+include/cppcms/http_context.h
+include/cppcms/http_cookie.h
+include/cppcms/http_file.h
+include/cppcms/http_request.h
+include/cppcms/http_response.h
+include/cppcms/json.h
+include/cppcms/locale_fwd.h
+include/cppcms/localization.h
+include/cppcms/mem_bind.h
+include/cppcms/mount_point.h
+include/cppcms/rpc_json.h
+include/cppcms/serialization.h
+include/cppcms/serialization_classes.h
+include/cppcms/service.h
+include/cppcms/session_api.h
+include/cppcms/session_cookies.h
+include/cppcms/session_dual.h
+include/cppcms/session_interface.h
+include/cppcms/session_pool.h
+include/cppcms/session_sid.h
+include/cppcms/session_storage.h
+include/cppcms/steal_buf.h
+include/cppcms/string_key.h
+include/cppcms/thread_pool.h
+include/cppcms/urandom.h
+include/cppcms/url_dispatcher.h
+include/cppcms/url_mapper.h
+include/cppcms/util.h
+include/cppcms/view.h
+include/cppcms/views_pool.h
+include/cppcms/xss.h
+lib/libbooster.a
+lib/libbooster.so
+lib/libbooster.so.0
+lib/libbooster.so.0.0.3
+lib/libcppcms.a
+lib/libcppcms.so
+lib/libcppcms.so.1
+lib/libcppcms.so.1.0.5
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/aio/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/aio/echo_server.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/autogenerated.doxy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_cache/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_cache/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_cache/content.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_cache/hello.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_cache/view.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chat/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chat/chat.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chat/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chat/the_chat.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples.doxy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/format.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/forms/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/forms/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/forms/content.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/forms/hello.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/forms/view.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/hello.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hierarchy/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hierarchy/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hierarchy/myapp.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json/json.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc/rpc.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc/usingrpc.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc_chat/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc_chat/chat.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc_chat/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/json_rpc_chat/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/localization/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/localization/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/localization/content.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/localization/hello.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/localization/locale/he/LC_MESSAGES/hello.po
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/localization/view.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/CMakeLists.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/forums.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/forums.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/main.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/master.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/master.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/mb.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/mb.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/thread.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/apps/thread.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/data/data.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/data/forums.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/data/master.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/data/thread.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/locale/he/LC_MESSAGES/mb.po
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/media/style-ltr.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/media/style-rtl.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/media/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/model/mysql.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/model/sqlite3.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/view/forums.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/view/master.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/message_board/view/thread.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/serialization/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/serialization/external_serialization.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/serialization/serialization.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sessions/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sessions/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sessions/content.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sessions/hello.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sessions/view.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/Makefile.dyn
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/config-dyn.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/content.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/first.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/hello-tmpl.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/content.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/intro.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/master.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/myapp.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/news.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates_inheritance/page.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uploads/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uploads/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uploads/content.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uploads/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uploads/uploader.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uploads/view.tmpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/url_mapping/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/url_mapping/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/url_mapping/hello.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xss/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xss/comment_profile.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xss/config.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xss/tinymce_profile.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xss/xss.cpp