aboutsummaryrefslogtreecommitdiff
path: root/www/crawl
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-12-21 18:39:12 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-12-21 18:39:12 +0000
commita8c91e1d261d9d9557d8b9b6bc18dc6a409d87ea (patch)
tree691ab3064e0c0d1f9c98394ca3c24890391eba5d /www/crawl
parentdbd5d617998c0d43f0563976a0772b03937ff801 (diff)
downloadports-a8c91e1d261d9d9557d8b9b6bc18dc6a409d87ea.tar.gz
ports-a8c91e1d261d9d9557d8b9b6bc18dc6a409d87ea.zip
Notes
Diffstat (limited to 'www/crawl')
-rw-r--r--www/crawl/Makefile16
-rw-r--r--www/crawl/distinfo2
-rw-r--r--www/crawl/files/patch-Makefile.in10
-rw-r--r--www/crawl/files/patch-configure (renamed from www/crawl/files/patch-configure.in)16
4 files changed, 25 insertions, 19 deletions
diff --git a/www/crawl/Makefile b/www/crawl/Makefile
index bcd03617cc83..1a4bdb161f08 100644
--- a/www/crawl/Makefile
+++ b/www/crawl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= crawl
-PORTVERSION= 0.3
-PORTREVISION= 2
+PORTVERSION= 0.4
CATEGORIES= www
MASTER_SITES= http://www.monkey.org/~provos/
@@ -17,20 +16,15 @@ COMMENT= A small, efficient web crawler with advanced features
BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
+GNU_CONFIGURE= yes
USE_REINPLACE= yes
-USE_AUTOCONF= yes
-CONFIGURE_ARGS= --with-libevent=${LOCALBASE}
-CONFIGURE_ENV= LIBS="${LDFLAGS} -lmd"
-CFLAGS+= -D__FUNCTION__='""'
+CONFIGURE_ARGS+= --with-libevent=${LOCALBASE} --program-transform-name=''
MAN1= crawl.1
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/include/db2,${LOCALBASE}/include/db3,g ; \
- s,db2,db3,g' ${WRKSRC}/configure.in
- ${CHMOD} u+w ${WRKSRC}/*
+ @${REINPLACE_CMD} -e 's,/usr/include/db2,${LOCALBASE}/include/db3,g' \
+ -e 's,db2,db3,g' ${WRKSRC}/configure.in
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/crawl/distinfo b/www/crawl/distinfo
index eb9856eabbcc..1bf0ef1eec2b 100644
--- a/www/crawl/distinfo
+++ b/www/crawl/distinfo
@@ -1 +1 @@
-MD5 (crawl-0.3.tar.gz) = 5281f076276f65b62bfb0e994c1bbb81
+MD5 (crawl-0.4.tar.gz) = b1cce00b14d29eb715d3537fac75309e
diff --git a/www/crawl/files/patch-Makefile.in b/www/crawl/files/patch-Makefile.in
new file mode 100644
index 000000000000..0f6ac92fab60
--- /dev/null
+++ b/www/crawl/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig Sat May 17 20:50:51 2003
++++ Makefile.in Sun Dec 21 12:19:52 2003
+@@ -159,7 +154,6 @@
+ $(MAKE) $(srcdir)/stamp-h.in; \
+ else :; fi
+ $(srcdir)/stamp-h.in: $(top_srcdir)/configure.in $(ACLOCAL_M4) acconfig.h
+- cd $(top_srcdir) && $(AUTOHEADER)
+ @echo timestamp > $(srcdir)/stamp-h.in 2> /dev/null
+
+ mostlyclean-hdr:
diff --git a/www/crawl/files/patch-configure.in b/www/crawl/files/patch-configure
index 9de236fb45a9..7f99fc735e42 100644
--- a/www/crawl/files/patch-configure.in
+++ b/www/crawl/files/patch-configure
@@ -1,9 +1,11 @@
---- configure.in.orig Wed Jun 20 14:41:44 2001
-+++ configure.in Wed Jun 20 17:30:07 2001
-@@ -38,11 +38,11 @@
- ;;
+$FreeBSD$
+
+--- configure.orig Sun Dec 21 12:18:11 2003
++++ configure Sun Dec 21 12:18:28 2003
+@@ -2545,11 +2545,11 @@
*)
- AC_MSG_RESULT($withval)
+ echo "$as_me:$LINENO: result: $withval" >&5
+ echo "${ECHO_T}$withval" >&6
- if test -f $withval/event.h -a -f $withval/libevent.a; then
+ if test -f $withval/include/event.h -a -f $withval/lib/libevent.a; then
owd=`pwd`
@@ -13,5 +15,5 @@
+ EVENTINC="-I$withval/include"
+ EVENTLIB="-L$withval/lib -levent"
else
- AC_ERROR(event.h or libevent.a not found in $withval)
- fi
+ { { echo "$as_me:$LINENO: error: event.h or libevent.a not found in $withval" >&5
+ echo "$as_me: error: event.h or libevent.a not found in $withval" >&2;}