aboutsummaryrefslogtreecommitdiff
path: root/www/crp/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-01 18:14:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-01 18:14:18 +0000
commit9968b6382a73379f2c137d38d7369fc36ca7d1e0 (patch)
treeaa27031ff8d7b59c9b122e4cfd9c1abac7c535ae /www/crp/Makefile
parent95f1f29249c85ed8fa166aca95d04182f3d3bcf8 (diff)
downloadports-9968b6382a73379f2c137d38d7369fc36ca7d1e0.tar.gz
ports-9968b6382a73379f2c137d38d7369fc36ca7d1e0.zip
Notes
Diffstat (limited to 'www/crp/Makefile')
-rw-r--r--www/crp/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/www/crp/Makefile b/www/crp/Makefile
new file mode 100644
index 000000000000..28a3ce1a2c48
--- /dev/null
+++ b/www/crp/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: crp
+# Date created: June 01 2004
+# Whom: Lars Eggert <lars.eggert@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crp
+PORTVERSION= 20031012
+CATEGORIES= www science
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= CRP
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Automates the process of being the program chair of a conference
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+
+WWWDIR?= ${PREFIX}/www
+SPOOLDIR?= /var/spool/conference
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-patch:
+ @${SED} -e 's|%%WWWDIR%%|${WWWDIR}|g; s|%%DISTNAME%%|${DISTNAME}|g' \
+ ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
+
+do-install:
+ @${MKDIR} -m 755 ${WWWDIR} ${SPOOLDIR}
+ @${CP} -R ${WRKSRC} ${WWWDIR}
+ @${SED} -e 's#/var/www/html#${PREFIX}/www/${DISTNAME}#' \
+ ${WRKSRC}/Code/confHeader.inc > ${WWWDIR}/${DISTNAME}/Code/confHeader.inc
+ @${CHOWN} -R ${WWWOWN}:${WWWGROUP} ${WWWDIR}/${DISTNAME} ${SPOOLDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>