aboutsummaryrefslogtreecommitdiff
path: root/www/dansguardian-devel
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-10 15:28:46 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-10 15:28:46 +0000
commit60185927834fffead454f42d67bd1f57748f3414 (patch)
tree49523a4230ac572c356af5b26996a8a9d9928c6d /www/dansguardian-devel
parent22395d69b90df4acad08d01c7804ae63ee6ab0ce (diff)
downloadports-60185927834fffead454f42d67bd1f57748f3414.tar.gz
ports-60185927834fffead454f42d67bd1f57748f3414.zip
Notes
Diffstat (limited to 'www/dansguardian-devel')
-rw-r--r--www/dansguardian-devel/Makefile19
-rw-r--r--www/dansguardian-devel/distinfo6
-rw-r--r--www/dansguardian-devel/files/patch-Makefile.in8
-rw-r--r--www/dansguardian-devel/pkg-plist6
4 files changed, 18 insertions, 21 deletions
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index e8457d8ef93b..671ee33df909 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dansguardian
-PORTVERSION= 2.9.3.2
+PORTVERSION= 2.9.5.0
CATEGORIES= www
MASTER_SITES= # empty, see below
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -14,12 +14,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= fcash@sd73.bc.ca
COMMENT= A fast, feature-rich web content filter for Squid proxy servers
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- iconv.3:${PORTSDIR}/converters/libiconv
-
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
USE_GCC= 3.4+
+USE_ICONV= yes
USE_RC_SUBR= dansguardian.sh
@@ -43,9 +42,9 @@ OPTIONS= DG_APACHE "Enable Apache support" on \
DG_URL= http://dansguardian.org/index.php?page=copyright2
CONFDIR= ${PREFIX}/etc/dansguardian
-NO_CDROM= "Commercial download is restricted. Check ${DG_URL} for more info"
-NO_PACKAGE= "Redistribution is restricted. Check ${DG_URL} for more info"
-RESTRICTED= "${NO_PACKAGE}"
+NO_CDROM= Commercial download is restricted. Check ${DG_URL} for more info
+NO_PACKAGE= Redistribution is restricted. Check ${DG_URL} for more info
+RESTRICTED= ${NO_PACKAGE}
.include <bsd.port.pre.mk>
@@ -55,7 +54,7 @@ USE_APACHE= 1.3+
.if defined(WITH_DG_CLAMAV)
CONFIGURE_ARGS+= --enable-clamav=yes
-LIB_DEPENDS+= clamav.1:${PORTSDIR}/security/clamav:install
+LIB_DEPENDS+= clamav.1:${PORTSDIR}/security/clamav
.endif
.if defined(WITH_DG_CLAMD)
@@ -64,11 +63,11 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
.endif
.if defined(WITH_DG_ICAP)
-BROKEN= "I don't have access to ICAP AV, so I can't test this. If you have access to it, drop me an e-mail. Thanks"
+BROKEN= I don't have access to ICAP AV, so I can't test this. If you have access to it, drop me an e-mail. Thanks
.endif
.if defined(WITH_DG_KASP)
-BROKEN= "I don't have access to Kaspersky AV, so I can't test this. If you have access to it, drop me an e-mail. Thanks"
+BROKEN= I don't have access to Kaspersky AV, so I can't test this. If you have access to it, drop me an e-mail. Thanks
.endif
.if defined(WITH_DG_DMGR)
diff --git a/www/dansguardian-devel/distinfo b/www/dansguardian-devel/distinfo
index 8eff9a5ad583..c4e651a61b10 100644
--- a/www/dansguardian-devel/distinfo
+++ b/www/dansguardian-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (dansguardian-2.9.3.2.tar.gz) = 9683eab32ee99f270213c394713de171
-SHA256 (dansguardian-2.9.3.2.tar.gz) = c6ac384e9a9205d37f350c1a803cc8c04594e486868b40ebcd8d36405aaef605
-SIZE (dansguardian-2.9.3.2.tar.gz) = 402793
+MD5 (dansguardian-2.9.5.0.tar.gz) = 40da3170df0b1f2def892316e13bcd9c
+SHA256 (dansguardian-2.9.5.0.tar.gz) = 1dae71135b94f2b3ae9cf6d5cf066afcd6954b2444c60f9fe4febc8b946d9f2d
+SIZE (dansguardian-2.9.5.0.tar.gz) = 411920
diff --git a/www/dansguardian-devel/files/patch-Makefile.in b/www/dansguardian-devel/files/patch-Makefile.in
index 620abcd36f09..6ff0b5acf3ae 100644
--- a/www/dansguardian-devel/files/patch-Makefile.in
+++ b/www/dansguardian-devel/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Fri Dec 16 09:25:29 2005
-+++ Makefile.in Fri Dec 16 09:25:46 2005
-@@ -615,10 +615,10 @@
+--- Makefile.in.orig Thu Feb 2 03:06:47 2006
++++ Makefile.in Thu Feb 9 14:34:35 2006
+@@ -617,10 +617,12 @@
install-data-local:
@@ -12,6 +12,8 @@
+# $(mkinstalldirs) $(DESTDIR)$(DGLOGLOCATION) && \
+# chown -R $(DGPROXYUSER):$(DGPROXYGROUP) $(DESTDIR)$(DGLOGLOCATION); \
+# fi
++ touch $(DGLOGLOCATION)/dansguardian.log
++ chown $(DGPROXYUSER):$(DGPROXYGROUP) $(DGLOGLOCATION)/dansguardian.log
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
diff --git a/www/dansguardian-devel/pkg-plist b/www/dansguardian-devel/pkg-plist
index b45fdca20c30..bbc544399595 100644
--- a/www/dansguardian-devel/pkg-plist
+++ b/www/dansguardian-devel/pkg-plist
@@ -136,8 +136,7 @@ sbin/dansguardian
%%DATADIR%%/scripts/systemv-init
etc/dansguardian/authplugins/ident.conf
etc/dansguardian/authplugins/ip.conf
-etc/dansguardian/authplugins/ntlm.conf
-etc/dansguardian/authplugins/proxy.conf
+etc/dansguardian/authplugins/proxy-basic.conf
etc/dansguardian/lists/authplugins/ipgroups
etc/dansguardian/lists/blacklists/ads/domains
etc/dansguardian/lists/blacklists/ads/urls
@@ -223,9 +222,6 @@ etc/dansguardian/downloadmanagers/default.conf
etc/dansguardian/downloadmanagers/fancy.conf
etc/dansguardian/contentscanners/clamav.conf
etc/dansguardian/contentscanners/clamdscan.conf
-etc/dansguardian/contentscanners/icapscan.conf
-etc/dansguardian/contentscanners/kavav.conf
-etc/dansguardian/contentscanners/kavdscan.conf
etc/dansguardian/dansguardian.conf
etc/dansguardian/dansguardianf1.conf
@dirrm %%DATADIR%%/scripts