aboutsummaryrefslogtreecommitdiff
path: root/www/davix
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-04 03:26:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-04 03:26:58 +0000
commita525b4c2c27f572eafd64ad567d6d93505ca1592 (patch)
treed1e8825e7f219766b46097ad01ddae5317cc444b /www/davix
parentb53623defe42fd8799c8698047409fc132401fac (diff)
downloadports-a525b4c2c27f572eafd64ad567d6d93505ca1592.tar.gz
ports-a525b4c2c27f572eafd64ad567d6d93505ca1592.zip
Notes
Diffstat (limited to 'www/davix')
-rw-r--r--www/davix/Makefile6
-rw-r--r--www/davix/distinfo4
-rw-r--r--www/davix/files/patch-src_libs_datetime_datetime__utils.cpp44
3 files changed, 8 insertions, 46 deletions
diff --git a/www/davix/Makefile b/www/davix/Makefile
index 825e875459ae..b3b61ffb3de0 100644
--- a/www/davix/Makefile
+++ b/www/davix/Makefile
@@ -2,8 +2,12 @@
PORTNAME= davix
DISTVERSION= 0.6.9
-MASTER_SITES= http://grid-deployment.web.cern.ch/grid-deployment/dms/lcgutil/tar/davix/${DISTVERSION}/
+PORTREVISION= 1
CATEGORIES= www
+MASTER_SITES= http://grid-deployment.web.cern.ch/grid-deployment/dms/lcgutil/tar/davix/${DISTVERSION}/
+
+PATCH_SITES= https://github.com/cern-fts/davix/commit/
+PATCHFILES= 8e6386f64187cf32a32627033105e3a641f6b3d2.patch:-p1
MAINTAINER= yuri@FreeBSD.org
COMMENT= Make the task of managing files over HTTP-based protocols simple
diff --git a/www/davix/distinfo b/www/davix/distinfo
index 1a86fff68bb1..a43e387374f5 100644
--- a/www/davix/distinfo
+++ b/www/davix/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1538501544
+TIMESTAMP = 1538623319
SHA256 (davix-0.6.9.tar.gz) = fbd97eb5fdf82ca48770d06bf8e2805b35f23255478aa381a9d25a49eb98e348
SIZE (davix-0.6.9.tar.gz) = 4333197
+SHA256 (8e6386f64187cf32a32627033105e3a641f6b3d2.patch) = 5666a12d11cfb4e2278e4488031aea4c061f12409bd60805052b1e620be66ab4
+SIZE (8e6386f64187cf32a32627033105e3a641f6b3d2.patch) = 951
diff --git a/www/davix/files/patch-src_libs_datetime_datetime__utils.cpp b/www/davix/files/patch-src_libs_datetime_datetime__utils.cpp
deleted file mode 100644
index a467cd259e89..000000000000
--- a/www/davix/files/patch-src_libs_datetime_datetime__utils.cpp
+++ /dev/null
@@ -1,44 +0,0 @@
---- src/libs/datetime/datetime_utils.cpp.orig 2018-06-16 07:41:55 UTC
-+++ src/libs/datetime/datetime_utils.cpp
-@@ -19,6 +19,7 @@
- */
-
- #include <davix_internal_config.hpp>
-+#include <sys/time.h>
- #include "datetime_utils.hpp"
-
- time_t parse_http_date(const char* http_date){
-@@ -32,7 +33,15 @@ time_t parse_http_date(const char* http_
- if ( p == NULL || *p != '\0'){
- return -1;
- }
-- return mktime(&tm) - timezone;;
-+ int _timezone = 0;
-+ {
-+ struct timeval tv;
-+ struct timezone tz;
-+ gettimeofday( &tv, &tz );
-+ _timezone = -tz.tz_minuteswest * 60;
-+ }
-+
-+ return mktime(&tm) - _timezone;;
-
- }
-
-@@ -70,8 +79,15 @@ time_t parse_iso8601date(const char* iso
- }
- }
-
-+ int _timezone = 0;
-+ {
-+ struct timeval tv;
-+ struct timezone tz;
-+ gettimeofday( &tv, &tz );
-+ _timezone = -tz.tz_minuteswest * 60;
-+ }
-
-- return mktime(&tm_time) - timezone;
-+ return mktime(&tm_time) - _timezone;
-
- }
-