aboutsummaryrefslogtreecommitdiff
path: root/www/decss/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 13:08:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 13:08:38 +0000
commit4c8380565eec68e2ecdfd71ed3394bc8f1efb42e (patch)
treeb7d62fcc4822976d259605742b2e0c985f80b2b8 /www/decss/Makefile
parent91e42cc7ad2d29b786c51a19760f4b71e89d93b2 (diff)
downloadports-4c8380565eec68e2ecdfd71ed3394bc8f1efb42e.tar.gz
ports-4c8380565eec68e2ecdfd71ed3394bc8f1efb42e.zip
Notes
Diffstat (limited to 'www/decss/Makefile')
-rw-r--r--www/decss/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/www/decss/Makefile b/www/decss/Makefile
index f7d4668ea191..bf1ddf0bf202 100644
--- a/www/decss/Makefile
+++ b/www/decss/Makefile
@@ -12,15 +12,21 @@ COMMENT= Strip cascading style sheets from webpages
WRKSRC= ${WRKDIR}/source
-NO_BUILD= YES
-USES= perl5
+USES= perl5 shebangfix
+NO_BUILD= yes
+
+PLIST_FILES= bin/decss
+PORTDOCS= FAQ README decss-now.png decss_mirror.html \
+ original_pigdog_article.txt
+SHEBANG_FILES= DeCSS
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/DeCSS ${PREFIX}/bin/decss
- ${MKDIR} ${PREFIX}/share/doc/decss
-.for i in FAQ README decss-now.png decss_mirror.html original_pigdog_article.txt
- ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/decss
+ ${INSTALL_SCRIPT} ${WRKSRC}/DeCSS ${STAGEDIR}${PREFIX}/bin/decss
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>