aboutsummaryrefslogtreecommitdiff
path: root/www/dfileserver/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-11-01 15:20:29 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-11-01 15:20:29 +0000
commit3b420afacd416a9c202523df7d2fc8f2e54cb81b (patch)
treef6d5861b4698f59b44afdbfd79bf93ac46664808 /www/dfileserver/Makefile
parent9e3552be9d0513237698c002311d11d328824205 (diff)
downloadports-3b420afacd416a9c202523df7d2fc8f2e54cb81b.tar.gz
ports-3b420afacd416a9c202523df7d2fc8f2e54cb81b.zip
Notes
Diffstat (limited to 'www/dfileserver/Makefile')
-rw-r--r--www/dfileserver/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/www/dfileserver/Makefile b/www/dfileserver/Makefile
index bedb9039acd6..16462a521618 100644
--- a/www/dfileserver/Makefile
+++ b/www/dfileserver/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DFileServer
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.3
CATEGORIES= www
MASTER_SITES= http://harpy.soarwitheagles.net/~dashy/
@@ -18,6 +18,7 @@ PLIST_FILES= bin/dfileserver
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV= CXX=${CXX}
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -25,6 +26,10 @@ MAKE_ENV= CXX=${CXX}
USE_GCC= 3.4+
.endif
+post-patch:
+ ${REINPLACE_CMD} 's,g++,${CXX},;s,$$GCCFLAGS,${CXXFLAGS},; \
+ s,strip,${STRIP_CMD},' ${WRKSRC}/build.sh
+
do-build:
@(cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ./build.sh)