aboutsummaryrefslogtreecommitdiff
path: root/www/dfileserver
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-15 19:50:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-15 19:50:00 +0000
commitcbe8e6b2569fa8932c8df5587a3a36b63523888a (patch)
tree3ca248f63167e7847ed4ccfd07cb5f58e8a9a564 /www/dfileserver
parent15dfb6c0e73d29acfe53b92e215d2e73ffef9cef (diff)
downloadports-cbe8e6b2569fa8932c8df5587a3a36b63523888a.tar.gz
ports-cbe8e6b2569fa8932c8df5587a3a36b63523888a.zip
Notes
Diffstat (limited to 'www/dfileserver')
-rw-r--r--www/dfileserver/Makefile35
-rw-r--r--www/dfileserver/distinfo2
-rw-r--r--www/dfileserver/files/patch-build.sh35
-rw-r--r--www/dfileserver/pkg-descr11
4 files changed, 83 insertions, 0 deletions
diff --git a/www/dfileserver/Makefile b/www/dfileserver/Makefile
new file mode 100644
index 000000000000..bedb9039acd6
--- /dev/null
+++ b/www/dfileserver/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: DFileServer
+# Date created: 8 September 2005
+# Whom: Dash|RD
+#
+# $FreeBSD$
+#
+
+PORTNAME= DFileServer
+PORTVERSION= 1.1.2
+CATEGORIES= www
+MASTER_SITES= http://harpy.soarwitheagles.net/~dashy/
+
+MAINTAINER= dashevil@gmail.com
+COMMENT= A compact webserver designed to make sharing files easy
+
+PLIST_FILES= bin/dfileserver
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAKE_ENV= CXX=${CXX}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4+
+.endif
+
+do-build:
+ @(cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ./build.sh)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/DFileServer.x86 ${PREFIX}/bin/dfileserver
+
+.include <bsd.port.post.mk>
diff --git a/www/dfileserver/distinfo b/www/dfileserver/distinfo
new file mode 100644
index 000000000000..3080e932cb4e
--- /dev/null
+++ b/www/dfileserver/distinfo
@@ -0,0 +1,2 @@
+MD5 (DFileServer-1.1.2.tar.gz) = 60d20b8012a801b564abbf8fde5e052d
+SIZE (DFileServer-1.1.2.tar.gz) = 20448
diff --git a/www/dfileserver/files/patch-build.sh b/www/dfileserver/files/patch-build.sh
new file mode 100644
index 000000000000..2f0c4031e43d
--- /dev/null
+++ b/www/dfileserver/files/patch-build.sh
@@ -0,0 +1,35 @@
+--- build.sh.orig Sun Jun 19 07:07:05 2005
++++ build.sh Thu Sep 15 21:44:32 2005
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-GCCFLAGS="-Wall -Werror -O3"
++GCCFLAGS=${CFLAGS}
+
+ mkdir ./obj/
+ mkdir ./obj/contrib/
+@@ -8,18 +8,18 @@
+ echo "Native Build:" $GCCFLAGS
+
+ echo "Compiling src/DashFileServer.cxx"
+-g++ $GCCFLAGS -c src/DashFileServer.cxx -o obj/DashFileServer.o
++${CXX} $GCCFLAGS -c src/DashFileServer.cxx -o obj/DashFileServer.o
+ echo "Compiling src/ClientConnection.cxx"
+-g++ $GCCFLAGS -c src/ClientConnection.cxx -o obj/ClientConnection.o
++${CXX} $GCCFLAGS -c src/ClientConnection.cxx -o obj/ClientConnection.o
+ echo "Compiling src/CPathResolver.cxx"
+-g++ $GCCFLAGS -c src/CPathResolver.cxx -o obj/CPathResolver.o
++${CXX} $GCCFLAGS -c src/CPathResolver.cxx -o obj/CPathResolver.o
+ echo "Compiling src/DirectoryIndexing.cxx"
+-g++ $GCCFLAGS -c src/DirectoryIndexing.cxx -o obj/DirectoryIndexing.o
++${CXX} $GCCFLAGS -c src/DirectoryIndexing.cxx -o obj/DirectoryIndexing.o
+ echo "Compiling src/MimeTypes.cxx"
+-g++ $GCCFLAGS -c src/MimeTypes.cxx -o obj/MimeTypes.o
++${CXX} $GCCFLAGS -c src/MimeTypes.cxx -o obj/MimeTypes.o
+
+ echo "Linking..."
+-g++ -o DFileServer.x86 obj/DashFileServer.o obj/ClientConnection.o obj/CPathResolver.o obj/DirectoryIndexing.o obj/MimeTypes.o
++${CXX} -o DFileServer.x86 obj/DashFileServer.o obj/ClientConnection.o obj/CPathResolver.o obj/DirectoryIndexing.o obj/MimeTypes.o
+
+ echo "Striping..."
+ strip --strip-all DFileServer.x86
diff --git a/www/dfileserver/pkg-descr b/www/dfileserver/pkg-descr
new file mode 100644
index 000000000000..30a74e8b5081
--- /dev/null
+++ b/www/dfileserver/pkg-descr
@@ -0,0 +1,11 @@
+A small and simple webserver programmed in C++ that was designed to make
+sharing files easy.
+
+By default, it shares whatever folder it was executed from on port 2000.
+While simple, a good deal of flexibility is exposed when you read the
+documentation and look at the optional configuration files, provided
+seperately here:
+http://harpy.soarwitheagles.net/~dashy/DFileServer-1.1.2-documentation.tar.gz
+
+- Chris Laverdure
+dashevil@gmail.com