aboutsummaryrefslogtreecommitdiff
path: root/www/dfileserver
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-11-01 15:20:29 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-11-01 15:20:29 +0000
commit3b420afacd416a9c202523df7d2fc8f2e54cb81b (patch)
treef6d5861b4698f59b44afdbfd79bf93ac46664808 /www/dfileserver
parent9e3552be9d0513237698c002311d11d328824205 (diff)
downloadports-3b420afacd416a9c202523df7d2fc8f2e54cb81b.tar.gz
ports-3b420afacd416a9c202523df7d2fc8f2e54cb81b.zip
Notes
Diffstat (limited to 'www/dfileserver')
-rw-r--r--www/dfileserver/Makefile7
-rw-r--r--www/dfileserver/distinfo4
-rw-r--r--www/dfileserver/files/patch-build.sh35
3 files changed, 8 insertions, 38 deletions
diff --git a/www/dfileserver/Makefile b/www/dfileserver/Makefile
index bedb9039acd6..16462a521618 100644
--- a/www/dfileserver/Makefile
+++ b/www/dfileserver/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DFileServer
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.3
CATEGORIES= www
MASTER_SITES= http://harpy.soarwitheagles.net/~dashy/
@@ -18,6 +18,7 @@ PLIST_FILES= bin/dfileserver
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV= CXX=${CXX}
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -25,6 +26,10 @@ MAKE_ENV= CXX=${CXX}
USE_GCC= 3.4+
.endif
+post-patch:
+ ${REINPLACE_CMD} 's,g++,${CXX},;s,$$GCCFLAGS,${CXXFLAGS},; \
+ s,strip,${STRIP_CMD},' ${WRKSRC}/build.sh
+
do-build:
@(cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ./build.sh)
diff --git a/www/dfileserver/distinfo b/www/dfileserver/distinfo
index 3080e932cb4e..71498ca245ee 100644
--- a/www/dfileserver/distinfo
+++ b/www/dfileserver/distinfo
@@ -1,2 +1,2 @@
-MD5 (DFileServer-1.1.2.tar.gz) = 60d20b8012a801b564abbf8fde5e052d
-SIZE (DFileServer-1.1.2.tar.gz) = 20448
+MD5 (DFileServer-1.1.3.tar.gz) =3D 439970464d42a2639e31076ffa4d3c14
+SIZE (DFileServer-1.1.3.tar.gz) =3D 22909
diff --git a/www/dfileserver/files/patch-build.sh b/www/dfileserver/files/patch-build.sh
deleted file mode 100644
index 2f0c4031e43d..000000000000
--- a/www/dfileserver/files/patch-build.sh
+++ /dev/null
@@ -1,35 +0,0 @@
---- build.sh.orig Sun Jun 19 07:07:05 2005
-+++ build.sh Thu Sep 15 21:44:32 2005
-@@ -1,6 +1,6 @@
- #!/bin/sh
-
--GCCFLAGS="-Wall -Werror -O3"
-+GCCFLAGS=${CFLAGS}
-
- mkdir ./obj/
- mkdir ./obj/contrib/
-@@ -8,18 +8,18 @@
- echo "Native Build:" $GCCFLAGS
-
- echo "Compiling src/DashFileServer.cxx"
--g++ $GCCFLAGS -c src/DashFileServer.cxx -o obj/DashFileServer.o
-+${CXX} $GCCFLAGS -c src/DashFileServer.cxx -o obj/DashFileServer.o
- echo "Compiling src/ClientConnection.cxx"
--g++ $GCCFLAGS -c src/ClientConnection.cxx -o obj/ClientConnection.o
-+${CXX} $GCCFLAGS -c src/ClientConnection.cxx -o obj/ClientConnection.o
- echo "Compiling src/CPathResolver.cxx"
--g++ $GCCFLAGS -c src/CPathResolver.cxx -o obj/CPathResolver.o
-+${CXX} $GCCFLAGS -c src/CPathResolver.cxx -o obj/CPathResolver.o
- echo "Compiling src/DirectoryIndexing.cxx"
--g++ $GCCFLAGS -c src/DirectoryIndexing.cxx -o obj/DirectoryIndexing.o
-+${CXX} $GCCFLAGS -c src/DirectoryIndexing.cxx -o obj/DirectoryIndexing.o
- echo "Compiling src/MimeTypes.cxx"
--g++ $GCCFLAGS -c src/MimeTypes.cxx -o obj/MimeTypes.o
-+${CXX} $GCCFLAGS -c src/MimeTypes.cxx -o obj/MimeTypes.o
-
- echo "Linking..."
--g++ -o DFileServer.x86 obj/DashFileServer.o obj/ClientConnection.o obj/CPathResolver.o obj/DirectoryIndexing.o obj/MimeTypes.o
-+${CXX} -o DFileServer.x86 obj/DashFileServer.o obj/ClientConnection.o obj/CPathResolver.o obj/DirectoryIndexing.o obj/MimeTypes.o
-
- echo "Striping..."
- strip --strip-all DFileServer.x86