aboutsummaryrefslogtreecommitdiff
path: root/www/dillo2
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-04-18 07:02:42 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-04-18 07:02:42 +0000
commitee9623eb2b198f528979864356604581bbbebcc7 (patch)
treec1bb40e2cfec4023ea5c0cc8e3fc4e314a0b8212 /www/dillo2
parentdd2c6b5a2d51a0defb0bbc4ced9dcabc3d6dab0f (diff)
downloadports-ee9623eb2b198f528979864356604581bbbebcc7.tar.gz
ports-ee9623eb2b198f528979864356604581bbbebcc7.zip
Notes
Diffstat (limited to 'www/dillo2')
-rw-r--r--www/dillo2/Makefile83
-rw-r--r--www/dillo2/distinfo73
-rw-r--r--www/dillo2/pkg-plist8
3 files changed, 141 insertions, 23 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 365876b4a93e..a7f8af5c36be 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -2,17 +2,22 @@
# $FreeBSD$
PORTNAME= dillo
-PORTVERSION= 3.0.2
-PORTREVISION= 1
+DISTVERSION= 3.0.3
CATEGORIES= www ipv6
-MASTER_SITES= http://www.dillo.org/download/ LOCAL/bf
+MASTER_SITES= http://www.dillo.org/download/ LOCAL/bf/dillo/ \
+ TEX_CTAN:hyphen
+MASTER_SITE_SUBDIR= \
+ language/hyph-utf8/tex/generic/hyph-utf8/patterns/txt/:hyphen
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bf@FreeBSD.org
COMMENT= A fast, small graphical Web browser built upon fltk
LICENSE= GPLv3
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_BZIP2= yes
@@ -24,18 +29,14 @@ CONFLICTS= dillo-i18n-[0-9]* \
dillo-0*
LATEST_LINK= dillo2
-OPTIONS_DEFINE= COOKIES DEBUG IPV6 SSL THREADED_DNS
-OPTIONS_DEFAULT= COOKIES SSL THREADED_DNS
-COOKIES_DESC= Enable cookies
-DEBUG_DESC= Enable profiling and extra logging
-SSL_DESC= Enable (experimental) https support
-THREADED_DNS_DESC= Enable re-entrant resolver library
+OPTIONS_DEFINE= COOKIES HYPHENATION IPV6 SSL THREADS
+OPTIONS_DEFAULT= COOKIES HYPHENATION IPV6 SSL THREADS
-.include <bsd.port.options.mk>
+COOKIES_DESC= Cookie support
+HYPHENATION_DESC= Hyphenation file(s) for HYPHENATION_LANGS
+SSL_DESC= Experimental HTTPS support
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCOOKIES}
CONFIGURE_ARGS+= --enable-cookies
@@ -43,12 +44,39 @@ CONFIGURE_ARGS+= --enable-cookies
CONFIGURE_ARGS+= --disable-cookies
.endif
-.if ${PORT_OPTIONS:MDEBUG}
+.ifdef(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-gprof --enable-rtfl
.else
CONFIGURE_ARGS+= --disable-gprof --disable-rtfl
.endif
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
+.endif
+
+.if ${PORT_OPTIONS:MHYPHENATION}
+ALL_HYPHENATION_LANGS= af as bg bn ca cop cs cy da de-1901 de-1996 \
+de-ch-1901 el-monoton el-polyton en-gb en-us eo es et eu fi fr fur ga \
+gl grc gu hi hr hsb hu hy ia id is it kmr kn la lt lv ml mn-cyrl mr \
+mul-ethi nb nl nn or pa pl pms pt rm ro ru sa sh-cyrl sh-latn sk sl \
+sr-cyrl sv ta te tk tr uk zh-latn-pinyin
+.if defined(MAINTAINER_MODE) || make(makesum)
+HYPHENATION_LANGS?= ${ALL_HYPHENATION_LANGS}
+.else
+HYPHENATION_LANGS?= \
+ ${ALL_HYPHENATION_LANGS:N*-1901:N*-latn:N*-gb:N*-monoton}
+.endif
+.for _l in ${HYPHENATION_LANGS}
+.if !${ALL_HYPHENATION_LANGS:M${_l}}
+IGNORE= remove the invalid hyphenation language "${_l}" from HYPHENATION_LANGS
+.else
+DISTFILES+= hyph-${_l}.pat.txt:hyphen
+IGNOREFILES+= hyph-${_l}.pat.txt
+PLIST_FILES+= libexec/dillo/hyphenation/${_l:C/-.*\$//}.pat
+.endif
+.endfor
+.endif
+
.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
@@ -62,7 +90,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --disable-ssl
.endif
-.if ${PORT_OPTIONS:MTHREADED_DNS}
+.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+= --enable-threaded-dns
.else
CONFIGURE_ARGS+= --disable-threaded-dns
@@ -71,23 +99,38 @@ CONFIGURE_ARGS+= --disable-threaded-dns
post-patch:
@${MV} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.dist
@${MV} ${WRKSRC}/dpid/dpidrc.in ${WRKSRC}/dpid/dpidrc.dist.in
+ @${MV} ${WRKSRC}/src/domainrc ${WRKSRC}/src/domainrc.dist
@${MV} ${WRKSRC}/src/keysrc ${WRKSRC}/src/keysrc.dist
@${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|dillorc|dillorc.dist|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|dpidrc|dpidrc.dist|g" ${WRKSRC}/dpid/Makefile.in
- @${REINPLACE_CMD} -e "s|keysrc|keysrc.dist|g" ${WRKSRC}/src/Makefile.in
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e "\|install-data-am:|s|install-dist_docDATA||" ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -E "s/(domain|keys)rc/&.dist/g" ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e "s|/lib/dillo|/libexec/dillo|" \
+ ${WRKSRC}/dillo-install-hyphenation \
+ ${WRKSRC}/doc/dillo.1.in \
+ ${WRKSRC}/dpid/dpid.c
+.if ${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} -e "\|install-data-am:|s|install-dist_docDATA||" \
+ ${WRKSRC}/doc/Makefile.in
.endif
post-install:
-.for f in dillorc dpidrc keysrc
+.for f in dillorc domainrc dpidrc keysrc
. if !exists(${PREFIX}/etc/dillo/${f})
${INSTALL_DATA} ${PREFIX}/etc/dillo/${f}.dist ${PREFIX}/etc/dillo/${f}
. endif
.endfor
.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
+ @${MKDIR} ${PREFIX}/libexec/dillo/hyphenation
+ @${TOUCH} ${PREFIX}/libexec/dillo/hyphenation/.keep_me
+.if ${PORT_OPTIONS:MHYPHENATION}
+.for _l in ${HYPHENATION_LANGS}
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/hyph-${_l}.pat.txt \
+ ${PREFIX}/libexec/dillo/hyphenation/${_l:C/-.*\$//}.pat
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/www/dillo2/distinfo b/www/dillo2/distinfo
index 75209a58840c..7fc5086b38a7 100644
--- a/www/dillo2/distinfo
+++ b/www/dillo2/distinfo
@@ -1,2 +1,71 @@
-SHA256 (dillo-3.0.2.tar.bz2) = b4f2cd7c1be9f09e705f68c095813ea5bb9d72870338fc36c61d687e042950d6
-SIZE (dillo-3.0.2.tar.bz2) = 640894
+SHA256 (dillo/dillo-3.0.3.tar.bz2) = 48241ca96d4c2f4bf83ebeb40c741c990fab0d6b0f7b9766a64234e481008dd2
+SIZE (dillo/dillo-3.0.3.tar.bz2) = 685824
+SHA256 (dillo/hyph-af.pat.txt) = IGNORE
+SHA256 (dillo/hyph-as.pat.txt) = IGNORE
+SHA256 (dillo/hyph-bg.pat.txt) = IGNORE
+SHA256 (dillo/hyph-bn.pat.txt) = IGNORE
+SHA256 (dillo/hyph-ca.pat.txt) = IGNORE
+SHA256 (dillo/hyph-cop.pat.txt) = IGNORE
+SHA256 (dillo/hyph-cs.pat.txt) = IGNORE
+SHA256 (dillo/hyph-cy.pat.txt) = IGNORE
+SHA256 (dillo/hyph-da.pat.txt) = IGNORE
+SHA256 (dillo/hyph-de-1901.pat.txt) = IGNORE
+SHA256 (dillo/hyph-de-1996.pat.txt) = IGNORE
+SHA256 (dillo/hyph-de-ch-1901.pat.txt) = IGNORE
+SHA256 (dillo/hyph-el-monoton.pat.txt) = IGNORE
+SHA256 (dillo/hyph-el-polyton.pat.txt) = IGNORE
+SHA256 (dillo/hyph-en-gb.pat.txt) = IGNORE
+SHA256 (dillo/hyph-en-us.pat.txt) = IGNORE
+SHA256 (dillo/hyph-eo.pat.txt) = IGNORE
+SHA256 (dillo/hyph-es.pat.txt) = IGNORE
+SHA256 (dillo/hyph-et.pat.txt) = IGNORE
+SHA256 (dillo/hyph-eu.pat.txt) = IGNORE
+SHA256 (dillo/hyph-fi.pat.txt) = IGNORE
+SHA256 (dillo/hyph-fr.pat.txt) = IGNORE
+SHA256 (dillo/hyph-fur.pat.txt) = IGNORE
+SHA256 (dillo/hyph-ga.pat.txt) = IGNORE
+SHA256 (dillo/hyph-gl.pat.txt) = IGNORE
+SHA256 (dillo/hyph-grc.pat.txt) = IGNORE
+SHA256 (dillo/hyph-gu.pat.txt) = IGNORE
+SHA256 (dillo/hyph-hi.pat.txt) = IGNORE
+SHA256 (dillo/hyph-hr.pat.txt) = IGNORE
+SHA256 (dillo/hyph-hsb.pat.txt) = IGNORE
+SHA256 (dillo/hyph-hu.pat.txt) = IGNORE
+SHA256 (dillo/hyph-hy.pat.txt) = IGNORE
+SHA256 (dillo/hyph-ia.pat.txt) = IGNORE
+SHA256 (dillo/hyph-id.pat.txt) = IGNORE
+SHA256 (dillo/hyph-is.pat.txt) = IGNORE
+SHA256 (dillo/hyph-it.pat.txt) = IGNORE
+SHA256 (dillo/hyph-kmr.pat.txt) = IGNORE
+SHA256 (dillo/hyph-kn.pat.txt) = IGNORE
+SHA256 (dillo/hyph-la.pat.txt) = IGNORE
+SHA256 (dillo/hyph-lt.pat.txt) = IGNORE
+SHA256 (dillo/hyph-lv.pat.txt) = IGNORE
+SHA256 (dillo/hyph-ml.pat.txt) = IGNORE
+SHA256 (dillo/hyph-mn-cyrl.pat.txt) = IGNORE
+SHA256 (dillo/hyph-mr.pat.txt) = IGNORE
+SHA256 (dillo/hyph-mul-ethi.pat.txt) = IGNORE
+SHA256 (dillo/hyph-nb.pat.txt) = IGNORE
+SHA256 (dillo/hyph-nl.pat.txt) = IGNORE
+SHA256 (dillo/hyph-nn.pat.txt) = IGNORE
+SHA256 (dillo/hyph-or.pat.txt) = IGNORE
+SHA256 (dillo/hyph-pa.pat.txt) = IGNORE
+SHA256 (dillo/hyph-pl.pat.txt) = IGNORE
+SHA256 (dillo/hyph-pms.pat.txt) = IGNORE
+SHA256 (dillo/hyph-pt.pat.txt) = IGNORE
+SHA256 (dillo/hyph-rm.pat.txt) = IGNORE
+SHA256 (dillo/hyph-ro.pat.txt) = IGNORE
+SHA256 (dillo/hyph-ru.pat.txt) = IGNORE
+SHA256 (dillo/hyph-sa.pat.txt) = IGNORE
+SHA256 (dillo/hyph-sh-cyrl.pat.txt) = IGNORE
+SHA256 (dillo/hyph-sh-latn.pat.txt) = IGNORE
+SHA256 (dillo/hyph-sk.pat.txt) = IGNORE
+SHA256 (dillo/hyph-sl.pat.txt) = IGNORE
+SHA256 (dillo/hyph-sr-cyrl.pat.txt) = IGNORE
+SHA256 (dillo/hyph-sv.pat.txt) = IGNORE
+SHA256 (dillo/hyph-ta.pat.txt) = IGNORE
+SHA256 (dillo/hyph-te.pat.txt) = IGNORE
+SHA256 (dillo/hyph-tk.pat.txt) = IGNORE
+SHA256 (dillo/hyph-tr.pat.txt) = IGNORE
+SHA256 (dillo/hyph-uk.pat.txt) = IGNORE
+SHA256 (dillo/hyph-zh-latn-pinyin.pat.txt) = IGNORE
diff --git a/www/dillo2/pkg-plist b/www/dillo2/pkg-plist
index 02a70f4d737a..3ff19bad0cdc 100644
--- a/www/dillo2/pkg-plist
+++ b/www/dillo2/pkg-plist
@@ -1,9 +1,13 @@
bin/dillo
+bin/dillo-install-hyphenation
bin/dpid
bin/dpidc
@unexec if cmp -s %D/etc/dillo/dillorc.dist %D/etc/dillo/dillorc; then rm -f %D/etc/dillo/dillorc; fi
etc/dillo/dillorc.dist
@exec if [ ! -f %B/dillorc ]; then cp -p %D/%F %B/dillorc; fi
+@unexec if cmp -s %D/etc/dillo/domainrc.dist %D/etc/dillo/domainrc; then rm -f %D/etc/dillo/domainrc; fi
+etc/dillo/domainrc.dist
+@exec if [ ! -f %B/domainrc ]; then cp -p %D/%F %B/domainrc; fi
@unexec if cmp -s %D/etc/dillo/dpidrc.dist %D/etc/dillo/dpidrc; then rm -f %D/etc/dillo/dpidrc; fi
etc/dillo/dpidrc.dist
@exec if [ ! -f %B/dpidrc ]; then cp -p %D/%F %B/dpidrc; fi
@@ -19,6 +23,8 @@ libexec/dillo/dpi/ftp/ftp.filter.dpi
libexec/dillo/dpi/hello/hello.filter.dpi
libexec/dillo/dpi/https/https.filter.dpi
libexec/dillo/dpi/vsource/vsource.filter.dpi
+libexec/dillo/hyphenation/.keep_me
+@dirrmtry libexec/dillo/hyphenation
@dirrm libexec/dillo/dpi/https
@dirrm libexec/dillo/dpi/hello
@dirrm libexec/dillo/dpi/ftp
@@ -29,5 +35,5 @@ libexec/dillo/dpi/vsource/vsource.filter.dpi
@dirrm libexec/dillo/dpi/bookmarks
@dirrm libexec/dillo/dpi/vsource
@dirrm libexec/dillo/dpi
-@dirrm libexec/dillo
+@dirrmtry libexec/dillo
@dirrmtry etc/dillo