aboutsummaryrefslogtreecommitdiff
path: root/www/dillo2
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-05-20 20:36:18 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-05-20 20:36:18 +0000
commita16b726b7ad292ed37035a9d523aa847568ec98e (patch)
treeb82ac4a97bc84210a68e07f877172ab7f6db7511 /www/dillo2
parent129c1c7df9c0505ea99398eb571cbb0818925301 (diff)
downloadports-a16b726b7ad292ed37035a9d523aa847568ec98e.tar.gz
ports-a16b726b7ad292ed37035a9d523aa847568ec98e.zip
Notes
Diffstat (limited to 'www/dillo2')
-rw-r--r--www/dillo2/Makefile34
-rw-r--r--www/dillo2/distinfo6
-rw-r--r--www/dillo2/files/enable-ssl.patch10
-rw-r--r--www/dillo2/files/patch-configure114
-rw-r--r--www/dillo2/files/patch-dpi-https.c16
-rw-r--r--www/dillo2/pkg-plist4
6 files changed, 152 insertions, 32 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index d0b359737d72..25e37e6cfb4d 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -9,34 +9,38 @@
#
PORTNAME= dillo
-PORTVERSION= 0.8.5
-PORTREVISION= 1
+PORTVERSION= 0.8.6
CATEGORIES= www ipv6
MASTER_SITES= http://www.dillo.org/download/
-MAINTAINER?= tmseck@netcologne.de
-COMMENT?= A fast, small graphical Web browser built upon GTK+
+MAINTAINER= tmseck@netcologne.de
+COMMENT= A fast, small graphical Web browser built upon GTK+
-RUN_DEPENDS+= wget:${PORTSDIR}/ftp/wget
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GNOME= gnometarget gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --enable-ipv6 --libdir=${PREFIX}/libexec
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --enable-cookies --enable-ipv6 --enable-threaded-dns \
+ --disable-dlgui \
+ --libdir=${PREFIX}/libexec
.if defined(WITH_DILLO_SSL)
CONFIGURE_ARGS+= --enable-ssl
+EXTRA_PATCHES+= ${PATCHDIR}/enable-ssl.patch
USE_OPENSSL= yes
.else
CONFIGURE_ARGS+= --disable-ssl
.endif
-CONFLICTS?= dillo-i18n-*[0-9]*
+CONFLICTS= dillo-i18n-*[0-9]*
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
@@ -44,16 +48,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|dillorc|dillorc.sample|g' ${WRKSRC}/Makefile.in
@${CP} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.sample
-# let a slave port redefine this target if it needs to:
-.if !target(pre-configure)
pre-configure:
.if !defined(WITH_DILLO_SSL)
@${ECHO_CMD} ""
- @${ECHO_CMD} " You can enable dillo's experimental SSL support by specifing"
- @${ECHO_CMD} " WITH_DILLO_SSL=yes in your make environment or on the"
- @${ECHO_CMD} " commandline."
- @${ECHO_CMD} ""
-.endif
+ @${ECHO_CMD} " Set WITH_DILLO_SSL=yes in your make environment or on the"
+ @${ECHO_CMD} " commandline to enable experimental SSL support."
.endif
+ @${ECHO_CMD} ""
.include <bsd.port.mk>
diff --git a/www/dillo2/distinfo b/www/dillo2/distinfo
index acee1cd7ab14..226bf232cbeb 100644
--- a/www/dillo2/distinfo
+++ b/www/dillo2/distinfo
@@ -1,3 +1,3 @@
-MD5 (dillo-0.8.5.tar.bz2) = d0ab7fa1d40b310deb891388604188f8
-SHA256 (dillo-0.8.5.tar.bz2) = 980ccd8e0c0a85e37478e33b5f4f59d2cfda5c16d30af3acad259626d387cd1a
-SIZE (dillo-0.8.5.tar.bz2) = 424795
+MD5 (dillo-0.8.6.tar.bz2) = b65233d368bbd265a55effcf2c17f84b
+SHA256 (dillo-0.8.6.tar.bz2) = 47e695a5d370eb656f5e41eeb917ad6281b1559bf60172c9eca89b5518a9f9b9
+SIZE (dillo-0.8.6.tar.bz2) = 441739
diff --git a/www/dillo2/files/enable-ssl.patch b/www/dillo2/files/enable-ssl.patch
new file mode 100644
index 000000000000..c20ccebf7659
--- /dev/null
+++ b/www/dillo2/files/enable-ssl.patch
@@ -0,0 +1,10 @@
+--- dpi/https.c.orig Sat Mar 25 16:46:48 2006
++++ dpi/https.c Sat Mar 25 16:47:38 2006
+@@ -62,7 +62,6 @@
+ #include "dpiutil.h"
+
+ #define ENABLE_SSL
+-#undef ENABLE_SSL
+ #ifdef ENABLE_SSL
+
+ #include <openssl/ssl.h>
diff --git a/www/dillo2/files/patch-configure b/www/dillo2/files/patch-configure
new file mode 100644
index 000000000000..5dbc5f4c6290
--- /dev/null
+++ b/www/dillo2/files/patch-configure
@@ -0,0 +1,114 @@
+--- configure.orig Sat Apr 15 14:01:45 2006
++++ configure Sun Apr 16 20:20:43 2006
+@@ -309,7 +309,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar DLGUI_TRUE DLGUI_FALSE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB CPP CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE GLIB_CONFIG GLIB_CFLAGS GLIB_LIBS GTK_CONFIG GTK_CFLAGS GTK_LIBS EGREP LIBJPEG_LIBS LIBJPEG_LDFLAGS LIBJPEG_CPPFLAGS LIBPNG_LIBS LIBPNG_CFLAGS LIBZ_LIBS LIBSSL_LIBS LIBPTHREAD_LIBS LIBPTHREAD_LDFLAGS LIBFLTK_CXXFLAGS LIBFLTK_LIBS src doc bin util lib LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar DLGUI_TRUE DLGUI_FALSE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB CPP CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE GLIB_CONFIG GLIB_CFLAGS GLIB_LIBS GTK_CONFIG GTK_CFLAGS GTK_LIBS FLTK2_CONFIG EGREP LIBJPEG_LIBS LIBJPEG_LDFLAGS LIBJPEG_CPPFLAGS LIBPNG_LIBS LIBPNG_CFLAGS LIBZ_LIBS LIBSSL_LIBS LIBPTHREAD_LIBS LIBPTHREAD_LDFLAGS LIBFLTK_CXXFLAGS LIBFLTK_LIBS src doc bin util lib LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -1961,16 +1961,6 @@
+ enable_threaded_dns=yes
+ fi;
+
+-
+-if test x$enable_dlgui = xyes; then
+- DLGUI_TRUE=
+- DLGUI_FALSE='#'
+-else
+- DLGUI_TRUE='#'
+- DLGUI_FALSE=
+-fi
+-
+-
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+ ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+@@ -5884,11 +5874,81 @@
+ rm -f conf.gtktest
+
+
+- echo "$as_me:$LINENO: checking Hackish check for FLTK" >&5
+-echo $ECHO_N "checking Hackish check for FLTK... $ECHO_C" >&6
+- LIBFLTK_CXXFLAGS=`fltk-config --cxxflags`
+- LIBFLTK_LIBS=`fltk-config --ldflags`
++if test "x$enable_dlgui" = "xyes"; then
++ for ac_prog in fltk2-config fltk-config
++do
++ # Extract the first word of "$ac_prog", so it can be a program name with args.
++set dummy $ac_prog; ac_word=$2
++echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
++if test "${ac_cv_path_FLTK2_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ case $FLTK2_CONFIG in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_FLTK2_CONFIG="$FLTK2_CONFIG" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_FLTK2_CONFIG="$as_dir/$ac_word$ac_exec_ext"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++
++ ;;
++esac
++fi
++FLTK2_CONFIG=$ac_cv_path_FLTK2_CONFIG
++
++if test -n "$FLTK2_CONFIG"; then
++ echo "$as_me:$LINENO: result: $FLTK2_CONFIG" >&5
++echo "${ECHO_T}$FLTK2_CONFIG" >&6
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++
++ test -n "$FLTK2_CONFIG" && break
++done
++test -n "$FLTK2_CONFIG" || FLTK2_CONFIG="NOTFOUND"
+
++ if test "x$FLTK2_CONFIG" != "xNOTFOUND" && test -x "$FLTK2_CONFIG"; then
++ fltk_version=`$FLTK2_CONFIG --version`
++ case "$fltk_version" in
++ 2.*)
++ LIBFLTK_CXXFLAGS=`$FLTK2_CONFIG --cxxflags`
++ LIBFLTK_LIBS=`$FLTK2_CONFIG --ldflags`
++ fltk2_ok="yes"
++ ;;
++ *)
++ echo "$as_me:$LINENO: result: need fltk2 -- disabling fltk support" >&5
++echo "${ECHO_T}need fltk2 -- disabling fltk support" >&6
++ fltk2_ok="no"
++ ;;
++ esac
++ else
++ fltk2_ok="no"
++ fi
++else
++ fltk2_ok="no"
++fi
++
++
++if test x$fltk2_ok = xyes; then
++ DLGUI_TRUE=
++ DLGUI_FALSE='#'
++else
++ DLGUI_TRUE='#'
++ DLGUI_FALSE=
++fi
+
+ if test "x$enable_jpeg" = "xyes"; then
+
diff --git a/www/dillo2/files/patch-dpi-https.c b/www/dillo2/files/patch-dpi-https.c
index b3e4173cd8c2..4fd698b0f55b 100644
--- a/www/dillo2/files/patch-dpi-https.c
+++ b/www/dillo2/files/patch-dpi-https.c
@@ -1,19 +1,11 @@
---- dpi/https.c.orig Sun Oct 3 17:16:15 2004
-+++ dpi/https.c Sun Oct 3 17:17:47 2004
-@@ -53,7 +53,6 @@
- #include <glib.h>
- #include "dpiutil.h"
-
--#undef ENABLE_SSL
- #ifdef ENABLE_SSL
-
- #include <openssl/ssl.h>
-@@ -605,13 +616,8 @@ static void no_ssl_support(void)
+--- dpi/https.c.orig Sat Mar 25 16:49:59 2006
++++ dpi/https.c Sat Mar 25 16:55:35 2006
+@@ -655,13 +655,8 @@
"<b>}</b>\n\n"
" <b>*** Dillo's prototype plugin for https support"
" is disabled now ***</b>\n\n"
- " If you want to test this <b>alpha</b> support code, just remove\n"
-- " line 56 from https.c, recompile and reinstall.\n\n"
+- " line 65 from https.c, recompile and reinstall.\n\n"
- " (beware that this https support is very limited now)\n\n"
- " To use https and SSL, you must have \n"
- " the OpenSSL development libraries installed. Check your\n"
diff --git a/www/dillo2/pkg-plist b/www/dillo2/pkg-plist
index 36cd84b7d98d..bbe25cdd3a4f 100644
--- a/www/dillo2/pkg-plist
+++ b/www/dillo2/pkg-plist
@@ -5,6 +5,8 @@ bin/dpidc
etc/dillorc.sample
etc/dpidrc
libexec/dillo/dpi/bookmarks/bookmarks.dpi
+libexec/dillo/dpi/cookies/cookies.dpi
+libexec/dillo/dpi/datauri/datauri.filter.dpi
libexec/dillo/dpi/downloads/downloads.dpi
libexec/dillo/dpi/file/file.dpi
libexec/dillo/dpi/ftp/ftp.filter.dpi
@@ -15,6 +17,8 @@ libexec/dillo/dpi/https/https.filter.dpi
@dirrm libexec/dillo/dpi/ftp
@dirrm libexec/dillo/dpi/file
@dirrm libexec/dillo/dpi/downloads
+@dirrm libexec/dillo/dpi/datauri
+@dirrm libexec/dillo/dpi/cookies
@dirrm libexec/dillo/dpi/bookmarks
@dirrm libexec/dillo/dpi
@dirrm libexec/dillo