aboutsummaryrefslogtreecommitdiff
path: root/www/dokuwiki
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-07-23 10:57:28 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-07-23 10:57:28 +0000
commite8884641aa887b0e78331d9cdc9fcf7a0b9530b0 (patch)
treeaa00b94c68e8614613a7c96d3b26503fe1cdfdb5 /www/dokuwiki
parent7a6178fd1c89d572fac960405059255faf10d56a (diff)
downloadports-e8884641aa887b0e78331d9cdc9fcf7a0b9530b0.tar.gz
ports-e8884641aa887b0e78331d9cdc9fcf7a0b9530b0.zip
Notes
Diffstat (limited to 'www/dokuwiki')
-rw-r--r--www/dokuwiki/Makefile4
-rw-r--r--www/dokuwiki/files/patch-lib-exe-spellcheck.php11
2 files changed, 15 insertions, 0 deletions
diff --git a/www/dokuwiki/Makefile b/www/dokuwiki/Makefile
index 7ebad5121054..8d62893d5cca 100644
--- a/www/dokuwiki/Makefile
+++ b/www/dokuwiki/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dokuwiki
PORTVERSION= ${DIST_VER:S/${PORTNAME}//:S/-//g}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.splitbrain.org/_media/projects/dokuwiki/ \
LOCAL/chinsan/${PORTNAME}
@@ -36,6 +37,9 @@ x-generate-plist:
${SED} -e 's|^|@dirrm %%DOKUWIKI_DIR%%/|' >> ${TEMP_PLIST} \
&& ${ECHO_CMD} "@dirrmtry %%DOKUWIKI_DIR%%" >> ${TEMP_PLIST}
+post-patch:
+ @${REINPLACE_CMD} -ie 's|9|10|' ${WRKSRC}/conf/msg
+
do-install:
# Data files
-${MKDIR} ${PREFIX}/${DOKUWIKI_DIR}
diff --git a/www/dokuwiki/files/patch-lib-exe-spellcheck.php b/www/dokuwiki/files/patch-lib-exe-spellcheck.php
new file mode 100644
index 000000000000..a4d40ade8ae4
--- /dev/null
+++ b/www/dokuwiki/files/patch-lib-exe-spellcheck.php
@@ -0,0 +1,11 @@
+--- lib/exe/spellcheck.php.orig 2007-07-23 14:40:45.000000000 +0800
++++ lib/exe/spellcheck.php 2007-07-23 14:39:30.000000000 +0800
+@@ -272,7 +272,7 @@
+ * Just send data back as received for UTF-8 testing
+ */
+ function spell_utf8test(){
+- print $_POST['data'];
++ print substr( $_POST['data'], 0, 3 );
+ }
+
+ /**