aboutsummaryrefslogtreecommitdiff
path: root/www/dpsearch/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-11-04 17:21:35 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-11-04 17:21:35 +0000
commit3f47cb73d55bba06c22abd88e1a1fa64f7c6ca25 (patch)
treea518f2a6b4220eaff41eab05376cec78a76e75ec /www/dpsearch/Makefile
parent2a7464bc90216ff1abdace1f42ff4b7c12dbba4a (diff)
Notes
Diffstat (limited to 'www/dpsearch/Makefile')
-rw-r--r--www/dpsearch/Makefile77
1 files changed, 39 insertions, 38 deletions
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index 7509a2a89a1c..ce651db54a2e 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -6,25 +6,27 @@
#
PORTNAME= dpsearch
-PORTVERSION= 4.21
+PORTVERSION= 4.25
CATEGORIES= www
-MASTER_SITES= http://www.dataparksearch.org/
+MASTER_SITES= http://www.dataparksearch.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source search engine for Internet and Intranet sites
#RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-INSTALLS_SHLIB= yes
+INSTALLS_SHLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=13
+DOCSDIR= ${PREFIX}/share/doc/dataparksearch
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc/dpsearch \
--localstatedir=/var/dpsearch \
--enable-mp3 \
--with-zlib
-OPTIONS= DPSEARCH_THREADS "Enable pthreads" on \
+OPTIONS= DPSEARCH_THREADS "Enable pthreads" on \
DPSEARCH_SSL "Enable SSL" on \
DPSEARCH_GUESSER "Enable charset and language guesser" on \
DPSEARCH_CHARSETS "Enable all charsets" off \
@@ -34,72 +36,76 @@ OPTIONS= DPSEARCH_THREADS "Enable pthreads" on \
DPSEARCH_CHASEN "Enable ChaSen japanese analyzer" off \
DPSEARCH_APACHE "Enable mod_dpsearch for Apache" off \
DPSEARCH_IDN "Enable Internationalized Domain Names" off \
- DPSEARCH_PGSQL "Use PGSQL (mutually exclusive)" on \
- DPSEARCH_MYSQL "Use MySQL (mutually exclusive)" off \
+ DPSEARCH_PGSQL "Use PGSQL (mutually exclusive)" off \
+ DPSEARCH_MYSQL "Use MySQL (mutually exclusive)" on \
DPSEARCH_SQLITE "Use SQLite (mutually exclusive)" off \
-.if defined(PACKAGE_BUILDING)
-WITH_DPSEARCH_MYSQL= yes
-.endif
-
.include <bsd.port.pre.mk>
-CONFIGURE_ENV+= PORTNAME="${PORTNAME}"
+CONFIGURE_ENV+= PORTNAME="${PORTNAME}"
.if !defined(WITHOUT_DPSEARCH_THREADS)
-CONFIGURE_ARGS+= --enable-pthreads
-CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ARGS+=--enable-pthreads
+CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
.else
-CONFIGURE_ARGS+= --disable-pthreads
+CONFIGURE_ARGS+=--disable-pthreads
.endif
.if !defined(NO_OPENSSL) && !defined(WITHOUT_DPSEARCH_SSL)
-WITH_OPENSSL= yes
+WITH_OPENSSL= yes
.endif
.ifdef WITH_OPENSSL
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
.endif
.if defined(WITH_DPSEARCH_GUESSER)
-CONFIGURE_ARGS+= --enable-charset-guesser
+CONFIGURE_ARGS+=--enable-charset-guesser
.endif
.if defined(WITH_DPSEARCH_CHASRETS)
-CONFIGURE_ARGS+= --with-extra-charsets=all
+CONFIGURE_ARGS+=--with-extra-charsets=all
.endif
.if defined(WITH_DPSEARCH_CHINESE)
-CONFIGURE_ARGS+= --with-extra-charsets=chinese
+CONFIGURE_ARGS+=--with-extra-charsets=chinese
.endif
.if defined(WITH_DPSEARCH_JAPANESE)
-CONFIGURE_ARGS+= --with-extra-charsets=japanese
+CONFIGURE_ARGS+=--with-extra-charsets=japanese
.endif
.if defined(WITH_DPSEARCH_MECAB)
-LIB_DEPEND+= mecab.0:${PORTSDIR}/japanese/mecab
-CONFIGURE_ARGS+= --enable-mecab
+LIB_DEPEND+= mecab.0:${PORTSDIR}/japanese/mecab
+CONFIGURE_ARGS+=--enable-mecab
.endif
.if defined(WITH_DPSEARCH_CHASEN)
-LIB_DEPEND+= chasen.0:${PORTSDIR}/japanese/chasen
-CONFIGURE_ARGS+= --enable-chasen
+LIB_DEPEND+= chasen.0:${PORTSDIR}/japanese/chasen
+CONFIGURE_ARGS+=--enable-chasen
.endif
.if defined(WITH_DPSEARCH_IDN)
-LIB_DEPEND+= idn.16:${PORTSDIR}/devel/libidn
-CONFIGURE_ARGS+= --enable-idn
+LIB_DEPEND+= idn.16:${PORTSDIR}/devel/libidn
+CONFIGURE_ARGS+=--enable-idn
.endif
.if defined(WITH_DPSEARCH_APACHE)
.if defined (WITH_APACHE2)
-BUILD_DEPEND+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache2
+BUILD_DEPEND+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache2
.else
-BUILD_DEPEND+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
+BUILD_DEPEND+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
+.endif
+CONFIGURE_ARGS+=--enable-apache-module
.endif
-CONFIGURE_ARGS+= --enable-apache-module
+
+.if !defined(WITH_DPSEARCH_PGSQL) && !defined(WITH_DPSEARCH_MYSQL) && !defined(WITH_DPSEARCH_SQLITE)
+WITH_DPSEARCH_MYSQL=yes
+pre-fetch:
+ @${ECHO}
+ @${ECHO} "Choose MySQL by default."
+ @${ECHO}
.endif
.if defined(WITH_DPSEARCH_PGSQL)
@@ -108,22 +114,17 @@ LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
.elif defined(WITH_DPSEARCH_MYSQL)
-LIB_DEPENDS+= mysqlclient:${PORTSDIR}/databases/mysql41-client
+USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
.elif defined(WITH_DPSEARCH_SQLITE)
-LIB_DEPEND+= sqlite.2:${PORTSDIR}/databases/sqlite
-CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
+LIB_DEPEND+= sqlite.2:${PORTSDIR}/databases/sqlite
+CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
-.else
-pre-fetch:
- @${ECHO}
- @${ECHO} "One of databases should be chose."
- @exit 1
.endif
pre-install:
- @${MKDIR} ${PREFIX}/share/dpsearch
+ @${MKDIR} ${DATADIR}
post-install:
${CHMOD} 700 /var/dpsearch/cache