aboutsummaryrefslogtreecommitdiff
path: root/www/dpsearch/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-16 11:14:28 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-16 11:14:28 +0000
commitd2f2ed95b134da88dd416be103157ffa18694c2b (patch)
tree3c3d99536f5a6033a8f8fc5ccd1f3da541e74635 /www/dpsearch/Makefile
parent4eac9f1b182ef9e0273b2857517bcb96a1a9000d (diff)
Notes
Diffstat (limited to 'www/dpsearch/Makefile')
-rw-r--r--www/dpsearch/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index 1c9cf1bf8835..ef04258bdd8c 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dpsearch
-PORTVERSION= 4.32
+PORTVERSION= 4.33
CATEGORIES= www
MASTER_SITES= http://dataparksearch.newsa.ru/ \
http://www.dataparksearch.org/
@@ -38,6 +38,7 @@ OPTIONS= DPSEARCH_THREADS "Enable pthreads" on \
DPSEARCH_CHASEN "Enable ChaSen japanese analyzer" off \
DPSEARCH_APACHE "Enable mod_dpsearch for Apache" off \
DPSEARCH_IDN "Enable Internationalized Domain Names" off \
+ DPSEARCH_ASPELL "Enable aspell support" off \
DPSEARCH_PGSQL "Use PostgreSQL (mutually exclusive)" off \
DPSEARCH_MYSQL "Use MySQL (mutually exclusive)" on \
DPSEARCH_SQLITE "Use SQLite (mutually exclusive)" off
@@ -54,6 +55,12 @@ CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--disable-pthreads
.endif
+.if !defined(WITHOUT_DPSEARCH_ASPELL)
+LIB_DEPEND+= aspell.16:${PORTSDIR}/textproc/aspell
+.else
+CONFIGURE_ARGS+=--without-aspell
+.endif
+
.if !defined(NO_OPENSSL) && !defined(WITHOUT_DPSEARCH_SSL)
WITH_OPENSSL= yes
.endif