aboutsummaryrefslogtreecommitdiff
path: root/www/dpsearch
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-29 22:38:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-29 22:38:49 +0000
commit604fcef035f3f04c3c877a350a4b0db0e595604d (patch)
treee476d50d7db0e60b846a153b400572aca42b2286 /www/dpsearch
parent65e222528f8e441f004be1cdb196897d3ff714b7 (diff)
downloadports-604fcef035f3f04c3c877a350a4b0db0e595604d.tar.gz
ports-604fcef035f3f04c3c877a350a4b0db0e595604d.zip
Notes
Diffstat (limited to 'www/dpsearch')
-rw-r--r--www/dpsearch/Makefile20
-rw-r--r--www/dpsearch/pkg-plist4
2 files changed, 14 insertions, 10 deletions
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index 1064eb82f891..f08fa79455ae 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dpsearch
PORTVERSION= 4.50
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://dataparksearch.googlecode.com/files/ \
http://www.dataparksearch.org/
@@ -53,7 +54,7 @@ CONFIGURE_ARGS+=--disable-pthreads
.endif
.if !defined(WITHOUT_DPSEARCH_ASPELL)
-LIB_DEPEND+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
.else
CONFIGURE_ARGS+=--without-aspell
.endif
@@ -83,27 +84,26 @@ CONFIGURE_ARGS+=--with-extra-charsets=japanese
.endif
.if defined(WITH_DPSEARCH_MECAB)
-LIB_DEPEND+= mecab.0:${PORTSDIR}/japanese/mecab
+LIB_DEPENDS+= mecab.1:${PORTSDIR}/japanese/mecab
CONFIGURE_ARGS+=--enable-mecab
.endif
.if defined(WITH_DPSEARCH_CHASEN)
-LIB_DEPEND+= chasen.0:${PORTSDIR}/japanese/chasen
+LIB_DEPENDS+= chasen.2:${PORTSDIR}/japanese/chasen
CONFIGURE_ARGS+=--enable-chasen
.endif
.if defined(WITH_DPSEARCH_IDN)
-LIB_DEPEND+= idn.16:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= idn.16:${PORTSDIR}/dns/libidn
CONFIGURE_ARGS+=--enable-idn
.endif
.if defined(WITH_DPSEARCH_APACHE)
-.if defined (WITH_APACHE2)
-BUILD_DEPEND+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache20
-.else
-BUILD_DEPEND+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
-.endif
+USE_APACHE= 1.3+
+PLIST_SUB+= APACHE=""
CONFIGURE_ARGS+=--enable-apache-module
+.else
+PLIST_SUB+= APACHE="@comment "
.endif
.if !defined(WITH_DPSEARCH_PGSQL) && !defined(WITH_DPSEARCH_MYSQL) && !defined(WITH_DPSEARCH_SQLITE)
@@ -123,7 +123,7 @@ USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
.elif defined(WITH_DPSEARCH_SQLITE)
-LIB_DEPEND+= sqlite.2:${PORTSDIR}/databases/sqlite2
+LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
.endif
diff --git a/www/dpsearch/pkg-plist b/www/dpsearch/pkg-plist
index a773e3ac1d59..93c2014d34df 100644
--- a/www/dpsearch/pkg-plist
+++ b/www/dpsearch/pkg-plist
@@ -376,6 +376,10 @@ lib/libdpcharset.so
lib/libdpsearch-4.so
lib/libdpsearch.a
lib/libdpsearch.so
+%%APACHE%%lib/libdpsearch_mod-4.so
+%%APACHE%%lib/libdpsearch_mod.a
+%%APACHE%%lib/libdpsearch_mod.so
+%%APACHE%%%%APACHEMODDIR%%/mod_dpsearch.so
sbin/cached
sbin/dpconv
sbin/dpguesser