aboutsummaryrefslogtreecommitdiff
path: root/www/drraw/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-24 14:04:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-24 14:04:36 +0000
commit47649f7033a40f88bdbb902b00bb10fde1c82e2a (patch)
treec9128f0ea50cfa1c45671f3e7a79326f4cf05185 /www/drraw/Makefile
parent9088b943cdeebf10b988b4cdfd82808eb70aa550 (diff)
downloadports-47649f7033a40f88bdbb902b00bb10fde1c82e2a.tar.gz
ports-47649f7033a40f88bdbb902b00bb10fde1c82e2a.zip
Notes
Diffstat (limited to 'www/drraw/Makefile')
-rw-r--r--www/drraw/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/drraw/Makefile b/www/drraw/Makefile
index 02d2703559a0..921957b76240 100644
--- a/www/drraw/Makefile
+++ b/www/drraw/Makefile
@@ -22,13 +22,12 @@ NO_BUILD= yes
PORTDOCS= CHANGES INSTALL LICENSE README.EVENTS WISHLIST
-WWWDIR?= www
CONFDIR?= etc
DATADIRS?= "/var/db/rrdtool" => "[Label1] "
SAVEDDIR?= /var/db/${PORTNAME}/saved
TMPDIR?= /var/db/${PORTNAME}/tmp
-PLIST_SUB+= WWWDIR=${WWWDIR} CONFDIR=${CONFDIR}
+PLIST_SUB+= CONFDIR=${CONFDIR}
post-patch:
@${REINPLACE_CMD} -e 's|%%CONFDIR%%|${PREFIX}/${CONFDIR}|g' ${WRKSRC}/drraw.cgi
@@ -43,12 +42,12 @@ post-patch:
do-install:
${INSTALL_DATA} ${WRKSRC}/drraw.conf-dist ${PREFIX}/${CONFDIR}
- ${MKDIR} ${PREFIX}/${WWWDIR}/${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/drraw.cgi ${PREFIX}/${WWWDIR}/${PORTNAME}
+ ${MKDIR} ${WWWDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/drraw.cgi ${WWWDIR}
- ${MKDIR} ${PREFIX}/${WWWDIR}/${PORTNAME}/icons
+ ${MKDIR} ${WWWDIR}/icons
.for theFile in bomb.gif folder.gif folder.open.gif generic.gif link.gif text.gif unknown.gif
- ${INSTALL_DATA} ${WRKSRC}/icons/${theFile} ${PREFIX}/${WWWDIR}/${PORTNAME}/icons
+ ${INSTALL_DATA} ${WRKSRC}/icons/${theFile} ${WWWDIR}/icons
.endfor
.if !defined(NOPORTDOCS)