aboutsummaryrefslogtreecommitdiff
path: root/www/drupal5-i18n
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-07 15:28:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-07 15:28:33 +0000
commitf40cc462934468f32183ea030776397cc244c489 (patch)
tree0b063b744c87d198d5650ccecf6f22521f6837be /www/drupal5-i18n
parent64ac26a1c25bb367e4cfe4e4df6dd0e7f30ccf7d (diff)
Notes
Diffstat (limited to 'www/drupal5-i18n')
-rw-r--r--www/drupal5-i18n/Makefile45
-rw-r--r--www/drupal5-i18n/distinfo6
-rw-r--r--www/drupal5-i18n/files/patch-i18n.module15
3 files changed, 48 insertions, 18 deletions
diff --git a/www/drupal5-i18n/Makefile b/www/drupal5-i18n/Makefile
index ad1f3a0a6523..c889beb6b6ee 100644
--- a/www/drupal5-i18n/Makefile
+++ b/www/drupal5-i18n/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: drupal-i18n
+# New ports collection makefile for: drupal5-i18n
# Date created: 26 Jan 2007
# Whom: Nick Hilliard <nick@foobar.org>
#
@@ -6,27 +6,42 @@
#
PORTNAME= i18n
-DISTVERSION= 4.7.x-1.0
-PORTREVISION= 20061209
-CATEGORIES= www security
-MASTER_SITE_SUBDIR= pav/drupal
+DISTVERSION= 5.x-2.1
+CATEGORIES= www
+MASTER_SITES= http://ftp.osuosl.org/pub/drupal/files/projects/
MAINTAINER= nick@foobar.org
COMMENT= An internationalisation module for the Drupal CMS
-DRUPAL_MODULE= yes
-DRUPAL_MODSUBDIR= i18n
-MODULE_FILES= translation.module i18n.module i18n.install i18n.inc \
- i18nprofile/i18nprofile.install \
- i18nprofile/i18nprofile.module \
- flags/ca.png flags/cs.png flags/de.png flags/en.png \
- flags/es.png flags/eu.png flags/fi.png flags/fr.png \
+DRUPAL5_MODULE= yes
+
+MODULE_DIRS= contrib experimental flags i18nblocks i18nprofile \
+ i18nviews translation
+
+MODULE_FILES= contrib/i18nmenu.info contrib/i18nmenu.module \
+ contrib/i18ntaxonomy.info contrib/i18ntaxonomy.install \
+ contrib/i18ntaxonomy.module i18n.info i18n.install \
+ i18n.module experimental/README.txt \
+ experimental/i18ncontent.info \
+ experimental/i18ncontent.module \
+ experimental/i18nstrings.info \
+ experimental/i18nstrings.install \
+ experimental/i18nstrings.module experimental/i18nsync.info \
+ experimental/i18nsync.install experimental/i18nsync.module \
+ experimental/ttext.info experimental/ttext.install \
+ experimental/ttext.module flags/ar.png flags/ca.png \
+ flags/cs.png flags/de.png flags/en.png flags/es.png \
+ flags/eu.png flags/fi.png flags/fr.png flags/ga.png \
flags/gl.png flags/he.png flags/hu.png flags/it.png \
flags/ja.png flags/km.png flags/nl.png flags/ru.png \
- flags/sk.png flags/sv.png
+ flags/sk.png flags/sv.png i18nblocks/i18nblocks.info \
+ i18nblocks/i18nblocks.install i18nblocks/i18nblocks.module \
+ i18nprofile/i18nprofile.info i18nprofile/i18nprofile.install \
+ i18nprofile/i18nprofile.module i18nviews/i18nviews.info \
+ i18nviews/i18nviews.module translation/translation.info \
+ translation/translation.module
-MODULE_DIRS= flags i18nprofile
-DOC_FILES= CHANGELOG.txt CREDITS.txt HOWTO.txt INSTALL.txt LICENSE.txt README.txt
+DOC_FILES= CHANGELOG.txt CREDITS.txt INSTALL.txt LICENSE.txt README.txt
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/drupal5/bsd.drupal.mk"
diff --git a/www/drupal5-i18n/distinfo b/www/drupal5-i18n/distinfo
index 5bbb25c9ba05..38c516b31a5f 100644
--- a/www/drupal5-i18n/distinfo
+++ b/www/drupal5-i18n/distinfo
@@ -1,3 +1,3 @@
-MD5 (drupal/i18n-4.7.x-1.0.tar.gz) = fa1ae8f3a279d92130523764f4b28779
-SHA256 (drupal/i18n-4.7.x-1.0.tar.gz) = 01c4ddc8d4aba9db8114448bcdc1ce2210c6aa11263cfd5aaa81cc7db07e1048
-SIZE (drupal/i18n-4.7.x-1.0.tar.gz) = 52454
+MD5 (drupal/i18n-5.x-2.1.tar.gz) = 7c884e2240e7b55c360a3ff7f527171f
+SHA256 (drupal/i18n-5.x-2.1.tar.gz) = 7799d1fbd2437a0f1fe8a300d5e7e647b4f395baad18d1dbf428f616a76eed7b
+SIZE (drupal/i18n-5.x-2.1.tar.gz) = 71684
diff --git a/www/drupal5-i18n/files/patch-i18n.module b/www/drupal5-i18n/files/patch-i18n.module
new file mode 100644
index 000000000000..f4576b9ae763
--- /dev/null
+++ b/www/drupal5-i18n/files/patch-i18n.module
@@ -0,0 +1,15 @@
+--- i18n.module 2007/05/03 13:48:57 1.36.2.12
++++ i18n.module 2007/05/16 17:43:10 1.36.2.13
+@@ -187,10 +187,10 @@
+ if (isset($node->menu) && !$node->menu['delete'] && $node->menu['title']) {
+ $item = $node->menu;
+ $item['path'] = ($item['path']) ? $item['path'] : "node/$node->nid";
+-
++ $item['type'] = $item['type'] | MENU_MODIFIED_BY_ADMIN;
+ if ($item['mid']) {
+ // Update menu item
+- db_query("UPDATE {menu} SET pid = %d, path = '%s', title = '%s', description = '%s', weight = %d, type = %d, language = '%s' WHERE mid = %d", $item['pid'], $item['path'], $item['title'], $item['description'], $item['weight'], $item['type'], $item['mid'], $node->language);
++ db_query("UPDATE {menu} SET pid = %d, path = '%s', title = '%s', description = '%s', weight = %d, type = %d, language = '%s' WHERE mid = %d", $item['pid'], $item['path'], $item['title'], $item['description'], $item['weight'], $item['type'], $node->language, $item['mid']);
+ drupal_set_message(t('The menu item %title has been updated with node language.', array('%title' => $item['title'])));
+ } elseif(SAVED_NEW == menu_save_item($item)) {
+ // Creating new menu item with node language