aboutsummaryrefslogtreecommitdiff
path: root/www/drupal5-ubercart
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 17:15:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 17:15:08 +0000
commit3790b1e5b582af8d3a6e8d5c6f22db954811bea8 (patch)
tree966f2ab64feec3073f57ded6e8ba740176c25879 /www/drupal5-ubercart
parentd2922db9d2523e631507d30d97edbba643c16b88 (diff)
downloadports-3790b1e5b582af8d3a6e8d5c6f22db954811bea8.tar.gz
ports-3790b1e5b582af8d3a6e8d5c6f22db954811bea8.zip
Notes
Diffstat (limited to 'www/drupal5-ubercart')
-rw-r--r--www/drupal5-ubercart/Makefile362
-rw-r--r--www/drupal5-ubercart/distinfo3
-rw-r--r--www/drupal5-ubercart/pkg-descr10
3 files changed, 375 insertions, 0 deletions
diff --git a/www/drupal5-ubercart/Makefile b/www/drupal5-ubercart/Makefile
new file mode 100644
index 000000000000..9d1217a48e32
--- /dev/null
+++ b/www/drupal5-ubercart/Makefile
@@ -0,0 +1,362 @@
+# New ports collection makefile for: drupal5-ubercart
+# Date created: 11 February 2008
+# Whom: Jeremy Iverson <jeremy@algenta.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ubercart
+DISTVERSION= 5.x-1.0-beta5
+CATEGORIES= www
+MASTER_SITES= http://ftp.drupal.org/files/projects/
+
+MAINTAINER= jeremy@algenta.com
+COMMENT= Ubercart modules for Drupal 5
+
+RUN_DEPENDS= ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/tapir:${PORTSDIR}/www/drupal5-tapir \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/ubrowser:${PORTSDIR}/www/drupal5-ubrowser \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/token:${PORTSDIR}/www/drupal5-token \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/workflow_ng:${PORTSDIR}/www/drupal5-workflow_ng \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/cck:${PORTSDIR}/www/drupal5-cck \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/imagefield:${PORTSDIR}/www/drupal5-imagefield \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/imagecache:${PORTSDIR}/www/drupal5-imagecache \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/thickbox:${PORTSDIR}/www/drupal5-thickbox \
+ ${LOCALBASE}/${DRUPAL_BASE}/sites/all/modules/google_analytics:${PORTSDIR}/www/drupal5-google_analytics
+
+DRUPAL5_MODULE= yes
+
+MODULE_DIRS= uc_taxes/po \
+ uc_taxes \
+ uc_store/po \
+ uc_store/includes \
+ uc_store/images \
+ uc_store/countries \
+ uc_store \
+ uc_stock/po \
+ uc_stock \
+ uc_roles/po \
+ uc_roles \
+ uc_reports/po \
+ uc_reports \
+ uc_repeater/po \
+ uc_repeater \
+ uc_product_kit/po \
+ uc_product_kit \
+ uc_product/po \
+ uc_product \
+ uc_order/templates \
+ uc_order/po \
+ uc_order/images \
+ uc_order \
+ uc_notify/po \
+ uc_notify \
+ uc_importer/po \
+ uc_importer \
+ uc_googleanalytics/po \
+ uc_googleanalytics \
+ uc_file/po \
+ uc_file \
+ uc_catalog/po \
+ uc_catalog \
+ uc_cart_links/po \
+ uc_cart_links \
+ uc_cart/po \
+ uc_cart/images \
+ uc_cart \
+ uc_attribute/po \
+ uc_attribute \
+ shipping/uc_weightquote/po \
+ shipping/uc_weightquote \
+ shipping/uc_usps/po \
+ shipping/uc_usps \
+ shipping/uc_ups/po \
+ shipping/uc_ups \
+ shipping/uc_shipping/po \
+ shipping/uc_shipping/images \
+ shipping/uc_shipping \
+ shipping/uc_quote/po \
+ shipping/uc_quote \
+ shipping/uc_flatrate/po \
+ shipping/uc_flatrate \
+ shipping \
+ payment/uc_recurring \
+ payment/uc_paypal/po \
+ payment/uc_paypal \
+ payment/uc_payment_pack \
+ payment/uc_payment/po \
+ payment/uc_payment \
+ payment/uc_cybersource/po \
+ payment/uc_cybersource \
+ payment/uc_credit/po \
+ payment/uc_credit/images \
+ payment/uc_credit \
+ payment/uc_authorizenet/po \
+ payment/uc_authorizenet \
+ payment/uc_2checkout/po \
+ payment/uc_2checkout \
+ payment \
+ contrib
+
+MODULE_FILES= contrib/README.txt \
+ payment/uc_2checkout/2cocc05.gif \
+ payment/uc_2checkout/po/uc_2checkout.pot \
+ payment/uc_2checkout/uc_2checkout.info \
+ payment/uc_2checkout/uc_2checkout.module \
+ payment/uc_authorizenet/po/uc_authorizenet.pot \
+ payment/uc_authorizenet/uc_authorizenet.info \
+ payment/uc_authorizenet/uc_authorizenet.module \
+ payment/uc_credit/images/amex.gif \
+ payment/uc_credit/images/amex_cvv.jpg \
+ payment/uc_credit/images/discover.gif \
+ payment/uc_credit/images/echeck.gif \
+ payment/uc_credit/images/info.png \
+ payment/uc_credit/images/mastercard.gif \
+ payment/uc_credit/images/visa.gif \
+ payment/uc_credit/images/visa_cvv.jpg \
+ payment/uc_credit/po/uc_credit.pot \
+ payment/uc_credit/uc_credit.info \
+ payment/uc_credit/uc_credit.install \
+ payment/uc_credit/uc_credit.js \
+ payment/uc_credit/uc_credit.module \
+ payment/uc_cybersource/HOP.php \
+ payment/uc_cybersource/po/uc_cybersource.pot \
+ payment/uc_cybersource/uc_cybersource.info \
+ payment/uc_cybersource/uc_cybersource.module \
+ payment/uc_payment/po/uc_payment.pot \
+ payment/uc_payment/test_gateway.info \
+ payment/uc_payment/test_gateway.module \
+ payment/uc_payment/uc_payment.info \
+ payment/uc_payment/uc_payment.install \
+ payment/uc_payment/uc_payment.js \
+ payment/uc_payment/uc_payment.module \
+ payment/uc_payment/uc_payment_checkout_pane.inc \
+ payment/uc_payment/uc_payment_order_pane.inc \
+ payment/uc_payment/uc_payment_payment_method.inc \
+ payment/uc_payment/uc_payment_workflow.inc \
+ payment/uc_payment_pack/uc_payment_pack.info \
+ payment/uc_payment_pack/uc_payment_pack.module \
+ payment/uc_paypal/po/uc_paypal.pot \
+ payment/uc_paypal/uc_paypal.info \
+ payment/uc_paypal/uc_paypal.install \
+ payment/uc_paypal/uc_paypal.module \
+ payment/uc_recurring/uc_recurring.css \
+ payment/uc_recurring/uc_recurring.info \
+ payment/uc_recurring/uc_recurring.install \
+ payment/uc_recurring/uc_recurring.module \
+ shipping/uc_flatrate/po/uc_flatrate.pot \
+ shipping/uc_flatrate/uc_flatrate.info \
+ shipping/uc_flatrate/uc_flatrate.install \
+ shipping/uc_flatrate/uc_flatrate.module \
+ shipping/uc_quote/po/uc_quote.pot \
+ shipping/uc_quote/uc_quote.css \
+ shipping/uc_quote/uc_quote.info \
+ shipping/uc_quote/uc_quote.install \
+ shipping/uc_quote/uc_quote.js \
+ shipping/uc_quote/uc_quote.module \
+ shipping/uc_shipping/images/package.gif \
+ shipping/uc_shipping/images/ship.gif \
+ shipping/uc_shipping/po/uc_shipping.pot \
+ shipping/uc_shipping/uc_shipping.css \
+ shipping/uc_shipping/uc_shipping.info \
+ shipping/uc_shipping/uc_shipping.install \
+ shipping/uc_shipping/uc_shipping.js \
+ shipping/uc_shipping/uc_shipping.module \
+ shipping/uc_ups/po/uc_ups.pot \
+ shipping/uc_ups/uc_ups.css \
+ shipping/uc_ups/uc_ups.info \
+ shipping/uc_ups/uc_ups.install \
+ shipping/uc_ups/uc_ups.module \
+ shipping/uc_ups/uc_ups_logo.gif \
+ shipping/uc_usps/po/uc_usps.pot \
+ shipping/uc_usps/uc_usps.info \
+ shipping/uc_usps/uc_usps.install \
+ shipping/uc_usps/uc_usps.module \
+ shipping/uc_weightquote/po/uc_weightquote.pot \
+ shipping/uc_weightquote/uc_weightquote.info \
+ shipping/uc_weightquote/uc_weightquote.install \
+ shipping/uc_weightquote/uc_weightquote.module \
+ uc_attribute/po/uc_attribute.pot \
+ uc_attribute/uc_attribute.css \
+ uc_attribute/uc_attribute.info \
+ uc_attribute/uc_attribute.install \
+ uc_attribute/uc_attribute.module \
+ uc_cart/images/bullet-arrow-down.gif \
+ uc_cart/images/bullet-arrow-up.gif \
+ uc_cart/images/cart_empty.gif \
+ uc_cart/images/cart_full.gif \
+ uc_cart/po/uc_cart.pot \
+ uc_cart/uc_cart.css \
+ uc_cart/uc_cart.info \
+ uc_cart/uc_cart.install \
+ uc_cart/uc_cart.js \
+ uc_cart/uc_cart.module \
+ uc_cart/uc_cart_block.css \
+ uc_cart/uc_cart_block.js \
+ uc_cart/uc_cart_checkout_pane.inc \
+ uc_cart/uc_cart_workflow.inc \
+ uc_cart_links/po/uc_cart_links.pot \
+ uc_cart_links/uc_cart_links.info \
+ uc_cart_links/uc_cart_links.install \
+ uc_cart_links/uc_cart_links.module \
+ uc_catalog/po/uc_catalog.pot \
+ uc_catalog/uc_catalog.css \
+ uc_catalog/uc_catalog.info \
+ uc_catalog/uc_catalog.install \
+ uc_catalog/uc_catalog.module \
+ uc_file/po/uc_file.pot \
+ uc_file/uc_file.css \
+ uc_file/uc_file.info \
+ uc_file/uc_file.install \
+ uc_file/uc_file.js \
+ uc_file/uc_file.module \
+ uc_googleanalytics/po/uc_googleanalytics.pot \
+ uc_googleanalytics/uc_googleanalytics.info \
+ uc_googleanalytics/uc_googleanalytics.module \
+ uc_importer/README.txt \
+ uc_importer/po/uc_importer.pot \
+ uc_importer/uc_importer.info \
+ uc_importer/uc_importer.install \
+ uc_importer/uc_importer.module \
+ uc_importer/uc_importer_php4.module \
+ uc_notify/po/uc_notify.pot \
+ uc_notify/uc_notify.info \
+ uc_notify/uc_notify.install \
+ uc_notify/uc_notify.module \
+ uc_order/images/false-icon.gif \
+ uc_order/images/order_delete.png \
+ uc_order/images/order_edit.png \
+ uc_order/images/order_view.png \
+ uc_order/images/true-icon.gif \
+ uc_order/po/uc_order.pot \
+ uc_order/templates/admin.itpl.php \
+ uc_order/templates/customer.itpl.php \
+ uc_order/uc_order.css \
+ uc_order/uc_order.info \
+ uc_order/uc_order.install \
+ uc_order/uc_order.js \
+ uc_order/uc_order.module \
+ uc_order/uc_order_line_item.inc \
+ uc_order/uc_order_order_pane.inc \
+ uc_order/uc_order_workflow.inc \
+ uc_product/po/es.po \
+ uc_product/po/uc_product.pot \
+ uc_product/uc_product.css \
+ uc_product/uc_product.info \
+ uc_product/uc_product.install \
+ uc_product/uc_product.js \
+ uc_product/uc_product.module \
+ uc_product_kit/po/es.po \
+ uc_product_kit/po/uc_product_kit.pot \
+ uc_product_kit/uc_product_kit.info \
+ uc_product_kit/uc_product_kit.install \
+ uc_product_kit/uc_product_kit.module \
+ uc_repeater/po/es.po \
+ uc_repeater/po/uc_repeater.pot \
+ uc_repeater/uc_repeater.info \
+ uc_repeater/uc_repeater.install \
+ uc_repeater/uc_repeater.module \
+ uc_reports/po/uc_reports.pot \
+ uc_reports/uc_reports.css \
+ uc_reports/uc_reports.info \
+ uc_reports/uc_reports.install \
+ uc_reports/uc_reports.module \
+ uc_roles/po/uc_roles.pot \
+ uc_roles/uc_roles.css \
+ uc_roles/uc_roles.info \
+ uc_roles/uc_roles.install \
+ uc_roles/uc_roles.module \
+ uc_stock/po/uc_stock.pot \
+ uc_stock/uc_stock.css \
+ uc_stock/uc_stock.info \
+ uc_stock/uc_stock.install \
+ uc_stock/uc_stock.module \
+ uc_store/countries/afghanistan_4_1.cif \
+ uc_store/countries/aruba_533_1.cif \
+ uc_store/countries/australia_36_2.cif \
+ uc_store/countries/austria_40_1.cif \
+ uc_store/countries/belgium_56_1.cif \
+ uc_store/countries/brazil_76_1.cif \
+ uc_store/countries/canada_124_1.cif \
+ uc_store/countries/chile_152_1.cif \
+ uc_store/countries/czech_203_1.cif \
+ uc_store/countries/dominican_republic_214_1.cif \
+ uc_store/countries/egypt_818_1.cif \
+ uc_store/countries/finland_246_1.cif \
+ uc_store/countries/france_250_1.cif \
+ uc_store/countries/germany_276_1.cif \
+ uc_store/countries/greece_300_1.cif \
+ uc_store/countries/india_356_1.cif \
+ uc_store/countries/indonesia_360_1.cif \
+ uc_store/countries/iran_364_1.cif \
+ uc_store/countries/ireland_372_1.cif \
+ uc_store/countries/israel_376_1.cif \
+ uc_store/countries/italy_380_1.cif \
+ uc_store/countries/japan_392_1.cif \
+ uc_store/countries/korea_republic_of_410_1.cif \
+ uc_store/countries/latvia_428_1.cif \
+ uc_store/countries/mexico_484_1.cif \
+ uc_store/countries/netherlands_528_1.cif \
+ uc_store/countries/new_zealand_554_2.cif \
+ uc_store/countries/norway_578_1.cif \
+ uc_store/countries/peru_604_1.cif \
+ uc_store/countries/philippines_608_2.cif \
+ uc_store/countries/poland_616_1.cif \
+ uc_store/countries/romania_642_1.cif \
+ uc_store/countries/russia_643_1.cif \
+ uc_store/countries/saint_lucia_662_1.cif \
+ uc_store/countries/singapore_702_1.cif \
+ uc_store/countries/south_africa_710_1.cif \
+ uc_store/countries/spain_724_1.cif \
+ uc_store/countries/sweden_752_1.cif \
+ uc_store/countries/switzerland_756_1.cif \
+ uc_store/countries/taiwan_158_1.cif \
+ uc_store/countries/turkey_792_1.cif \
+ uc_store/countries/united_kingdom_826_1.cif \
+ uc_store/countries/united_states_840_1.cif \
+ uc_store/countries/venezuela_862_1.cif \
+ uc_store/images/address_book.gif \
+ uc_store/images/alert.gif \
+ uc_store/images/copy.gif \
+ uc_store/images/error.gif \
+ uc_store/images/info.gif \
+ uc_store/images/menu_customers.gif \
+ uc_store/images/menu_customers_small.gif \
+ uc_store/images/menu_help.gif \
+ uc_store/images/menu_help_small.gif \
+ uc_store/images/menu_orders.gif \
+ uc_store/images/menu_orders_small.gif \
+ uc_store/images/menu_products.gif \
+ uc_store/images/menu_products_small.gif \
+ uc_store/images/menu_reports.gif \
+ uc_store/images/menu_reports_small.gif \
+ uc_store/images/menu_store_settings.gif \
+ uc_store/images/menu_store_settings_small.gif \
+ uc_store/images/order_delete.gif \
+ uc_store/images/order_edit.gif \
+ uc_store/images/order_view.gif \
+ uc_store/images/print.gif \
+ uc_store/images/store_monitor.gif \
+ uc_store/images/store_monitor_small.gif \
+ uc_store/includes/XML2Array.php \
+ uc_store/includes/simplexml.php \
+ uc_store/po/es.po \
+ uc_store/po/uc_store.pot \
+ uc_store/uc_country_select.js \
+ uc_store/uc_store.css \
+ uc_store/uc_store.info \
+ uc_store/uc_store.install \
+ uc_store/uc_store.js \
+ uc_store/uc_store.module \
+ uc_taxes/po/es.po \
+ uc_taxes/po/uc_taxes.pot \
+ uc_taxes/uc_taxes.info \
+ uc_taxes/uc_taxes.install \
+ uc_taxes/uc_taxes.js \
+ uc_taxes/uc_taxes.module \
+ uc_taxes/uc_taxes_workflow.inc
+
+DOC_FILES= CREDITS.txt LICENSE.txt README.txt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/drupal5/bsd.drupal.mk"
+.include <bsd.port.post.mk>
diff --git a/www/drupal5-ubercart/distinfo b/www/drupal5-ubercart/distinfo
new file mode 100644
index 000000000000..a5be93f704be
--- /dev/null
+++ b/www/drupal5-ubercart/distinfo
@@ -0,0 +1,3 @@
+MD5 (drupal/ubercart-5.x-1.0-beta5.tar.gz) = 3d3c87af3e4d61c3cda592fd7b4503b8
+SHA256 (drupal/ubercart-5.x-1.0-beta5.tar.gz) = 47df12a0f9eee40781896be543b91d10dd614b6090a2d95a94f5e1a95a010c87
+SIZE (drupal/ubercart-5.x-1.0-beta5.tar.gz) = 466009
diff --git a/www/drupal5-ubercart/pkg-descr b/www/drupal5-ubercart/pkg-descr
new file mode 100644
index 000000000000..cfd18b4cc0ca
--- /dev/null
+++ b/www/drupal5-ubercart/pkg-descr
@@ -0,0 +1,10 @@
+Ubercart is an e-commerce suite developed for Drupal. It has been designed with
+the end user in mind, focusing on usability in three key areas: store
+configuration, product and catalog creation, and order administration. On the
+front end, all major systems are configurable and integrate with the standard
+Drupal systems (node, taxonomy, user, etc.). On the back end, the settings
+pages and order administration pages have been designed with ease of use in
+mind, and we are constantly working to lower the barrier to entry for new
+Ubercart users.
+
+WWW: http://drupal.org/project/ubercart