aboutsummaryrefslogtreecommitdiff
path: root/www/drupal5
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2007-01-05 21:32:19 +0000
committerBrooks Davis <brooks@FreeBSD.org>2007-01-05 21:32:19 +0000
commit874c88d048265580ae01e9d7ef3243a600b5d18e (patch)
tree0545f466de398ea553b2beb261388bf644212205 /www/drupal5
parenteb96436d3a0f4f1b4c11dd63d62e1cf3a7780fa3 (diff)
downloadports-874c88d048265580ae01e9d7ef3243a600b5d18e.tar.gz
ports-874c88d048265580ae01e9d7ef3243a600b5d18e.zip
Notes
Diffstat (limited to 'www/drupal5')
-rw-r--r--www/drupal5/Makefile17
-rw-r--r--www/drupal5/bsd.drupal.mk22
-rw-r--r--www/drupal5/distinfo6
-rw-r--r--www/drupal5/pkg-plist97
4 files changed, 91 insertions, 51 deletions
diff --git a/www/drupal5/Makefile b/www/drupal5/Makefile
index baab2bc98d67..3ff169d84f4c 100644
--- a/www/drupal5/Makefile
+++ b/www/drupal5/Makefile
@@ -6,14 +6,12 @@
#
PORTNAME= drupal
-PORTVERSION= 4.6.10
+PORTVERSION= 4.7.5
CATEGORIES= www
-MASTER_SITES= http://ftp.osuosl.org/pub/drupal/files/projects/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= brooks
-DIST_SUBDIR= drupal
+MASTER_SITES= http://ftp.osuosl.org/pub/drupal/files/projects/
+DIST_SUBDIR= drupal
-MAINTAINER= brooks@FreeBSD.org
+MAINTAINER= brooks@freebsd.org
COMMENT= CMS that supports pgsql and mysql
DRUPAL_PORT= yes
@@ -24,11 +22,9 @@ WANT_PHP_WEB= yes
OPTIONS+= MYSQL "MySQL database support" on \
PGSQL "PostgreSQL database support" off
-WWWOWN?= www
-WWWGRP?= www
-
NO_BUILD= yes
-DOCS= CHANGELOG.txt INSTALL.txt LICENSE.txt MAINTAINERS.txt
+DOCS= CHANGELOG.txt INSTALL.txt LICENSE.txt MAINTAINERS.txt \
+ UPGRADE.txt INSTALL.mysql.txt INSTALL.pgsql.txt
SUB_FILES+= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -48,7 +44,6 @@ do-install:
${CP} ${WRKSRC}/.htaccess ${DRUPAL_DIR}
${CP} ${WRKSRC}/cron.php ${DRUPAL_DIR}
${CP} -R ${WRKSRC}/database ${DRUPAL_DIR}
- ${CP} ${WRKSRC}/favicon.ico ${DRUPAL_DIR}
${CP} -R ${WRKSRC}/includes ${DRUPAL_DIR}
${CP} ${WRKSRC}/index.php ${DRUPAL_DIR}
${CP} -R ${WRKSRC}/misc ${DRUPAL_DIR}
diff --git a/www/drupal5/bsd.drupal.mk b/www/drupal5/bsd.drupal.mk
index 37fb9249394f..23bab7ea3d6b 100644
--- a/www/drupal5/bsd.drupal.mk
+++ b/www/drupal5/bsd.drupal.mk
@@ -12,18 +12,19 @@ DOCSDIR?= ${DRUPAL_DOCSDIR}
.endif
.if defined(DRUPAL_MODULE)
-DRUPAL_VERSION?= 4.6.0
-DRUPAL_MODDIR?= ${DRUPAL_BASE}/modules
+DRUPAL_VERSION?= 4.7.0
+.if defined(DRUPAL_MODSUBDIR)
+DRUPAL_MODDIR?= ${DRUPAL_BASE}/modules/${DRUPAL_MODSUBDIR}
+.else
+DRUPAL_MODDIR?= ${DRUPAL_BASE}/modules
+.endif
DOCSDIR?= ${DRUPAL_DOCSDIR}/${PORTNAME}
-# We have to mirror the distfiles because they are automaticly
-# regenerated snapshots that change size even when nothing changes in the
-# files themselves so they will generally be MASTER_SITE_LOCAL
-MASTER_SITES?= ${MASTER_SITE_LOCAL}
+MASTER_SITES?= http://ftp.osuosl.org/pub/drupal/files/projects/
PKGNAMEPREFIX= drupal-
DIST_SUBDIR= drupal
-RUN_DEPENDS= ${LOCALBASE}/${DRUPAL_BASE}/index.php:${PORTSDIR}/www/drupal
+RUN_DEPENDS+= ${LOCALBASE}/${DRUPAL_BASE}/index.php:${PORTSDIR}/www/drupal
NO_BUILD?= yes
@@ -42,6 +43,9 @@ PLIST_SUB+= DRUPAL_MODDIR=${DRUPAL_MODDIR}
PLIST_FILES+= ${MODULE_FILES:C|^|%%DRUPAL_MODDIR%%/|}
PLIST_FILES+= ${MODULE_CONF_FILES:C|^|%%DRUPAL_MODDIR%%/|:C|$|-dist|}
PLIST_DIRS+= ${MODULE_DIRS:C|^|%%DRUPAL_MODDIR%%/|}
+.if defined(DRUPAL_MODSUBDIR)
+PLIST_DIRS+= ${DRUPAL_MODDIR}
+.endif
.if !defined(NOPORTDOCS)
PLIST_FILES+= ${DOC_FILES:C|^|%%DOCSDIR%%/|}
PLIST_DIRS+= ${DOC_DIRS:C|^|%%DOCSDIR%%/|}
@@ -51,15 +55,19 @@ PLIST_DIRS+= %%DOCSDIR%%
do-install:
.if defined(MODULE_CONF_DIRS)
@${MKDIR} ${MODULE_CONF_DIRS:C|^|${PREFIX}/${DRUPAL_MODDIR}/|}
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${MODULE_CONF_DIRS:C|^|${PREFIX}/${DRUPAL_MODDIR}/|}
.endif
.if defined(MODULE_DIRS)
@${MKDIR} ${MODULE_DIRS:C|^|${PREFIX}/${DRUPAL_MODDIR}/|}
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${MODULE_DIRS:C|^|${PREFIX}/${DRUPAL_MODDIR}/|}
.endif
.for f in ${MODULE_FILES}
@${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${DRUPAL_MODDIR}/${f}
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${DRUPAL_MODDIR}/${f}
.endfor
.for f in ${MODULE_CONF_FILES}
@${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${DRUPAL_MODDIR}/${f}-dist
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${DRUPAL_MODDIR}/${f}-dist
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR} ${DOC_DIRS:C|^|${DOCSDIR}/|}
diff --git a/www/drupal5/distinfo b/www/drupal5/distinfo
index d38713ea00a8..0af6d1ca650e 100644
--- a/www/drupal5/distinfo
+++ b/www/drupal5/distinfo
@@ -1,3 +1,3 @@
-MD5 (drupal/drupal-4.6.10.tar.gz) = c96eef1d33b5bac9526b3b1d6fc5b556
-SHA256 (drupal/drupal-4.6.10.tar.gz) = 1186c4542c20a58f7acad3c2428f58b38d0350cbe68bac35de27ed06699d6cb0
-SIZE (drupal/drupal-4.6.10.tar.gz) = 459223
+MD5 (drupal/drupal-4.7.5.tar.gz) = fc398d8c8f287dac0ccac23ae0665a2b
+SHA256 (drupal/drupal-4.7.5.tar.gz) = d419d1b0244a4a0efb1f5360caf6865a5fc3a6d2769be65d878d12d4ce59445a
+SIZE (drupal/drupal-4.7.5.tar.gz) = 490421
diff --git a/www/drupal5/pkg-plist b/www/drupal5/pkg-plist
index 10159905b407..37272b89237f 100644
--- a/www/drupal5/pkg-plist
+++ b/www/drupal5/pkg-plist
@@ -1,53 +1,79 @@
+%%PORTDOCS%%%%DOCSDIR%%/MAINTAINERS.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.mysql.txt
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.pgsql.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
%%DRUPAL_BASE%%/.htaccess
%%DRUPAL_BASE%%/cron.php
-%%DRUPAL_BASE%%/database/database.mysql
+%%DRUPAL_BASE%%/database/database.4.0.mysql
+%%DRUPAL_BASE%%/database/database.4.1.mysql
%%DRUPAL_BASE%%/database/database.pgsql
%%DRUPAL_BASE%%/database/updates.inc
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
-%%PORTDOCS%%%%DOCSDIR%%/MAINTAINERS.txt
-%%DRUPAL_BASE%%/favicon.ico
-%%DRUPAL_BASE%%/includes/bootstrap.inc
+%%DRUPAL_BASE%%/includes/xmlrpcs.inc
%%DRUPAL_BASE%%/includes/common.inc
%%DRUPAL_BASE%%/includes/database.inc
%%DRUPAL_BASE%%/includes/database.mysql.inc
+%%DRUPAL_BASE%%/includes/database.mysqli.inc
%%DRUPAL_BASE%%/includes/database.pgsql.inc
%%DRUPAL_BASE%%/includes/file.inc
+%%DRUPAL_BASE%%/includes/form.inc
%%DRUPAL_BASE%%/includes/image.inc
+%%DRUPAL_BASE%%/includes/install.inc
%%DRUPAL_BASE%%/includes/locale.inc
%%DRUPAL_BASE%%/includes/menu.inc
%%DRUPAL_BASE%%/includes/module.inc
%%DRUPAL_BASE%%/includes/pager.inc
+%%DRUPAL_BASE%%/includes/path.inc
%%DRUPAL_BASE%%/includes/session.inc
%%DRUPAL_BASE%%/includes/tablesort.inc
%%DRUPAL_BASE%%/includes/theme.inc
+%%DRUPAL_BASE%%/includes/unicode.inc
%%DRUPAL_BASE%%/includes/xmlrpc.inc
-%%DRUPAL_BASE%%/includes/xmlrpcs.inc
+%%DRUPAL_BASE%%/includes/bootstrap.inc
%%DRUPAL_BASE%%/index.php
-%%DRUPAL_BASE%%/misc/arrow-asc.png
+%%DRUPAL_BASE%%/misc/watchdog-warning.png
%%DRUPAL_BASE%%/misc/arrow-desc.png
+%%DRUPAL_BASE%%/misc/autocomplete.js
%%DRUPAL_BASE%%/misc/blog.png
+%%DRUPAL_BASE%%/misc/collapse.js
%%DRUPAL_BASE%%/misc/drupal.css
-%%DRUPAL_BASE%%/misc/druplicon-small.png
+%%DRUPAL_BASE%%/misc/drupal.js
%%DRUPAL_BASE%%/misc/druplicon.png
+%%DRUPAL_BASE%%/misc/favicon.ico
+%%DRUPAL_BASE%%/misc/feed.png
%%DRUPAL_BASE%%/misc/forum-closed.png
%%DRUPAL_BASE%%/misc/forum-default.png
%%DRUPAL_BASE%%/misc/forum-hot-new.png
%%DRUPAL_BASE%%/misc/forum-hot.png
%%DRUPAL_BASE%%/misc/forum-new.png
%%DRUPAL_BASE%%/misc/forum-sticky.png
+%%DRUPAL_BASE%%/misc/grippie.png
+%%DRUPAL_BASE%%/misc/maintenance.css
%%DRUPAL_BASE%%/misc/menu-collapsed.png
%%DRUPAL_BASE%%/misc/menu-expanded.png
%%DRUPAL_BASE%%/misc/menu-leaf.png
-%%DRUPAL_BASE%%/misc/powered-by-drupal-dark.png
-%%DRUPAL_BASE%%/misc/powered-by-drupal-light.png
-%%DRUPAL_BASE%%/misc/powered-by-drupal.png
+%%DRUPAL_BASE%%/misc/powered-black-135x42.png
+%%DRUPAL_BASE%%/misc/powered-black-80x15.png
+%%DRUPAL_BASE%%/misc/powered-black-88x31.png
+%%DRUPAL_BASE%%/misc/powered-blue-135x42.png
+%%DRUPAL_BASE%%/misc/powered-blue-80x15.png
+%%DRUPAL_BASE%%/misc/powered-blue-88x31.png
+%%DRUPAL_BASE%%/misc/powered-gray-135x42.png
+%%DRUPAL_BASE%%/misc/powered-gray-80x15.png
+%%DRUPAL_BASE%%/misc/powered-gray-88x31.png
%%DRUPAL_BASE%%/misc/print.css
+%%DRUPAL_BASE%%/misc/progress.gif
+%%DRUPAL_BASE%%/misc/progress.js
+%%DRUPAL_BASE%%/misc/textarea.js
+%%DRUPAL_BASE%%/misc/throbber.gif
+%%DRUPAL_BASE%%/misc/update.js
+%%DRUPAL_BASE%%/misc/upload.js
%%DRUPAL_BASE%%/misc/watchdog-error.png
-%%DRUPAL_BASE%%/misc/watchdog-warning.png
%%DRUPAL_BASE%%/misc/xml.png
-%%DRUPAL_BASE%%/modules/aggregator.module
+%%DRUPAL_BASE%%/misc/arrow-asc.png
+%%DRUPAL_BASE%%/modules/watchdog.module
%%DRUPAL_BASE%%/modules/archive.module
%%DRUPAL_BASE%%/modules/block.module
%%DRUPAL_BASE%%/modules/blog.module
@@ -68,7 +94,7 @@
%%DRUPAL_BASE%%/modules/ping.module
%%DRUPAL_BASE%%/modules/poll.module
%%DRUPAL_BASE%%/modules/profile.module
-%%DRUPAL_BASE%%/modules/queue.module
+%%DRUPAL_BASE%%/modules/user.module
%%DRUPAL_BASE%%/modules/search.module
%%DRUPAL_BASE%%/modules/statistics.module
%%DRUPAL_BASE%%/modules/story.module
@@ -77,8 +103,7 @@
%%DRUPAL_BASE%%/modules/throttle.module
%%DRUPAL_BASE%%/modules/tracker.module
%%DRUPAL_BASE%%/modules/upload.module
-%%DRUPAL_BASE%%/modules/user.module
-%%DRUPAL_BASE%%/modules/watchdog.module
+%%DRUPAL_BASE%%/modules/aggregator.module
%%DRUPAL_BASE%%/scripts/code-clean.sh
%%DRUPAL_BASE%%/scripts/code-style.pl
%%DRUPAL_BASE%%/scripts/cron-curl.sh
@@ -87,24 +112,32 @@
@unexec if cmp -s %D/%%DRUPAL_BASE%%/sites/default/settings.php-dist %D/%%DRUPAL_BASE%%/sites/default/settings.php; then rm -f %D/%%DRUPAL_BASE%%/sites/default/settings.php; fi
%%DRUPAL_BASE%%/sites/default/settings.php-dist
@exec if [ ! -f %D/%%DRUPAL_BASE%%/sites/default/settings.php ] ; then cp -p %D/%F %B/settings.php; fi
+%%DRUPAL_BASE%%/themes/bluemarine/style.css
+%%DRUPAL_BASE%%/themes/bluemarine/box.tpl.php
+%%DRUPAL_BASE%%/themes/bluemarine/comment.tpl.php
%%DRUPAL_BASE%%/themes/bluemarine/logo.png
+%%DRUPAL_BASE%%/themes/bluemarine/node.tpl.php
+%%DRUPAL_BASE%%/themes/bluemarine/page.tpl.php
%%DRUPAL_BASE%%/themes/bluemarine/screenshot.png
-%%DRUPAL_BASE%%/themes/bluemarine/style.css
-%%DRUPAL_BASE%%/themes/bluemarine/xtemplate.xtmpl
-%%DRUPAL_BASE%%/themes/chameleon/background.png
-%%DRUPAL_BASE%%/themes/chameleon/chameleon.theme
-%%DRUPAL_BASE%%/themes/chameleon/common.css
-%%DRUPAL_BASE%%/themes/chameleon/logo.png
+%%DRUPAL_BASE%%/themes/bluemarine/block.tpl.php
%%DRUPAL_BASE%%/themes/chameleon/marvin/bullet.png
%%DRUPAL_BASE%%/themes/chameleon/marvin/druplicon-watermark.png
%%DRUPAL_BASE%%/themes/chameleon/marvin/logo.png
%%DRUPAL_BASE%%/themes/chameleon/marvin/screenshot.png
%%DRUPAL_BASE%%/themes/chameleon/marvin/style.css
+%%DRUPAL_BASE%%/themes/chameleon/chameleon.theme
+%%DRUPAL_BASE%%/themes/chameleon/common.css
+%%DRUPAL_BASE%%/themes/chameleon/background.png
%%DRUPAL_BASE%%/themes/chameleon/screenshot.png
%%DRUPAL_BASE%%/themes/chameleon/style.css
-%%DRUPAL_BASE%%/themes/engines/xtemplate/xtemplate.engine
-%%DRUPAL_BASE%%/themes/engines/xtemplate/xtemplate.inc
-%%DRUPAL_BASE%%/themes/pushbutton/arrow-next-hover.png
+%%DRUPAL_BASE%%/themes/chameleon/logo.png
+%%DRUPAL_BASE%%/themes/engines/phptemplate/block.tpl.php
+%%DRUPAL_BASE%%/themes/engines/phptemplate/box.tpl.php
+%%DRUPAL_BASE%%/themes/engines/phptemplate/comment.tpl.php
+%%DRUPAL_BASE%%/themes/engines/phptemplate/default.tpl.php
+%%DRUPAL_BASE%%/themes/engines/phptemplate/node.tpl.php
+%%DRUPAL_BASE%%/themes/engines/phptemplate/phptemplate.engine
+%%DRUPAL_BASE%%/themes/pushbutton/tabs-option-on.png
%%DRUPAL_BASE%%/themes/pushbutton/arrow-next-visited.png
%%DRUPAL_BASE%%/themes/pushbutton/arrow-next.png
%%DRUPAL_BASE%%/themes/pushbutton/arrow-prev-hover.png
@@ -114,6 +147,9 @@
%%DRUPAL_BASE%%/themes/pushbutton/arrow-up-visited.png
%%DRUPAL_BASE%%/themes/pushbutton/arrow-up.png
%%DRUPAL_BASE%%/themes/pushbutton/background.png
+%%DRUPAL_BASE%%/themes/pushbutton/block.tpl.php
+%%DRUPAL_BASE%%/themes/pushbutton/box.tpl.php
+%%DRUPAL_BASE%%/themes/pushbutton/comment.tpl.php
%%DRUPAL_BASE%%/themes/pushbutton/forum-container.jpg
%%DRUPAL_BASE%%/themes/pushbutton/forum-link.png
%%DRUPAL_BASE%%/themes/pushbutton/header-a.jpg
@@ -125,18 +161,19 @@
%%DRUPAL_BASE%%/themes/pushbutton/logo-background.jpg
%%DRUPAL_BASE%%/themes/pushbutton/logo-hover.jpg
%%DRUPAL_BASE%%/themes/pushbutton/logo.png
+%%DRUPAL_BASE%%/themes/pushbutton/node.tpl.php
+%%DRUPAL_BASE%%/themes/pushbutton/page.tpl.php
%%DRUPAL_BASE%%/themes/pushbutton/screenshot.png
%%DRUPAL_BASE%%/themes/pushbutton/style.css
%%DRUPAL_BASE%%/themes/pushbutton/tabs-off.png
%%DRUPAL_BASE%%/themes/pushbutton/tabs-on.png
%%DRUPAL_BASE%%/themes/pushbutton/tabs-option-hover.png
%%DRUPAL_BASE%%/themes/pushbutton/tabs-option-off.png
-%%DRUPAL_BASE%%/themes/pushbutton/tabs-option-on.png
-%%DRUPAL_BASE%%/themes/pushbutton/xtemplate.xtmpl
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-next-hover.png
%%DRUPAL_BASE%%/update.php
%%DRUPAL_BASE%%/xmlrpc.php
@dirrm %%DRUPAL_BASE%%/themes/pushbutton
-@dirrm %%DRUPAL_BASE%%/themes/engines/xtemplate
+@dirrm %%DRUPAL_BASE%%/themes/engines/phptemplate
@dirrm %%DRUPAL_BASE%%/themes/engines
@dirrm %%DRUPAL_BASE%%/themes/chameleon/marvin
@dirrm %%DRUPAL_BASE%%/themes/chameleon