aboutsummaryrefslogtreecommitdiff
path: root/www/drupal6-webform
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-16 19:50:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-16 19:50:05 +0000
commitcdaadb8eac8288a0336555087632d1e196c008d6 (patch)
tree0aa5a27944a3b7c54033f1448b9ebb39b3f12034 /www/drupal6-webform
parent03de9288ab33ac02aa3062baed298ce9c3122382 (diff)
Notes
Diffstat (limited to 'www/drupal6-webform')
-rw-r--r--www/drupal6-webform/Makefile42
-rw-r--r--www/drupal6-webform/distinfo3
-rw-r--r--www/drupal6-webform/pkg-descr13
3 files changed, 58 insertions, 0 deletions
diff --git a/www/drupal6-webform/Makefile b/www/drupal6-webform/Makefile
new file mode 100644
index 000000000000..558bd5e57a99
--- /dev/null
+++ b/www/drupal6-webform/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: drupal6-webform
+# Date created: 2 June 2009
+# Whom: Nick Hilliard <nick@foobar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webform
+DISTVERSION= 6.x-2.7
+CATEGORIES= www
+
+MAINTAINER= nick@foobar.org
+COMMENT= Drupal module to allow easy creation of forms
+
+DRUPAL6_MODULE= yes
+
+MODULE_FILES= components/date.inc components/email.inc \
+ components/fieldset.inc components/file.inc \
+ components/grid.inc components/hidden.inc \
+ components/markup.inc components/pagebreak.inc \
+ components/select.inc components/textarea.inc \
+ components/textfield.inc components/time.inc \
+ webform-confirmation.tpl.php webform-form.tpl.php \
+ webform-mail.tpl.php webform.css webform.info \
+ webform.install webform.js webform.module \
+ webform_components.inc webform_export.inc webform_report.inc \
+ webform_submissions.inc tests/components.test \
+ tests/permissions.test tests/submission.test \
+ tests/webform.test translations/webform.pot \
+ translations/cs.po translations/da.po translations/de.po \
+ translations/el.po translations/es.po translations/fr.po \
+ translations/he.po translations/hu.po translations/it.po \
+ translations/ja.po translations/nl.po translations/ru.po \
+ translations/sk.po translations/sv.po
+
+MODULE_DIRS= components tests translations
+
+DOC_FILES= CHANGELOG.txt INSTALL.txt README.txt THEMING.txt LICENSE.txt
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/drupal5/bsd.drupal.mk"
+.include <bsd.port.post.mk>
diff --git a/www/drupal6-webform/distinfo b/www/drupal6-webform/distinfo
new file mode 100644
index 000000000000..d7bc3de5c451
--- /dev/null
+++ b/www/drupal6-webform/distinfo
@@ -0,0 +1,3 @@
+MD5 (drupal/webform-6.x-2.7.tar.gz) = 7bd1634ec1e4ac2393cbda7fa2fc6eec
+SHA256 (drupal/webform-6.x-2.7.tar.gz) = c4808c2377443780f53d828c6b7d8addb2777b4cb019d5e27f4f0b5a53508ef4
+SIZE (drupal/webform-6.x-2.7.tar.gz) = 254954
diff --git a/www/drupal6-webform/pkg-descr b/www/drupal6-webform/pkg-descr
new file mode 100644
index 000000000000..ede991590058
--- /dev/null
+++ b/www/drupal6-webform/pkg-descr
@@ -0,0 +1,13 @@
+This module adds a webform nodetype to your Drupal site. Typical uses for
+Webform are questionnaires, contact or request/register forms, surveys,
+polls or a front end to issues tracking systems.
+
+Submissions from a webform are saved in a database table and can optionally
+be mailed to a nominated e-mail address upon submission. Past submissions
+are viewable for users with the correct permissions.
+
+Webform includes some simple statistical tools to help in form design and
+evaluation and also allows the whole table to be downloaded as a csv file
+for detailed statistical analysis.
+
+WWW: http://drupal.org/project/webform