aboutsummaryrefslogtreecommitdiff
path: root/www/drupal6/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-29 17:51:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-29 17:51:04 +0000
commit3e1bdc306cade5cf703b297edb462cb85049329a (patch)
treef220edd2eae15fd7cbb586916bc195512fffc840 /www/drupal6/Makefile
parent13b4e34a44a2eed028f0ef6cff26f0b75d17a66e (diff)
downloadports-3e1bdc306cade5cf703b297edb462cb85049329a.tar.gz
ports-3e1bdc306cade5cf703b297edb462cb85049329a.zip
Notes
Diffstat (limited to 'www/drupal6/Makefile')
-rw-r--r--www/drupal6/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/drupal6/Makefile b/www/drupal6/Makefile
index e98d32e4b344..e4dfc911df9d 100644
--- a/www/drupal6/Makefile
+++ b/www/drupal6/Makefile
@@ -48,6 +48,11 @@ do-install:
${CP} -R ${WRKSRC}/misc ${PREFIX}/${DRUPDIR}
${CP} -R ${WRKSRC}/modules ${PREFIX}/${DRUPDIR}
${CP} -R ${WRKSRC}/scripts ${PREFIX}/${DRUPDIR}
+ ${MKDIR} ${PREFIX}/${DRUPDIR}/sites/default
+ ${CP} ${WRKSRC}/sites/default/settings.php ${PREFIX}/${DRUPDIR}/sites/default/settings.php-dist
+ @if [ ! -f ${PREFIX}/${DRUPDIR}/sites/default/settings.php ]; then \
+ ${CP} -p ${PREFIX}/${DRUPDIR}/sites/default/settings.php-dist ${PREFIX}/${DRUPDIR}/sites/default/settings.php ; \
+ fi
${CP} -R ${WRKSRC}/sites ${PREFIX}/${DRUPDIR}
${CP} -R ${WRKSRC}/themes ${PREFIX}/${DRUPDIR}
${CP} ${WRKSRC}/update.php ${PREFIX}/${DRUPDIR}