aboutsummaryrefslogtreecommitdiff
path: root/www/drush
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-06-02 20:41:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-06-02 20:41:14 +0000
commit7ba2198e09a7e4b98dd690348ff628e5dbea1584 (patch)
tree6fe82230fb1275b2f4a58053ac65a998d6d47faa /www/drush
parent7d88409993985da2ee82dfa6fea6e9740c3e85e4 (diff)
downloadports-7ba2198e09a7e4b98dd690348ff628e5dbea1584.tar.gz
ports-7ba2198e09a7e4b98dd690348ff628e5dbea1584.zip
Notes
Diffstat (limited to 'www/drush')
-rw-r--r--www/drush/Makefile20
-rw-r--r--www/drush/distinfo4
-rw-r--r--www/drush/files/patch-drush57
-rw-r--r--www/drush/pkg-plist57
4 files changed, 55 insertions, 83 deletions
diff --git a/www/drush/Makefile b/www/drush/Makefile
index d306aa8c0411..8883a5f2f8b1 100644
--- a/www/drush/Makefile
+++ b/www/drush/Makefile
@@ -6,20 +6,25 @@
#
PORTNAME= drush
-PORTVERSION= 3.0
+PORTVERSION= 4.4
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
-DISTNAME= drush-All-versions-${PORTVERSION}
+DISTNAME= drush-7.x-${PORTVERSION}
-MAINTAINER= freebsduser@paradisegreen.co.uk
+MAINTAINER= dgeo@centrale-marseille.fr
COMMENT= Drupal command line and scripting interface
+RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Table.php:${PORTSDIR}/devel/pear-Console_Table
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
NO_BUILD= yes
# set php requirements same as drupal itself
-USE_PHP= gd pcre session xml mbstring
+USE_PHP= gd pcre session xml mbstring ctype
IGNORE_WITH_PHP=4
-WANT_PHP_WEB= yes
+WANT_PHP_CLI= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -30,7 +35,8 @@ do-configure:
do-install:
${MKDIR} ${DATADIR}
- ( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR} '! ( -name drush -or -name drush.bat -or -name *.orig -or -name *.bak )' )
- ${INSTALL_SCRIPT} ${WRKSRC}/drush ${PREFIX}/bin
+ ( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR} '! ( -name drush.bat -or -name *.orig -or -name *.bak -or -name .gitignore -or -name LICENSE.txt )' )
+ ${CHMOD} 755 ${DATADIR}/drush
+ ${LN} -s ${DATADIR}/drush ${PREFIX}/bin/drush
.include <bsd.port.post.mk>
diff --git a/www/drush/distinfo b/www/drush/distinfo
index 25d0c9c0b32e..85b91bbacdf1 100644
--- a/www/drush/distinfo
+++ b/www/drush/distinfo
@@ -1,2 +1,2 @@
-SHA256 (drush-All-versions-3.0.tar.gz) = 2112ab5a9b6c9ad9947c85f99a1a56dd1db40d4bb69d0cf962b84e6bd95c4207
-SIZE (drush-All-versions-3.0.tar.gz) = 171892
+SIZE (drush-7.x-4.4.tar.gz) = 253012
+SHA256 (drush-7.x-4.4.tar.gz) = f6af5d259c169d0b3738568c9a8d114c8958df6deb5440fce3b5842e753fc88f
diff --git a/www/drush/files/patch-drush b/www/drush/files/patch-drush
deleted file mode 100644
index fcea332580c0..000000000000
--- a/www/drush/files/patch-drush
+++ /dev/null
@@ -1,57 +0,0 @@
---- drush.orig 2010-04-29 21:25:16.000000000 +0100
-+++ drush 2010-04-29 21:32:18.000000000 +0100
-@@ -1,51 +1,16 @@
--#!/usr/bin/env sh
-+#!/bin/sh
- # $Id: drush,v 1.17 2010/04/14 22:29:33 weitzman Exp $
- #
- # This script is a simple wrapper that will run Drush with the most appropriate
- # php executable it can find.
- #
-
--# Get the absolute path of this executable
--ORIGDIR=$(pwd)
--SELF_PATH=$(cd -P -- "$(dirname -- "$0")" && pwd -P) && SELF_PATH=$SELF_PATH/$(basename -- "$0")
--
--# Resolve symlinks - this is the equivalent of "readlink -f", but also works with non-standard OS X readlink.
--while [ -h $SELF_PATH ]; do
-- # 1) cd to directory of the symlink
-- # 2) cd to the directory of where the symlink points
-- # 3) Get the pwd
-- # 4) Append the basename
-- DIR=$(dirname -- "$SELF_PATH")
-- SYM=$(readlink $SELF_PATH)
-- SELF_PATH=$(cd $DIR && cd $(dirname -- "$SYM") && pwd)/$(basename -- "$SYM")
--done
--cd "$ORIGDIR"
--
- # Build the path to drush.php.
--SCRIPT_PATH=$(dirname $SELF_PATH)/drush.php
--case $(uname -a) in
-- CYGWIN*)
-- SCRIPT_PATH=$(cygpath -w -a -- "$SCRIPT_PATH") ;;
--esac
-+SCRIPT_PATH=XXXDATADIRXXX/drush.php
-
- # If not exported and term is set determine and export the number of columns.
- if [ -z $COLUMNS ] && [ -n "$TERM" ]; then
- export COLUMNS=$(tput cols)
- fi
-
--# Special case for *AMP installers, since they normally don't set themselves as the default cli php out of the box.
--for php in /Applications/MAMP/bin/php5/bin/php /opt/lampp/bin/php /Applications/xampp/xamppfiles/bin/php /Applications/acquia-drupal/php/bin/php; do
-- if [ -x $php ]; then
-- exec $php $SCRIPT_PATH --php="$php" "$@"
-- fi
--done
--
--# We check for a command line (cli) version of php, and if found use that.
--which php-cli >/dev/null 2>&1
--if [ "$?" = 0 ] ; then
-- exec php-cli $SCRIPT_PATH --php="php-cli" "$@"
--else
-- # Alternatively we run with straight php, which works on most other systems.
-- # The --php=`which php` is for Dreamhost, which behaves oddly. See http://drupal.org/node/662926
-- exec php $SCRIPT_PATH --php=`which php` "$@"
--fi
-+exec php $SCRIPT_PATH --php=`which php` "$@"
diff --git a/www/drush/pkg-plist b/www/drush/pkg-plist
index 077edc44bebb..99dbb1843b92 100644
--- a/www/drush/pkg-plist
+++ b/www/drush/pkg-plist
@@ -1,44 +1,65 @@
bin/drush
-%%DATADIR%%/LICENSE.txt
%%DATADIR%%/README.txt
+%%DATADIR%%/commands/core/clear.cache.inc
+%%DATADIR%%/commands/core/core.drush.inc
+%%DATADIR%%/commands/core/docs.drush.inc
%%DATADIR%%/commands/core/drupal/batch_6.inc
%%DATADIR%%/commands/core/drupal/batch_7.inc
%%DATADIR%%/commands/core/drupal/environment_5.inc
%%DATADIR%%/commands/core/drupal/environment_6.inc
%%DATADIR%%/commands/core/drupal/environment_7.inc
+%%DATADIR%%/commands/core/drupal/site_install_6.inc
+%%DATADIR%%/commands/core/drupal/site_install_7.inc
%%DATADIR%%/commands/core/drupal/update_5.inc
%%DATADIR%%/commands/core/drupal/update_6.inc
%%DATADIR%%/commands/core/drupal/update_7.inc
-%%DATADIR%%/commands/core/clear.cache.inc
-%%DATADIR%%/commands/core/core.drush.inc
+%%DATADIR%%/commands/core/field.drush.inc
+%%DATADIR%%/commands/core/help.drush.inc
+%%DATADIR%%/commands/core/image.drush.inc
%%DATADIR%%/commands/core/rsync.core.inc
%%DATADIR%%/commands/core/scratch.php
%%DATADIR%%/commands/core/search.drush.inc
%%DATADIR%%/commands/core/site_install.drush.inc
%%DATADIR%%/commands/core/sitealias.drush.inc
+%%DATADIR%%/commands/core/test.drush.inc
+%%DATADIR%%/commands/core/topic.drush.inc
%%DATADIR%%/commands/core/upgrade.drush.inc
%%DATADIR%%/commands/core/variable.drush.inc
%%DATADIR%%/commands/core/watchdog.drush.inc
-%%DATADIR%%/commands/pm/package_handler/wget.inc
%%DATADIR%%/commands/pm/package_handler/cvs.inc
+%%DATADIR%%/commands/pm/package_handler/git_drupalorg.inc
+%%DATADIR%%/commands/pm/package_handler/wget.inc
%%DATADIR%%/commands/pm/pm.drush.inc
-%%DATADIR%%/commands/pm/updatecode.pm.inc
%%DATADIR%%/commands/pm/update_info/drupal_5.inc
%%DATADIR%%/commands/pm/update_info/drupal_6.inc
%%DATADIR%%/commands/pm/update_info/drupal_7.inc
+%%DATADIR%%/commands/pm/updatecode.pm.inc
%%DATADIR%%/commands/pm/version_control/backup.inc
%%DATADIR%%/commands/pm/version_control/bzr.inc
%%DATADIR%%/commands/pm/version_control/svn.inc
%%DATADIR%%/commands/sql/sql.drush.inc
%%DATADIR%%/commands/sql/sync.sql.inc
-%%DATADIR%%/drush.api.php
+%%DATADIR%%/commands/user/user.drush.inc
+%%DATADIR%%/docs/bootstrap.html
+%%DATADIR%%/docs/commands.html
+%%DATADIR%%/docs/context.html
+%%DATADIR%%/docs/drush.api.php
+%%DATADIR%%/docs/shellscripts.html
+%%DATADIR%%/docs/upgrade.html
%%DATADIR%%/drush.info
%%DATADIR%%/drush.php
+%%DATADIR%%/drush
%%DATADIR%%/drush_logo-black.png
%%DATADIR%%/examples/example.aliases.drushrc.php
+%%DATADIR%%/examples/example.bashrc
+%%DATADIR%%/examples/example.drush.ini
%%DATADIR%%/examples/example.drushrc.php
+%%DATADIR%%/examples/helloworld.script
+%%DATADIR%%/examples/policy.drush.inc
+%%DATADIR%%/examples/sandwich-topic.txt
%%DATADIR%%/examples/sandwich.drush.inc
%%DATADIR%%/examples/sandwich.txt
+%%DATADIR%%/examples/xkcd.drush.inc
%%DATADIR%%/includes/backend.inc
%%DATADIR%%/includes/batch.inc
%%DATADIR%%/includes/command.inc
@@ -46,14 +67,16 @@ bin/drush
%%DATADIR%%/includes/drush.inc
%%DATADIR%%/includes/environment.inc
%%DATADIR%%/includes/sitealias.inc
-@dirrmtry %%DATADIR%%/includes
-@dirrmtry %%DATADIR%%/examples
-@dirrmtry %%DATADIR%%/commands/sql
-@dirrmtry %%DATADIR%%/commands/pm/version_control
-@dirrmtry %%DATADIR%%/commands/pm/update_info
-@dirrmtry %%DATADIR%%/commands/pm/package_handler
-@dirrmtry %%DATADIR%%/commands/pm
-@dirrmtry %%DATADIR%%/commands/core/drupal
-@dirrmtry %%DATADIR%%/commands/core
-@dirrmtry %%DATADIR%%/commands
-@dirrmtry %%DATADIR%%
+@dirrm %%DATADIR%%/includes
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%/docs
+@dirrm %%DATADIR%%/commands/user
+@dirrm %%DATADIR%%/commands/sql
+@dirrm %%DATADIR%%/commands/pm/version_control
+@dirrm %%DATADIR%%/commands/pm/update_info
+@dirrm %%DATADIR%%/commands/pm/package_handler
+@dirrm %%DATADIR%%/commands/pm
+@dirrm %%DATADIR%%/commands/core/drupal
+@dirrm %%DATADIR%%/commands/core
+@dirrm %%DATADIR%%/commands
+@dirrm %%DATADIR%%