aboutsummaryrefslogtreecommitdiff
path: root/www/drush
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-09-30 11:11:08 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-09-30 11:11:08 +0000
commit1579a1110c4f477e46fec209910e5031357d2115 (patch)
tree29eedeca7cfbee6faf58184251ede5c0451a3cd7 /www/drush
parente16500bfdcad56e802433d826f54ffa6981af049 (diff)
- Update to 4.5
PR: ports/161149 Submitted by: Geoffroy Desvernay <dgeo@centrale-marseille.fr> (maintainer)
Notes
Notes: svn path=/head/; revision=282661
Diffstat (limited to 'www/drush')
-rw-r--r--www/drush/Makefile6
-rw-r--r--www/drush/distinfo4
-rw-r--r--www/drush/pkg-plist34
3 files changed, 34 insertions, 10 deletions
diff --git a/www/drush/Makefile b/www/drush/Makefile
index 8883a5f2f8b1..6313907b9cb5 100644
--- a/www/drush/Makefile
+++ b/www/drush/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= drush
-PORTVERSION= 4.4
+PORTVERSION= 4.5
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
DISTNAME= drush-7.x-${PORTVERSION}
@@ -14,11 +14,11 @@ DISTNAME= drush-7.x-${PORTVERSION}
MAINTAINER= dgeo@centrale-marseille.fr
COMMENT= Drupal command line and scripting interface
-RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Table.php:${PORTSDIR}/devel/pear-Console_Table
-
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Table.php:${PORTSDIR}/devel/pear-Console_Table
+
NO_BUILD= yes
# set php requirements same as drupal itself
diff --git a/www/drush/distinfo b/www/drush/distinfo
index 85b91bbacdf1..c75ba876b825 100644
--- a/www/drush/distinfo
+++ b/www/drush/distinfo
@@ -1,2 +1,2 @@
-SIZE (drush-7.x-4.4.tar.gz) = 253012
-SHA256 (drush-7.x-4.4.tar.gz) = f6af5d259c169d0b3738568c9a8d114c8958df6deb5440fce3b5842e753fc88f
+SIZE (drush-7.x-4.5.tar.gz) = 282760
+SHA256 (drush-7.x-4.5.tar.gz) = 11a8ba3acbebf0be45407dee54a4c59cb9da7dfb461cf4ed9e27e78b2968fc99
diff --git a/www/drush/pkg-plist b/www/drush/pkg-plist
index 99dbb1843b92..5e2135d70abd 100644
--- a/www/drush/pkg-plist
+++ b/www/drush/pkg-plist
@@ -4,15 +4,15 @@ bin/drush
%%DATADIR%%/commands/core/core.drush.inc
%%DATADIR%%/commands/core/docs.drush.inc
%%DATADIR%%/commands/core/drupal/batch_6.inc
-%%DATADIR%%/commands/core/drupal/batch_7.inc
+%%DATADIR%%/commands/core/drupal/batch.inc
%%DATADIR%%/commands/core/drupal/environment_5.inc
%%DATADIR%%/commands/core/drupal/environment_6.inc
-%%DATADIR%%/commands/core/drupal/environment_7.inc
+%%DATADIR%%/commands/core/drupal/environment.inc
%%DATADIR%%/commands/core/drupal/site_install_6.inc
-%%DATADIR%%/commands/core/drupal/site_install_7.inc
+%%DATADIR%%/commands/core/drupal/site_install.inc
%%DATADIR%%/commands/core/drupal/update_5.inc
%%DATADIR%%/commands/core/drupal/update_6.inc
-%%DATADIR%%/commands/core/drupal/update_7.inc
+%%DATADIR%%/commands/core/drupal/update.inc
%%DATADIR%%/commands/core/field.drush.inc
%%DATADIR%%/commands/core/help.drush.inc
%%DATADIR%%/commands/core/image.drush.inc
@@ -32,7 +32,7 @@ bin/drush
%%DATADIR%%/commands/pm/pm.drush.inc
%%DATADIR%%/commands/pm/update_info/drupal_5.inc
%%DATADIR%%/commands/pm/update_info/drupal_6.inc
-%%DATADIR%%/commands/pm/update_info/drupal_7.inc
+%%DATADIR%%/commands/pm/update_info/drupal.inc
%%DATADIR%%/commands/pm/updatecode.pm.inc
%%DATADIR%%/commands/pm/version_control/backup.inc
%%DATADIR%%/commands/pm/version_control/bzr.inc
@@ -67,6 +67,29 @@ bin/drush
%%DATADIR%%/includes/drush.inc
%%DATADIR%%/includes/environment.inc
%%DATADIR%%/includes/sitealias.inc
+%%DATADIR%%/commands/core/cache.drush.inc
+%%DATADIR%%/commands/core/archive.drush.inc
+%%DATADIR%%/tests/siteUpgradeTest.php
+%%DATADIR%%/tests/sqlSyncTest.php
+%%DATADIR%%/tests/variableTest.php
+%%DATADIR%%/tests/siteAliasTest.php
+%%DATADIR%%/tests/COVERAGE.txt
+%%DATADIR%%/tests/drush_testcase.inc
+%%DATADIR%%/tests/phpunit.xml.dist
+%%DATADIR%%/tests/userTest.php
+%%DATADIR%%/tests/README.txt
+%%DATADIR%%/tests/runner.php
+%%DATADIR%%/tests/archiveDumpTest.php
+%%DATADIR%%/tests/pmDownloadTest.php
+%%DATADIR%%/tests/contextTest.php
+%%DATADIR%%/tests/backendTest.php
+%%DATADIR%%/tests/commandTest.php
+%%DATADIR%%/tests/pmUpdateCodeTest.php
+%%DATADIR%%/tests/pmEnDisUnListTest.php
+%%DATADIR%%/tests/coreTest.php
+%%DATADIR%%/tests/devel.xml
+%%DATADIR%%/tests/fieldTest.php
+%%DATADIR%%/tests/unit.drush.inc
@dirrm %%DATADIR%%/includes
@dirrm %%DATADIR%%/examples
@dirrm %%DATADIR%%/docs
@@ -79,4 +102,5 @@ bin/drush
@dirrm %%DATADIR%%/commands/core/drupal
@dirrm %%DATADIR%%/commands/core
@dirrm %%DATADIR%%/commands
+@dirrm %%DATADIR%%/tests
@dirrm %%DATADIR%%