aboutsummaryrefslogtreecommitdiff
path: root/www/dtse
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-26 15:45:50 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-26 15:45:50 +0000
commit43d2efc0fc5e04d0ef908b2bb708e1732ab4ba60 (patch)
tree1abadab5ba1b03fb47f9f5ceac46fe4375d71bb5 /www/dtse
parent85c1629e8bf0b6eddd665534fa636835009893ae (diff)
Notes
Diffstat (limited to 'www/dtse')
-rw-r--r--www/dtse/Makefile4
-rw-r--r--www/dtse/files/patch-GNUmakefile.in26
2 files changed, 27 insertions, 3 deletions
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
index 663b6ec9e63a..de9caccb42e9 100644
--- a/www/dtse/Makefile
+++ b/www/dtse/Makefile
@@ -20,9 +20,8 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif
-USES= perl5
+USES= gmake perl5
USE_BZIP2= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= aclocal:env automake:env autoconf:env
HAS_CONFIGURE= yes
@@ -32,7 +31,6 @@ MAKEFILE= GNUmakefile
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
pre-configure:
cd ${WRKSRC}; ${SH} autogen.sh
diff --git a/www/dtse/files/patch-GNUmakefile.in b/www/dtse/files/patch-GNUmakefile.in
new file mode 100644
index 000000000000..de2127a7c00e
--- /dev/null
+++ b/www/dtse/files/patch-GNUmakefile.in
@@ -0,0 +1,26 @@
+--- ./GNUmakefile.in.orig 2013-11-24 15:43:48.000000000 -0800
++++ ./GNUmakefile.in 2013-11-24 15:43:56.000000000 -0800
+@@ -40,16 +40,16 @@
+ -include ${cxxdep}
+
+ install: installdirs
+- ${INSTALL_DATA} LICENSE LICENSE.html ${prefix}
+- ${INSTALL_DATA} README README.html osi-certified-90x75.png ${prefix}
+- ${INSTALL_PROGRAM} ${exe} ${bindir}
+- ${INSTALL_SCRIPT} search.cgi ${prefix}/http
+- ${INSTALL_DATA} dtse_pb.png ${prefix}/http
++ ${INSTALL_DATA} LICENSE LICENSE.html ${DESTDIR}${prefix}
++ ${INSTALL_DATA} README README.html osi-certified-90x75.png ${DESTDIR}${prefix}
++ ${INSTALL_PROGRAM} ${exe} ${DESTDIR}${bindir}
++ ${INSTALL_SCRIPT} search.cgi ${DESTDIR}${prefix}/http
++ ${INSTALL_DATA} dtse_pb.png ${DESTDIR}${prefix}/http
+ ${INSTALL_DATA} header.html body.html footer.html notfound.html \
+- pages.html ${prefix}/data
++ pages.html ${DESTDIR}${prefix}/data
+
+ installdirs: mkinstalldirs
+- ./mkinstalldirs ${bindir} ${prefix}/http ${prefix}/data
++ ./mkinstalldirs ${DESTDIR}${bindir} ${DESTDIR}${prefix}/http ${DESTDIR}${prefix}/data
+
+ clean:
+ -rm -rf object ${exe} core $(patsubst %, %.core, ${exe}) $(patsubst %, \