aboutsummaryrefslogtreecommitdiff
path: root/www/dummyflash/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
commit15b6544926b07a98710eeb765baf03e3fc9a195c (patch)
tree35103cf986d2ed2295c97768e62afcc47dfed877 /www/dummyflash/Makefile
parent23fcf54562404bb41380488c8318ac0e3ce15efc (diff)
downloadports-15b6544926b07a98710eeb765baf03e3fc9a195c.tar.gz
ports-15b6544926b07a98710eeb765baf03e3fc9a195c.zip
Notes
Diffstat (limited to 'www/dummyflash/Makefile')
-rw-r--r--www/dummyflash/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/www/dummyflash/Makefile b/www/dummyflash/Makefile
index dd6254be7688..3305bf17ec07 100644
--- a/www/dummyflash/Makefile
+++ b/www/dummyflash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dummyflash
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= ftp://ftp.netscape.com/pub/sdk/plugin/unix/
DISTNAME= unix-sdk-3.0b5
@@ -21,8 +21,14 @@ BUILD_WRKSRC= ${WRKSRC}/PluginSDK30b5/examples/UnixTemplate/Unix
NO_WRKSUBDIR= yes
MAKEFILE= makefile.freebsd
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=dummyflash.so
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+
do-install:
- @${MKDIR} ${PREFIX}/lib/browser_plugins
- ${INSTALL_DATA} ${BUILD_WRKSRC}/dummyflash.so ${PREFIX}/lib/browser_plugins
+ @${MKDIR} ${WEBPLUGINS_DIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/dummyflash.so ${WEBPLUGINS_DIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>