aboutsummaryrefslogtreecommitdiff
path: root/www/eaccelerator
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-04 09:49:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-04 09:49:28 +0000
commit2556f07444b36c6b516fde6a2791f97710e4409d (patch)
tree698ade58d74e8cdc13ecab4b936375aaca314f3b /www/eaccelerator
parent8a7e55fc12f7cf69f7db69edb89a6f15403fa936 (diff)
downloadports-2556f07444b36c6b516fde6a2791f97710e4409d.tar.gz
ports-2556f07444b36c6b516fde6a2791f97710e4409d.zip
Notes
Diffstat (limited to 'www/eaccelerator')
-rw-r--r--www/eaccelerator/Makefile68
-rw-r--r--www/eaccelerator/distinfo1
-rw-r--r--www/eaccelerator/pkg-descr11
-rw-r--r--www/eaccelerator/pkg-message17
-rw-r--r--www/eaccelerator/pkg-plist4
5 files changed, 101 insertions, 0 deletions
diff --git a/www/eaccelerator/Makefile b/www/eaccelerator/Makefile
new file mode 100644
index 000000000000..4ef1a6951586
--- /dev/null
+++ b/www/eaccelerator/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: turck-mmcache
+# Date created: Sat Mar 1 13:55:55 CET 2003
+# Whom: Alex Dupre <sysadmin@alexdupre.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= turck-mmcache
+PORTVERSION= 2.3.8
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sysadmin@alexdupre.com
+COMMENT= An opcode cache for PHP
+
+BUILD_DEPENDS= phpize:${PORTSDIR}/www/mod_php4
+LIB_DEPENDS= mm.12:${PORTSDIR}/devel/mm
+RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${APACHE_PORT} \
+ ${LOCALBASE}/bin/php:${PORTSDIR}/www/mod_php4
+
+USE_LIBTOOL= yes
+WANT_AUTOMAKE_VER= 15
+WANT_AUTOCONF_VER= 253
+
+CONFIGURE_ARGS= --enable-mmcache=shared \
+ --with-php-config=${LOCALBASE}/bin/php-config \
+ --prefix=${PREFIX}
+
+EXT_DIR= 20020429
+PLIST_SUB= EXT_DIR=${EXT_DIR}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_APACHE2) || exists(${LOCALBASE}/include/apache2/apr.h)
+APACHE_PORT?= ${PORTSDIR}/www/apache2
+.else
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+.endif
+
+post-extract:
+ @${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/phpize
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/configure
+
+post-build:
+ @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%EXT_DIR%%|${EXT_DIR}|g" \
+ ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/php/${EXT_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/modules/mmcache.so \
+ ${PREFIX}/lib/php/${EXT_DIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/eaccelerator/distinfo b/www/eaccelerator/distinfo
new file mode 100644
index 000000000000..765a015aef41
--- /dev/null
+++ b/www/eaccelerator/distinfo
@@ -0,0 +1 @@
+MD5 (turck-mmcache-2.3.8.tar.gz) = 01e7b64dcb32f765dfd518486a1b9d38
diff --git a/www/eaccelerator/pkg-descr b/www/eaccelerator/pkg-descr
new file mode 100644
index 000000000000..6618fbcb7a30
--- /dev/null
+++ b/www/eaccelerator/pkg-descr
@@ -0,0 +1,11 @@
+Turck MMCache is a opcode cache for PHP. It increases
+performance of PHP scripts by caching them in compiled state,
+so that the overhead of compiling is almost completely eliminated.
+Also it uses some optimizations for speed up of PHP scripts execution.
+Turck MMCache typically reduces server load and increases
+the speed of your PHP code by 1-10 times.
+
+WWW: http://www.turcksoft.com/en/e_mmc.htm
+
+- Alex Dupre
+sysadmin@alexdupre.com
diff --git a/www/eaccelerator/pkg-message b/www/eaccelerator/pkg-message
new file mode 100644
index 000000000000..3bfb80a63d30
--- /dev/null
+++ b/www/eaccelerator/pkg-message
@@ -0,0 +1,17 @@
+*****************************************************************************
+
+You have installed the turck-mmcache package.
+
+Edit %%LOCALBASE%%/etc/php.ini and add:
+
+[mmcache]
+zend_extension="%%PREFIX%%/lib/php/%%EXT_DIR%%/mmcache.so"
+mmcache.shm_size="16"
+mmcache.cache_dir="/tmp"
+mmcache.enable="1"
+mmcache.optimizer="1"
+mmcache.check_mtime="1"
+mmcache.debug="0"
+mmcache.filter=""
+
+*****************************************************************************
diff --git a/www/eaccelerator/pkg-plist b/www/eaccelerator/pkg-plist
new file mode 100644
index 000000000000..9c691ea755ae
--- /dev/null
+++ b/www/eaccelerator/pkg-plist
@@ -0,0 +1,4 @@
+lib/php/%%EXT_DIR%%/mmcache.so
+%%PORTDOCS%%share/doc/turck-mmcache/README
+@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
+%%PORTDOCS%%@dirrm share/doc/turck-mmcache